felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Savage (JIRA)" <j...@apache.org>
Subject [jira] Updated: (FELIX-1395) Failure to resolve required bundle when available version has qualifier
Date Tue, 21 Jul 2009 20:38:14 GMT

     [ https://issues.apache.org/jira/browse/FELIX-1395?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

David Savage updated FELIX-1395:
--------------------------------

    Attachment: sigil-parser-patch.txt

the following patch seems to fix things, but not sure if this has other unintended consequences

> Failure to resolve required bundle when available version has qualifier
> -----------------------------------------------------------------------
>
>                 Key: FELIX-1395
>                 URL: https://issues.apache.org/jira/browse/FELIX-1395
>             Project: Felix
>          Issue Type: Bug
>          Components: Sigil
>            Reporter: David Savage
>         Attachments: sigil-parser-patch.txt
>
>
> SigilParser fails to resolve bundles when require bundle specifies an open range and
the bundle that is available has a qualifier e.g. 
> Require-Bundle: org.foo.example;version=1.0.0 
> Bundle-SymbolicName: org.foo.example
> Bundle-Version: 1.0.0.1
> This is because SigilResolver converts the require bundle version into an explicit version
requirement for the purposes of downloading the version that the parse stage discovered (line
246):
> range = "[" + revision + "," + revision + "]";

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message