felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Guillaume Nodet <gno...@gmail.com>
Subject Problem with http service
Date Thu, 18 Jun 2009 16:40:21 GMT
Did I miss something with the HTTP service ?
The headers looks like:

Import-Package =
javax.net.ssl;resolution:=optional,javax.security.cert;resolution:=optional,javax.servlet;version="2.5",javax.servlet.http;version="2.5",javax.xml.parsers;resolution:=optional,org.osgi.framework;version="1.3",org.osgi.service.cm;version="1.2",org.osgi.service.http;version="1.2",org.osgi.service.log;version="1.3",org.osgi.util.tracker;version="1.3",org.slf4j;resolution:=optional,org.xml.sax;resolution:=optional,org.xml.sax.helpers;resolution:=optional

Export-Package =
org.osgi.service.http;uses:="javax.servlet.http,javax.servlet";version="1.1",javax.servlet;version="2.5",javax.servlet.http;uses:="javax.servlet";version="2.5"

which means the http service is exporting the javax.servlet package
with version 1.1 but imports 1.2 ...

Thoughts ?

-- 
Cheers,
Guillaume Nodet
------------------------
Blog: http://gnodet.blogspot.com/
------------------------
Open Source SOA
http://fusesource.com

Mime
View raw message