felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stuart McCulloch <mccu...@gmail.com>
Subject Re: org.osgi.framework.BundleException
Date Sun, 14 Jun 2009 15:49:30 GMT
2009/6/2 Marta Luna Serrano <martalun@gmail.com>

> Hi everyone!!
> I want to start a series of bundles as an applet, I have confirmed that the
> manifest file is OK, I have checked also that the number of bundles'
> version
> is the same on all the manifest files I have.
> This is my manifest file of my branding bundle:
> Bundle-Activator:
> net.java.sip.communicator.plugin.branding.BrandingActivator
> Bundle-Name: Branding plugin
> Bundle-Description: Branding plugin.
> Bundle-Vendor: sip-communicator.org
> Bundle-Version: 1.0
> Import-Package: org.osgi.framework,
>  net.java.sip.communicator.service.browserlauncher,
>  net.java.sip.communicator.service.gui,
>  net.java.sip.communicator.service.gui.event,
>  net.java.sip.communicator.util,
>  javax.swing,
>  javax.swing.event,
>  javax.swing.border,
>  javax.swing.text,
>  javax.swing.text.html,
>  javax.imageio,
> And this is what I have in the Java Console:
> Welcome to Felix.
> =================
> ERROR: Error starting
> file:/C:/eclipse/Workspace/SIPCommApplet/sc-bundles/branding.jar
> (org.osgi.framework.BundleException: Unresolved package in bundle 26:
> package;
> (&(package=org.jdesktop.jdic.desktopnet.java.sip.communicator.service.applet)(version>=0.0.0)))
> org.osgi.framework.BundleException: Unresolved package in bundle 26:
> package;
> (&(package=org.jdesktop.jdic.desktopnet.java.sip.communicator.service.applet)(version>=0.0.0))
>    at org.apache.felix.framework.Felix._resolveBundle(Felix.java:1650)
>    at org.apache.felix.framework.Felix._startBundle(Felix.java:1517)
>    at org.apache.felix.framework.Felix.startBundle(Felix.java:1470)
>    at
> org.apache.felix.framework.Felix.setFrameworkStartLevel(Felix.java:1065)
>    at
> org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:258)
>    at java.lang.Thread.run(Unknown Source)
> And I have the same error in notification.jar, swing-ui.jar, systray.jar,
> whiteboard.jar and extendedcallhistorysearch.jar.
> Any idea??

well the framework is trying to resolve bundle 26 which says it needs the
following package:


but no-one else is exporting this package, so therefore it cannot resolve
bundle 26

have you tried using the following command:

   "headers 26"

to print out the manifest of bundle 26 as seen by the framework - I find
this is the most
accurate way to check the manifest after parsing, etc. - if bundle 26 says
it needs this
package and no-one exports it then this is the expected behaviour

btw, if you're repeatedly installing and testing bundles you might want to
clear out the
framework cache (default location is "felix-cache/" in the current working
between runs otherwise the framework will attempt to start your old cached

so if you have old bundles in the cache with bad metadata then you can get
an error
repeat whenever you install new bundles, as the framework may attempt to
the old bundle (so the error wrt. bundle 26 could pop up again and again
until you
uninstall it from the framework or just clear the whole cache)


Thanks in advanced!!
> Regards

Cheers, Stuart

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message