felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Richard S. Hall (JIRA)" <j...@apache.org>
Subject [jira] Closed: (FELIX-28) Implement require-bundle functionality
Date Tue, 16 Jun 2009 20:43:07 GMT

     [ https://issues.apache.org/jira/browse/FELIX-28?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Richard S. Hall closed FELIX-28.
--------------------------------

    Resolution: Fixed

I am closing this as fixed, since we've had require-bundle functionality for a while now.
I think there may be some aspect not yet implemented (e.g., optionality), but we can open
separate issues for those.

> Implement require-bundle functionality
> --------------------------------------
>
>                 Key: FELIX-28
>                 URL: https://issues.apache.org/jira/browse/FELIX-28
>             Project: Felix
>          Issue Type: New Feature
>          Components: Framework, Specification compliance
>    Affects Versions: felix-0.8.0
>            Reporter: Richard S. Hall
>            Assignee: Richard S. Hall
>
> This issue is described in section 3.13 of the OSGi R4 specification. The main jist is
that bundles can now express explicit dependencies on other named bundles. This means that
the depending bundle imports everything that the target bundle exports. It is also possible
to re-export imported packages. This issue impacts the resolver algorithm and will likely
have some impacts on the run-time class loading search order.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message