felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alin Dreghiciu <adreghi...@gmail.com>
Subject Re: Unable to deploy File Install snapshot
Date Thu, 28 May 2009 21:56:57 GMT
Not an expert in Felix setup but fileinstall has as parent:
<groupId>org.apache.felix</groupId>
<artifactId>felix-parent</artifactId>
 <version>1.2.0</version>
while shell has:
    <groupId>org.apache.felix</groupId>
    <artifactId>felix</artifactId>
    <version>1.0.4</version>

As I recall 1.20 of parent pom uses the new nexus based repository so you
may have to add some credentials  to your settings.xml.
Looking here: http://tinyurl.com/mq2dab it also suggest that when you get a
401 you have an settings.xml problem.

Just my 2c,

On Thu, May 28, 2009 at 11:03 PM, Richard S. Hall <heavy@ungoverned.org>wrote:

> When I try to "mvn clean deploy" File Install, I get the following error:
>
> [INFO] Error deploying artifact: Failed to transfer file:
> https://repository.apache.org/content/repositories/snapshots/org/apache/felix/org.apache.felix.fileinstall/1.1.0-SNAPSHOT/org.apache.felix.fileinstall-1.1.0-20090528.200135-1.jar.
> Return code is: 401
>
> Anyone know what is going on? I was able to successfully deploy a shell
> bundle snapshot just now...
>
> -> richard
>



-- 
Alin Dreghiciu
Software Developer - Looking for new projects!
My profile: http://www.linkedin.com/in/alindreghiciu
My blog: http://adreghiciu.blogspot.com
http://www.ops4j.org - New Energy for OSS Communities - Open Participation
Software.
http://www.qi4j.org - New Energy for Java - Domain Driven Development.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message