felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stuart McCulloch (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (FELIX-1167) Incorrect import and and export versions created for -SNAPSHOT versions
Date Thu, 21 May 2009 06:38:45 GMT

     [ https://issues.apache.org/jira/browse/FELIX-1167?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Stuart McCulloch resolved FELIX-1167.
-------------------------------------

    Resolution: Invalid

Working as designed

> Incorrect import and and export versions created for -SNAPSHOT versions
> -----------------------------------------------------------------------
>
>                 Key: FELIX-1167
>                 URL: https://issues.apache.org/jira/browse/FELIX-1167
>             Project: Felix
>          Issue Type: Bug
>          Components: Maven Bundle Plugin
>    Affects Versions: maven-bundle-plugin-1.4.3, maven-bundle-plugin-2.0.0
>         Environment: Maven 2.1.0
> WinXP
> Maven-bundle-plugin 1.4.3 and 2.0.0
>            Reporter: Sebb
>
> The bundle plugin mangles the version details if there is a text suffix, e.g. 3.3-SNAPSHOT
> The version appears as follows in 1.4.3 and 2.0.0
> Bundle-Version: 3.3.0.SNAPSHOT and
> version="3.3.0.SNAPSHOT" (ExportPackage)
> This is using the following settings:
> <Export-Package>org.apache.commons.*;version=${pom.version}</Export-Package>
> <Import-Package>*</Import-Package>
> In version 1.4.3, the ImportPackages have:
> "3.3.0.SNAPSHOT"
> whereas in 2.0.0, the ImportPackages have:
> version="3.3"
> If the pom.version=3.3.1-SNAPSHOT then the BundleVersion and ExportVersion are both OK.
> However, in 2.0.0, the ImportPackage versions are still "3.3".

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message