felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Felix Meschberger (JIRA)" <j...@apache.org>
Subject [jira] Commented: (FELIX-1165) When restarting a bundle, the config admin reports "Configuration ... has already been delivered", and the bundle receives no configuration.
Date Tue, 19 May 2009 18:58:45 GMT

    [ https://issues.apache.org/jira/browse/FELIX-1165?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12710833#action_12710833
] 

Felix Meschberger commented on FELIX-1165:
------------------------------------------

Can you attach the source of your sample bundles to this issue, please ? Thanks.

The problem might be a subtle bug in your configurator bundle: This should use the ConfigurationAdmin.getConfiguration(String
pid, String location) method and either set the location parameter to the actual bundle location
of the configurable bundle or -- better yet, IMHO -- to null to not create a bound configuration
at all.

> When restarting a bundle, the config admin reports "Configuration ... has already been
delivered", and the bundle receives no configuration.
> --------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: FELIX-1165
>                 URL: https://issues.apache.org/jira/browse/FELIX-1165
>             Project: Felix
>          Issue Type: Bug
>          Components: Configuration Admin
>    Affects Versions: configadmin-1.0.1, configadmin-1.0.4, configadmin-1.0.8, configadmin-1.0.10
>         Environment: Windows XP, JDK 1.6.0_10, Felix 1.8.0, configadmin 1.0.10
>            Reporter: James Hanson
>            Priority: Minor
>
> When restarting a bundle, the configuration admin reports "Configuration ... has already
been delivered", and the bundle receives no configuration.
> As far as I can tell this only occurs if a bundle is installed and started by the felix.auto.start.1
property in the config.properties.  If Felix is restarted and the bundle is loaded from the
cache, the problem disappears.
> Test setup:
> Create a "configurable" bundle, implement ManagedService and register as a ManagedService
with a PID from the BundleActivator start() method.
> Create a "configurator" bundle and send a configuration to the PID.
> Extract Felix and add the Felix config admin bundle to the felix.auto.start.1 property
in conf/config.properties
> Add the two new bundles to the felix.auto.start.1 property.
> Start Felix.
> Stop the "configurable" bundle, and start it again.
> * If the configuration is sent from the "configurator", the bundle receives it.
> * If felix is restarted, the problem disappears unless the felix-cache is deleted.
> This can be reproduced with felix 1.8.0 using the example at:
> http://www.dynamicjava.org/articles/osgi-compendium/configuration-admin-service
> See also bug FELIX-516.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message