felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stuart McCulloch (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (FELIX-546) Import-Package version inconsistencies.
Date Thu, 29 Jan 2009 17:37:00 GMT

     [ https://issues.apache.org/jira/browse/FELIX-546?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Stuart McCulloch resolved FELIX-546.
------------------------------------

    Resolution: Fixed

Ran bugtest2 against trunk and it now works as expected, will deploy a new 1.5.0-SNAPSHOT
for testing tomorrow morning (8hrs from now).

For anyone else running this test, note there is a small typo in the third example:

   "[${bugtest1.version},${bugtest1..version}]"

should be:

   "[${bugtest1.version},${bugtest1.version}]"


> Import-Package version inconsistencies.
> ---------------------------------------
>
>                 Key: FELIX-546
>                 URL: https://issues.apache.org/jira/browse/FELIX-546
>             Project: Felix
>          Issue Type: Bug
>          Components: Maven Bundle Plugin
>    Affects Versions: maven-bundle-plugin-1.4.0
>         Environment: N/A
>            Reporter: Thomas Dewire
>            Assignee: Stuart McCulloch
>            Priority: Minor
>             Fix For: maven-bundle-plugin-1.6.0
>
>         Attachments: bugtest.tar.gz
>
>
> There is an inconsistency in how versions are handled in Import-Package statements.
> Style 1: <Import-Package>com.ea.bugtest1;version=1.0.0-SNAPSHOT</Import-Package>
> ...produces...
>  Import-Package: com.ea.bugtest1;version="1.0.0.SNAPSHOT"
> Style 2: <Import-Package>com.ea.bugtest1;version="1.0.0-SNAPSHOT"</Import-Package>
> ...produces...
> Import-Package: com.ea.bugtest1;version="1.0.0.SNAPSHOT"
> Style 3: <Import-Package>com.ea.bugtest1;version="[1.0.0-SNAPSHOT,1.0.0-SNAPSHOT]"</Import-Package>
> ...produces...
> Import-Package: com.ea.bugtest1;version="[1.0.0-SNAPSHOT,1.0.0-SNAPSHOT]"
> Note that the 1.0.0-SNAPSHOT has not been converted to 1.0.0.SNAPSHOT. Also, this form
breaks the OBR pieces of the plugin. The OBR repository must be set to NONE for this to work
at all. I'll file a separate bug on this issue
> I realize that having 1.0.0-SNAPSHOT in the import statment isn't exactly ideal, but
it is coming in through a maven property. We're trying to find a way to maintain some consistency
between our declared maven dependencies and our import-package statements by sharing a single
property value.
> I will attach a small demo project that will allow you to easily demonstrate the issue.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message