felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Richard S. Hall" <he...@ungoverned.org>
Subject Re: Problems compiling/running Felix trunk
Date Tue, 18 Nov 2008 14:47:35 GMT
Thanks. Will check it out.

-> richard

David Bosschaert wrote:
> Hi Richard,
>
> I can confirm that the trunk compiles from me too again. When looking
> at my .m2 I did notice that org.osgi.core version 1.1.0-SNAPSHOT was
> pulled in from somewhere. Apparently it wasn't available last weekend
> or something.
>
> I guess it would still be better to update this dependency to
> 1.3.0-SNAPSHOT since 1.1.0-SNAPSHOT is not built by trunk. I've
> attached the patch to bug
> https://issues.apache.org/jira/browse/FELIX-821 in case you want to
> have a look.
>
> Cheers,
>
> David
>
> 2008/11/17 Richard S. Hall <heavy@ungoverned.org>:
>   
>> David,
>>
>> I just removed my maven repo and built from scratch and everything built
>> fine for me. Your original patched POM files was stripped from your message,
>> do you remember which components were causing issues for you?
>>
>> -> richard
>>
>>
>> Richard S. Hall wrote:
>>     
>>> I think I see the problem for the error below, I forgot a comma in the
>>> default.properties file. I just committed that, so it should be fixed.
>>>
>>> As far as the 1.1.0-SNAPSHOT dependencies, I would assume those were
>>> missed dependencies after the release, but the strange thing is that we
>>> didn't release those, so I doesn't seem that the version should have
>>> changed.
>>>
>>> I have to run, but perhaps Karl will take a look or else I will when I
>>> return.
>>>
>>> -> richard
>>>
>>>
>>> David Bosschaert wrote:
>>>       
>>>> Hi all,
>>>>
>>>> When trying to compile the Felix trunk this morning my compilation
>>>> failed because a number of components still depend on org.osgi.core
>>>> version 1.1.0-SNAPSHOT. This is funny because it didn't happen to me
>>>> last week.
>>>> Anyway, I fixed my compilation by moving the dependency to
>>>> 1.3.0-SNAPSHOT which is the version of org.osgi.core that is currently
>>>> on trunk.
>>>>
>>>> I've attached the changes to the poms I made to this mail. However, if
>>>> I now start up Felix, I get the following error:
>>>>
>>>> Anyone an idea?
>>>>
>>>> Thanks!
>>>>
>>>> David
>>>>
>>>> F:\main>java -jar bin\felix.jar a9
>>>>
>>>> Welcome to Felix.
>>>> =================
>>>>
>>>> ERROR: Error parsing system bundle export statement: org.osgi.framework;
>>>> version
>>>> =1.4.0, org.osgi.framework.hooks.service; version=1.4.0
>>>> org.osgi.service.package
>>>> admin; version=1.2.0, org.osgi.service.startlevel; version=1.1.0,
>>>> org.osgi.servi
>>>> ce.url; version=1.0.0, org.osgi.util.tracker; version=1.3.3 ,
>>>> javax.accessibilit
>>>> y; javax.activity; javax.crypto; javax.crypto.interfaces;
>>>> javax.crypto.spec; jav
>>>> ax.imageio; javax.imageio.event; javax.imageio.metadata;
>>>> javax.imageio.plugins.b
>>>> mp; javax.imageio.plugins.jpeg; javax.imageio.spi; javax.imageio.stream;
>>>> javax.m
>>>> anagement; javax.management.loading; javax.management.modelmbean;
>>>> javax.manageme
>>>> nt.monitor; javax.management.openmbean; javax.management.relation;
>>>> javax.managem
>>>> ent.remote; javax.management.remote.rmi; javax.management.timer;
>>>> javax.naming; j
>>>> avax.naming.directory; javax.naming.event; javax.naming.ldap;
>>>> javax.naming.spi;
>>>> javax.net; javax.net.ssl; javax.print; javax.print.attribute;
>>>> javax.print.attrib
>>>> ute.standard; javax.print.event; javax.rmi; javax.rmi.CORBA;
>>>> javax.rmi.ssl; java
>>>> x.security.auth; javax.security.auth.callback;
>>>> javax.security.auth.kerberos; jav
>>>> ax.security.auth.login; javax.security.auth.spi;
>>>> javax.security.auth.x500; javax
>>>> .security.sasl; javax.sound.midi; javax.sound.midi.spi;
>>>> javax.sound.sampled; jav
>>>> ax.sound.sampled.spi; javax.sql; javax.sql.rowset;
>>>> javax.sql.rowset.serial; java
>>>> x.sql.rowset.spi; javax.swing; javax.swing.border;
>>>> javax.swing.colorchooser; jav
>>>> ax.swing.event; javax.swing.filechooser; javax.swing.plaf;
>>>> javax.swing.plaf.basi
>>>> c; javax.swing.plaf.metal; javax.swing.plaf.multi;
>>>> javax.swing.plaf.synth; javax
>>>> .swing.table; javax.swing.text; javax.swing.text.html;
>>>> javax.swing.text.html.par
>>>> ser; javax.swing.text.rtf; javax.swing.tree; javax.swing.undo;
>>>> javax.transaction
>>>> ; javax.transaction.xa; javax.xml; javax.xml.datatype;
>>>> javax.xml.namespace; java
>>>> x.xml.parsers; javax.xml.transform; javax.xml.transform.dom;
>>>> javax.xml.transform
>>>> .sax; javax.xml.transform.stream; javax.xml.validation; javax.xml.xpath;
>>>> org.iet
>>>> f.jgss; org.omg.CORBA; org.omg.CORBA_2_3; org.omg.CORBA_2_3.portable;
>>>> org.omg.CO
>>>> RBA.DynAnyPackage; org.omg.CORBA.ORBPackage; org.omg.CORBA.portable;
>>>> org.omg.COR
>>>> BA.TypeCodePackage; org.omg.CosNaming;
>>>> org.omg.CosNaming.NamingContextExtPackage
>>>> ; org.omg.CosNaming.NamingContextPackage; org.omg.Dynamic;
>>>> org.omg.DynamicAny; o
>>>> rg.omg.DynamicAny.DynAnyFactoryPackage; org.omg.DynamicAny.DynAnyPackage;
>>>> org.om
>>>> g.IOP; org.omg.IOP.CodecFactoryPackage; org.omg.IOP.CodecPackage;
>>>> org.omg.Messag
>>>> ing; org.omg.PortableInterceptor;
>>>> org.omg.PortableInterceptor.ORBInitInfoPackage
>>>> ; org.omg.PortableServer; org.omg.PortableServer.CurrentPackage;
>>>> org.omg.Portabl
>>>> eServer.POAManagerPackage; org.omg.PortableServer.POAPackage;
>>>> org.omg.PortableSe
>>>> rver.portable; org.omg.PortableServer.ServantLocatorPackage;
>>>> org.omg.SendingCont
>>>> ext; org.omg.stub.java.rmi; org.omg.stub.javax.management.remote.rmi;
>>>> org.w3c.do
>>>> m; org.w3c.dom.bootstrap; org.w3c.dom.css; org.w3c.dom.events;
>>>> org.w3c.dom.html;
>>>>  org.w3c.dom.ls; org.w3c.dom.ranges; org.w3c.dom.stylesheets;
>>>> org.w3c.dom.traver
>>>> sal; org.w3c.dom.views; org.xml.sax; org.xml.sax.ext;
>>>> org.xml.sax.helpers; versi
>>>> on="1.5.0" (java.lang.IllegalArgumentException: Duplicate attribute:
>>>> version)
>>>> java.lang.IllegalArgumentException: Duplicate attribute: version
>>>>        at
>>>> org.apache.felix.framework.util.manifestparser.ManifestParser.parseSt
>>>> andardHeaderClause(ManifestParser.java:1220)
>>>>        at
>>>> org.apache.felix.framework.util.manifestparser.ManifestParser.parseSt
>>>> andardHeader(ManifestParser.java:1131)
>>>>        at
>>>> org.apache.felix.framework.util.manifestparser.ManifestParser.parseEx
>>>> portHeader(ManifestParser.java:847)
>>>>        at
>>>> org.apache.felix.framework.ExtensionManager.<init>(ExtensionManager.j
>>>> ava:180)
>>>>        at org.apache.felix.framework.Felix.<init>(Felix.java:352)
>>>>        at org.apache.felix.main.Main.main(Main.java:212)
>>>> ERROR: Error starting
>>>> file:bundle/org.apache.felix.shell-1.1.0-SNAPSHOT.jar (org
>>>> .osgi.framework.BundleException: Unresolved constraint in bundle 1:
>>>> package; (&(
>>>> package=org.osgi.service.packageadmin)(version>=1.2.0)))
>>>> org.osgi.framework.BundleException: Unresolved constraint in bundle 1:
>>>> package;
>>>> (&(package=org.osgi.service.packageadmin)(version>=1.2.0))
>>>>        at
>>>> org.apache.felix.framework.Felix._resolveBundle(Felix.java:1776)
>>>>        at org.apache.felix.framework.Felix._startBundle(Felix.java:1636)
>>>>        at org.apache.felix.framework.Felix.startBundle(Felix.java:1579)
>>>>        at
>>>> org.apache.felix.framework.Felix.setFrameworkStartLevel(Felix.java:11
>>>> 73)
>>>>        at
>>>> org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:265
>>>> )
>>>>        at java.lang.Thread.run(Thread.java:595)
>>>> ERROR: Error starting
>>>> file:bundle/org.apache.felix.shell.tui-1.1.0-SNAPSHOT.jar
>>>> (org.osgi.framework.BundleException: Unresolved constraint in bundle 2:
>>>> package;
>>>>  (&(package=org.osgi.framework)(version>=1.4.0)))
>>>> org.osgi.framework.BundleException: Unresolved constraint in bundle 2:
>>>> package;
>>>> (&(package=org.osgi.framework)(version>=1.4.0))
>>>>        at
>>>> org.apache.felix.framework.Felix._resolveBundle(Felix.java:1776)
>>>>        at org.apache.felix.framework.Felix._startBundle(Felix.java:1636)
>>>>        at org.apache.felix.framework.Felix.startBundle(Felix.java:1579)
>>>>        at
>>>> org.apache.felix.framework.Felix.setFrameworkStartLevel(Felix.java:11
>>>> 73)
>>>>        at
>>>> org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:265
>>>> )
>>>>        at java.lang.Thread.run(Thread.java:595)
>>>> ERROR: Error starting
>>>> file:bundle/org.apache.felix.bundlerepository-1.3.0-SNAPSH
>>>> OT.jar (org.osgi.framework.BundleException: Unresolved constraint in
>>>> bundle 3: p
>>>> ackage; (&(package=org.osgi.framework)(version>=1.3.0)))
>>>> org.osgi.framework.BundleException: Unresolved constraint in bundle 3:
>>>> package;
>>>> (&(package=org.osgi.framework)(version>=1.3.0))
>>>>        at
>>>> org.apache.felix.framework.Felix._resolveBundle(Felix.java:1776)
>>>>        at org.apache.felix.framework.Felix._startBundle(Felix.java:1636)
>>>>        at org.apache.felix.framework.Felix.startBundle(Felix.java:1579)
>>>>        at
>>>> org.apache.felix.framework.Felix.setFrameworkStartLevel(Felix.java:11
>>>> 73)
>>>>        at
>>>> org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:265
>>>> )
>>>>        at java.lang.Thread.run(Thread.java:595)
>>>>
>>>>         

Mime
View raw message