felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Rubio (OSGI Mailing List)" <o...@webforefront.com>
Subject Fragment support 1.0.4 to 1.2 doesn't Import classes
Date Thu, 11 Sep 2008 19:26:39 GMT
I just upgraded to Felix 1.2+ from 1.0.4, only to realize some of my 
(library) bundles are fragments.

I'm getting a warning that in 1.2 there is partial support for 
fragments, which I of course appreciate. However, the application now 
ceases to work since it apparently doesn't import any classes in the 
fragment....
 Is there some way to get things to work as in 1.0.4 and get the warning ?
 I realize full support for fragments may be well down the road, but is 
there any plan for a release like 1.0.4 (import class from the fragment 
) and getting a warning ?

Thanks for any information on the subject.
Daniel Rubio
P.S- I realize the simple answer is keep using 1.0.4, but the reason for 
my question is because I'm in the process of writing a book (for Apress 
on Spring-OSGi) which is using Apache Felix, and some things are already 
based on the v.1.0.4 and the upgrade to the newer v.1.2 breaks a few of 
the apps.


Mime
View raw message