felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alan D. Cabrera" <l...@toolazydogs.com>
Subject Maven bundle plugin and Export
Date Mon, 18 Aug 2008 17:22:10 GMT
I have the following in my POM

             <plugin>
                 <groupId>org.apache.felix</groupId>
                 <artifactId>maven-bundle-plugin</artifactId>
                 <version>1.4.3</version>
                 <extensions>true</extensions>
                 <configuration>
                     <instructions>
                         <Export-Package>
                             org.livetribe.slp.osgi,
                             org.livetribe.slp,
                             org.livetribe.slp.da,
                             org.livetribe.slp.sa,
                             org.livetribe.slp.settings,
                             org.livetribe.slp.spi,
                             org.livetribe.slp.spi.da,
                             org.livetribe.slp.spi.filter,
                             org.livetribe.slp.spi.msg,
                             org.livetribe.slp.spi.net,
                             org.livetribe.slp.spi.sa,
                             org.livetribe.slp.spi.ua,
                             org.livetribe.slp.ua,
                             org.livetribe.slp.util,
                             org.livetribe.slp.util.logging
                         </Export-Package>
                         <Bundle-ClassPath>.,lib/slp.jar</Bundle- 
ClassPath>
                         <Bundle- 
RequiredExecutionEnvironment>J2SE-1.5,JavaSE-1.6</Bundle- 
RequiredExecutionEnvironment>
                     </instructions>
                 </configuration>
             </plugin>

and I get this warning

[WARNING] Warning building bundle org.livetribe.slp:livetribe-slp- 
osgi:bundle:2.1.0-SNAPSHOT : Instructions for Export-Package that are  
never used: org\.livetribe\.slp\.spi\.da, org\.livetribe\.slp\.ua, org 
\.livetribe\.slp, org\.livetribe\.slp\.util\.logging, org\.livetribe 
\.slp\.sa, org\.livetribe\.slp\.settings, org\.livetribe\.slp\.spi 
\.net, org\.livetribe\.slp\.util, org\.livetribe\.slp\.spi, org 
\.livetribe\.slp\.spi\.sa, org\.livetribe\.slp\.spi\.ua, org\.livetribe 
\.slp\.spi\.msg, org\.livetribe\.slp\.da, org\.livetribe\.slp\.spi 
\.filter

The jar file lib/slp.jar has the packages.  What am I doing wrong?


Regards,
Alan


Mime
View raw message