felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John Stalker (JIRA)" <j...@apache.org>
Subject [jira] Updated: (FELIX-616) upnp tester pom.xml depends on upnp base driver version 0.3.0 when it should be 0.9.0
Date Sun, 29 Jun 2008 13:03:45 GMT

     [ https://issues.apache.org/jira/browse/FELIX-616?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

John Stalker updated FELIX-616:
-------------------------------

    Attachment: upnp_dep.patch

patch file for upnp/tester/pom.xml

> upnp tester pom.xml depends on upnp base driver version 0.3.0 when it should be 0.9.0

> --------------------------------------------------------------------------------------
>
>                 Key: FELIX-616
>                 URL: https://issues.apache.org/jira/browse/FELIX-616
>             Project: Felix
>          Issue Type: Bug
>          Components: UPnP Subproject
>         Environment: OSX 10.5.3, java 1.5.0_13, mvn 2.0.9
>            Reporter: John Stalker
>         Attachments: upnp_dep.patch
>
>   Original Estimate: 0.08h
>  Remaining Estimate: 0.08h
>
> Checked out the felix tree (svn revision 672620) for the very first time (thus, no installed
artifacts in ~/.m2/repository)
> Followed the build instructions.  Got the following for the upnp tester build:
> [INFO] ------------------------------------------------------------------------
> [INFO] Building Apache Felix UPnP Tester
> [INFO]    task-segment: [install]
> [INFO] ------------------------------------------------------------------------
> [INFO] [resources:resources]
> [INFO] Using default encoding to copy filtered resources.
> [INFO] snapshot org.apache.felix:org.apache.felix.upnp.basedriver:0.3.0-SNAPSHOT: checking
for updates from apache.snapshots
> Downloading: http://people.apache.org/repo/m2-snapshot-repository/org/apache/felix/org.apache.felix.upnp.basedriver/0.3.0-SNAPSHOT/org.apache.felix.upnp.basedriver-0.3.0-SNAPSHOT.pom
> Downloading: http://people.apache.org/repo/m2-snapshot-repository/org/apache/felix/org.apache.felix.upnp.basedriver/0.3.0-SNAPSHOT/org.apache.felix.upnp.basedriver-0.3.0-SNAPSHOT.jar
> [INFO] ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO] ------------------------------------------------------------------------
> [INFO] Failed to resolve artifact.
> Missing:
> ----------
> 1) org.apache.felix:org.apache.felix.upnp.basedriver:jar:0.3.0-SNAPSHOT
>   Try downloading the file manually from the project website.
>   Then, install it using the command: 
>       mvn install:install-file -DgroupId=org.apache.felix -DartifactId=org.apache.felix.upnp.basedriver
-Dversion=0.3.0-SNAPSHOT -Dpackaging=jar -Dfile=/path/to/file
>   Alternatively, if you host your own repository you can deploy the file there: 
>       mvn deploy:deploy-file -DgroupId=org.apache.felix -DartifactId=org.apache.felix.upnp.basedriver
-Dversion=0.3.0-SNAPSHOT -Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]
>   Path to dependency: 
>   	1) org.apache.felix:org.apache.felix.upnp.tester:bundle:0.2.0-SNAPSHOT
>   	2) org.apache.felix:org.apache.felix.upnp.basedriver:jar:0.3.0-SNAPSHOT
> ----------
> 1 required artifact is missing.
> for artifact: 
>   org.apache.felix:org.apache.felix.upnp.tester:bundle:0.2.0-SNAPSHOT
> from the specified remote repositories:
>   central (http://repo1.maven.org/maven2),
>   apache.snapshots (http://people.apache.org/repo/m2-snapshot-repository)
> Changed the pom.xml so that it points at 0.9.0-SNAPSHOT (instead of 0.3.0-SNAPSHOT) and
it builds fine.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message