felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Felix Meschberger <fmesc...@gmail.com>
Subject Re: Telnet bundle
Date Tue, 24 Jun 2008 06:50:24 GMT
Hi,

Richard S. Hall schrieb:
> Dieter Wimberger wrote:
>> The language level I currently use is Java 1.3. In comparison to the 
>> older codebase, it may not run on very small embedded systems that are 
>> often Java 1 (if at all).
>>
>> I took this decision, because I needed SSH and the library I found 
>> (latest version is released under MIT license; 
>> http://www.lag.net/paramiko/java) needs 1.3.
> 
> I would think that Java 1.3 would be fine as far as I am concerned. Others?
> 
>> I guess it would be possible to get some things that are overhead out 
>> of the codebase and add them as extensions (e.g. Templates based on 
>> antlr and stringtemplates, Beanshell based shell, text editors etc.). 
>> It all depends on the requirements and the functionality you would 
>> like to see.
> 
> Well, from my point of view, I don't think we need to target less than 
> Java 1.3, but we can see what others think.

I also think 1.3 is reasonable.

Regards
Felix

Mime
View raw message