felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stuart McCulloch (JIRA)" <j...@apache.org>
Subject [jira] Assigned: (FELIX-547) OBR portion of the plugin balks on singular version range of [1.0.0,1.0.0].
Date Tue, 06 May 2008 16:02:57 GMT

     [ https://issues.apache.org/jira/browse/FELIX-547?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Stuart McCulloch reassigned FELIX-547:
--------------------------------------

    Assignee: Stuart McCulloch

> OBR portion of the plugin balks on singular version range of [1.0.0,1.0.0].
> ---------------------------------------------------------------------------
>
>                 Key: FELIX-547
>                 URL: https://issues.apache.org/jira/browse/FELIX-547
>             Project: Felix
>          Issue Type: Bug
>          Components: Maven Bundle Plugin
>    Affects Versions: maven-bundle-plugin-1.4.0
>         Environment: N/A
>            Reporter: Thomas Dewire
>            Assignee: Stuart McCulloch
>             Fix For: maven-bundle-plugin-1.4.2
>
>
> The OBR portion of the maven-bundle-plugin does not want to allow the syntax:
> <Import-Package>com.ea.bugtest1;version="[1.0.0,1.0.0]"</Import-Package>
> It complains with the following message:
> java.lang.IllegalArgumentException: Low Range is higher than High Range: 1.0.0-1.0.0
> ...although this appears to be a legal construct that will in fact load up in Equinox.
(Would it do the same in Felix?)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message