felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Richard S. Hall" <he...@ungoverned.org>
Subject Re: Felix hangs when loading org.apache.felix.log and org.apache.felix.eventadmin bundles
Date Thu, 17 Apr 2008 13:31:55 GMT
Tim Moloney wrote:
> Thanks for the info.  Will this be included in the upcoming 1.0.4 
> release?


-> richard

> Tim
> Richard S. Hall wrote:
>> In the trunk we have modified the framework so that it no longer 
>> tries to log to an available LogService for the time being, so this 
>> issue should be gone. When we have the time, we will try to reinstate 
>> the feature if we can find a suitable workaround.
>> -> richard
>> Tim Moloney wrote:
>>> Thanks for the pointer.
>>> It does appear to be the same problem as discussed here 
>>> (http://www.mail-archive.com/dev@felix.apache.org/msg03142.html).  
>>> The workaround of setting felix.log.level 3 (INFO) gets things 
>>> working more reliably.
>>> In the message thread, Niclas Hedhman wondered if there are any 
>>> other log services that experience this problem.  
>>> org.apache.felix.log appears to.
>>> Tim
>>> Richard S. Hall wrote:
>>>> I would guess this is related to a deadlocking issue that was 
>>>> discussed previously.
>>>> The issue is that Felix uses the external log service (if present) 
>>>> to log events and sometimes this can lead to deadlocks, apparently. 
>>>> Of course, this is just a guess on my part. I think there was a 
>>>> workaround...you can check the archives...or perhaps someone else 
>>>> can respond.
>>>> This issue will likely need further investigation.
>>>> -> richard
>>>> Tim Moloney wrote:
>>>>> I run Felix in Eclipse with a custom config.properties file that 
>>>>> autostarts a few bundles.  If I include both org.apache.felix.log 
>>>>> and org.apache.felix.eventadmin in felix.auto.start.1, Felix 
>>>>> hangs.  If I remove either org.apache.felix.log or 
>>>>> org.apache.felix.eventadmin or both, everything works fine.
>>>>> I've attached an example project that has an Activator class that 
>>>>> simply prints when its bundle is started and stopped.  If I 
>>>>> autostart both org.apache.felix.log and 
>>>>> org.apache.felix.eventadmin, the example bundle doesn't print its 
>>>>> start message and the shell bundle doesn't display prompts when 
>>>>> hitting <enter>.  Again, i f I remove either org.apache.felix.log

>>>>> or org.apache.felix.eventadmin or both, everything works fine.
>>>>> If I run from the command line, it will work most of the time, 
>>>>> however, it will occasionally fail in the same way.  It appears to 
>>>>> be the same problem but somehow running Felix inside Eclipse 
>>>>> exacerbates the problem.
>>>>> The attached project includes a README file that describes 
>>>>> *exactly* how to demonstrate the problem.
>>>>> Can anyone provide some suggestions to help me get this amazingly 
>>>>> simple task working properly?
>>>>> Thanks,
>>>>>  Tim

View raw message