felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Richard S. Hall" <he...@ungoverned.org>
Subject Re: [jira] Closed: (FELIX-55) Look at migration to more recent Jetty version
Date Fri, 28 Mar 2008 16:32:49 GMT
It appears that this patch has made it not possible to compile the trunk 
using JDK 1.4.x...

-> richard

Felix Meschberger (JIRA) wrote:
>      [ https://issues.apache.org/jira/browse/FELIX-55?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]
>
> Felix Meschberger closed FELIX-55.
> ----------------------------------
>
>     Resolution: Fixed
>
> I finally applied this patch in Rev. 641218.
>
> Now, the bundle incorporates Jetty 6.1.7 and exports Servlet API 2.5, which is provided
by the embedded Jetty container. Additionaly servlet-api bundles are not required any more.
>
> Closing this issue for now.
>
>   
>> Look at migration to more recent Jetty version
>> ----------------------------------------------
>>
>>                 Key: FELIX-55
>>                 URL: https://issues.apache.org/jira/browse/FELIX-55
>>             Project: Felix
>>          Issue Type: Improvement
>>          Components: HTTP Service
>>            Reporter: Rob Walker
>>            Assignee: Felix Meschberger
>>         Attachments: FELIX-55.patch, FELIX-55_jetty6.patch
>>
>>
>> - Look at the issues and effort involved in migrating to a more recent version of
Jetty. Most likely the latest Jetty6 would be considered, since this has architectural changes
over Jetty5 and hence we'd be upgrading to the latest greatest Jetty internals and APIs
>> - Check backwards compatibility against existing (limited) set of cases in test bundle
>> - enlist help from others with bundles using HttpService for more extensive testing
>>     
>
>   

Mime
View raw message