felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stefano Lenzi (JIRA)" <j...@apache.org>
Subject [jira] Commented: (FELIX-486) Felix release conting mixed bytecode: 1.3 and 1.4, we should compile all as 1.3
Date Sun, 17 Feb 2008 18:42:34 GMT

    [ https://issues.apache.org/jira/browse/FELIX-486?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12569739#action_12569739
] 

Stefano Lenzi commented on FELIX-486:
-------------------------------------

So it seems that I can apply the patch #4. 

I don't think that we should change the dependency of other project from org.osgi.core:1.0.0
neither to org.osgi.core:1.1.0-SNAPSHOT or org.osgi.core:1.0.1 because the code is not changed
only the bytecode is. Also each subproject at runtime will use the org.osgi.core provided
by the felix framework which will be the latest. 

I have only a question about the config.properties, is it correct for the main project to
point to SNAPSHOT artifact instead of release one? (At the moment the trunk point to the released
version of the artifact but the patch #4 changes it to the SNAPSHOT version.)



> Felix release conting mixed bytecode: 1.3 and 1.4, we should compile all as 1.3
> -------------------------------------------------------------------------------
>
>                 Key: FELIX-486
>                 URL: https://issues.apache.org/jira/browse/FELIX-486
>             Project: Felix
>          Issue Type: Improvement
>    Affects Versions: 1.0.1, 1.0.2, 1.0.3
>            Reporter: Stefano Lenzi
>            Assignee: Stefano Lenzi
>            Priority: Minor
>         Attachments: bytecode.jre13.r620538.patch, bytecode.jre13.r620865.patch, bytecode.jre13.vs.SNAPSHOT.r620865.patch,
bytecode.jre13.vs.SNAPSHOT.r626008.patch
>
>
> I found out that the following released project:
>  - shell-1.0.0
>  - javax.servlet-1.0.0
>  - org.osgi.core-1.0.0
>  - shell.tui-1.0.0
> which are used by the felix-1.0.3 release are compiled for JRE 1.4, so we ended up with
a felix released which is partially compiled for JRE 1.4 and for JRE 1.3.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message