felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Felix Meschberger <fmesc...@gmail.com>
Subject Look at migration to more recent Jetty version (FELIX-55)
Date Tue, 08 Jan 2008 16:44:08 GMT
Hi all,

I took a stab at migrating the http.jetty bundle to a more recent Jetty
version. For the moment I took Jetty 5.1.12, because it is said to be
supporting back to JDK 1.2 whereas Jetty 6.1 is supported for JDK 1.4
and higher only.

After reading the issue again, I started working on Jetty 6 integration
- it takes some time to grock the details, but I think, I am coming
closer :-)

One point with Jetty 6 is, that it requires Java 1.4 or higher and
Servlet API 2.5. This would of course "disable" support for older VMs.
Of course, this migrated http.jetty bundle would not be working with the
older servlet.api bundle any more.

Richard OTOH seems to be working on a lightweight implementation still
supporting 1.2. So I could imagine, that we could be going forward with
two versions: The most modern Jetty 6 based one and the most-lightweight
one by Richard.

WDYT ?

Regards
Felix

[1] http://issues.apache.org/jira/browse/FELIX-55


Mime
View raw message