felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carsten Ziegeler <cziege...@apache.org>
Subject Javax.servlet Module
Date Mon, 10 Sep 2007 15:38:28 GMT
I'm still wondering if we need our own version of the javax.servlet
implementation. I know that the spec mandates 2.1.

We just ran into compilation problems because of two different
servlet-apis on the classpath. This is due to the problem that our
version uses "org.apache.felix" as the group id whereas the servlet api
uses "javax.servlet". Therefore mvn can't tell that this is the same
library just with different versions. So as we use 2.3 features of the
servlet-api and as maven wanted to put the 2.1 version before the 2.3
version in the classpath, compilation failed.

Now, of course, it's possible to exclude this dependency here and there,
but it has to be excluded nearly with every felix artifact and is a nice

So, can't we just get rid off this? Or can we at least use the groupId
javax.servlet to make things easier?

Carsten Ziegeler

View raw message