felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Felix Meschberger <fmesc...@gmail.com>
Subject Pom updates
Date Thu, 20 Sep 2007 14:08:21 GMT
Hi all,

I updated the jmood and jmxintrospector pom files such that they now use
the Maven Bundle plugin. In addition I added MX4J dependencies to jmood
to make it compile on Java 1.4, which does not include the JMX APIs yet,
and added it to the bundle build profile of the parent pom.

The jmxintrospector is more involved, though, and I probably only
scratched the surface: jmxintrospectore uses generics and therefore
requires Java 5 or higher. Consequently I did not add jmxintrospector to
the parent pom. In addition the jmxintrospector uses CGLib and asm in
the exported package, which requires these packages to also be exported.
It would probably be worth it to refactor jmxintrospector, such that
these dependencies might be kept internal to the bundle.


View raw message