felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Richard S. Hall" <he...@ungoverned.org>
Subject Re: Do we need javax.servlet?
Date Tue, 24 Jul 2007 16:49:06 GMT
Actually, Commons is the perfect place for javax.servlet, it just didn't 
exist at the time.

However, we actually need version 2.1 of javax.servlet for the HTTP 
Service, but I imagine that other people might want newer versions of 
javax.servlet. Did we devise our approach for maintaining multiple 
versions of bundles in Commons? It seems that would be necessary.

Other than that issue, I am all for moving javax.servlet to Commons.

-> richard

original message:
----------------------------

Sorry, might be a stupid question, but why do we need our own
javax.servlet module?

Wouldn't a version 2.1 under felix/commons that wraps the 2.1 servlet
api be sufficient?

Carsten
-- 
Carsten Ziegeler
cziegeler@apache.org



Mime
View raw message