felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Konstantinos N. Ntermitzoglou" <kos...@inaccessnetworks.com>
Subject Re: java.lang.NoClassDefFoundError with JamVM
Date Mon, 25 Jun 2007 12:17:32 GMT
Hi again,
    please consider the following scenario (still on felix 0.8.0 *)
I have installed another bundle that uses classes from org.w3c.dom 
package. I have tried to run it using SUN jre. The result was a 
NoClassDefFoundError for a class of that package. That is correct since 
I have not included the package to the org.osgi.framework.bootdelegation 
property. The other bundle that I mention to my previous mails that 
imports packages from another API bundle, worked just fine.
    When I have tried the exact same scenario with jamVM, the bundle 
that uses classes from org.w3c.dom worked without throwing any 
exception.Moreover, the bundle that imports from the bundle API could 
not load classes from that imported packages.

Could it this be a sign that jamVM is incompatible with the delegation 
mechanism of Felix? Can I fix it someway ?

Thank you for your time.

*Richard, I have tried building the trunk version, but I have faced some 
trouble. Maybe because I am unfamiliar with Maven... Would it be too 
much trouble for you providing me with a built jar version? Thank you in 

Konstantinos N. Ntermitzoglou wrote:
> Ok, I will try using the trunk version and see what happens.
> If this does not work out either, I shall find a way to provide more 
> detailed information about my case. Thank you a lot for your concern 
> :) ,I will keep you posted!
> regards,
> Kostas
> Richard S. Hall wrote:
>> First of all, you really should try to build from trunk since there 
>> were significant changes since 0.8.0...if you cannot build from 
>> trunk, I could email you a build if necessary.
>> Perhaps you can try to create another bundle that illustrates the 
>> same issue?
>> I would imagine that if it worked with Oscar on the same VM that it 
>> should be possible to get it to work on Felix and that VM, but it is 
>> difficult for us to help you if you cannot give us any information. :-)
>> -> richard
>> Konstantinos N. Ntermitzoglou wrote:
>>> Hi,
>>>    I am using Felix version 0.8.0.
>>> Richard, I am really sorry but I can not provide this information 
>>> because the bundle(s) code I use is under a NDA. However, I am now 
>>> pretty convinced that it is not a Felix or bundle (manifest) problem 
>>> after all. I have used jamVM on the same machine I used the Sun JRE 
>>> and I get the same error. So, it probably has to do with my VM's 
>>> configuration (or maybe the Classpath? ) and the, obviously modified 
>>> in Felix, class loading mechanism. On the other hand, all my other 
>>> bundles seem to work just fine and that is what really confuses me...
>>> Thank you all for your replies, if you have any idea even with my 
>>> limited information I will be glad to hear,
>>> regards,
>>> Kostas
>>> Karl Pauls wrote:
>>>> and maybe tell us with which version of Felix you've been trying
>>>> (0.8.0 or trunk - if trunk which revision/date)?
>>>> regards,
>>>> Karl
>>>> On 6/21/07, Richard S. Hall <heavy@ungoverned.org> wrote:
>>>>> Yes.
>>>>> The biggest issue in switching from Oscar to Felix is that Felix
>>>>> generally does NOT give bundles access to anything on the class path,
>>>>> whereas Oscar gave them access to everything on the class path. 
>>>>> However,
>>>>> if you tested this bundle on Felix with the Sun JRE and it worked, 
>>>>> then
>>>>> that is odd.
>>>>> Could you show us your expection, manifest, and bundle content?
>>>>> -> richard
>>>>> Felix Meschberger wrote:
>>>>> > Hi,
>>>>> >
>>>>> > NoClassDefFoundError generally indicates a missing class to which
>>>>> > class to
>>>>> > be loaded should be linked. For example, if you load the 
>>>>> StringBuffer
>>>>> > class,
>>>>> > the String class is required for linking. If the String class would
>>>>> > not be
>>>>> > found, the NoClassDefFoundError is thrown - whereas a
>>>>> > ClassNotFoundException
>>>>> > would be thrown if the StringBuffer class itself was not found.
>>>>> >
>>>>> > So, in your use case, it might be, that there are missing classes
>>>>> > expected
>>>>> > from the environment (system classes, boot class path or other 
>>>>> bundles),
>>>>> > which are missed. You might want to check the
>>>>> > org.osgi.framework.system.packages and
>>>>> > org.osgi.framework.bootdelegationproperties of the Felix
>>>>> > configuration.
>>>>> >
>>>>> > Regards
>>>>> > Felix
>>>>> >
>>>>> > On 6/21/07, Konstantinos N. Ntermitzoglou 
>>>>> <kosder@inaccessnetworks.com>
>>>>> > wrote:
>>>>> >>
>>>>> >> Hi everybody,
>>>>> >>
>>>>> >>     I have recently moved from Oscar to Felix, but I am facing
>>>>> >> following issue that keeps me from doing it totally. I have
an API
>>>>> >> bundle and another one that implements it. I have been using

>>>>> them with
>>>>> >> Oscar under an arm-linux architecture with JamVM1.4.5, 
>>>>> classpath 0.92
>>>>> >> and  all worked  just fine. The same configuration  will not

>>>>> work  with
>>>>> >> Felix. When I start the implementer bundle, it seems that the

>>>>> wiring is
>>>>> >> done correctly but when the time comes for an API class to be

>>>>> loaded I
>>>>> >> am getting java.lang.NoClassDefFoundError. I have used the 
>>>>> exact same
>>>>> >> configuration on an i686-linux with SUN's JVM and then the 
>>>>> bundle was
>>>>> >> started successfully.
>>>>> >> So I believe my bundles are R4 compatible and are bundled 
>>>>> correctly
>>>>> >> (Manifest import-export etc. ), so what can it be wrong ? Any

>>>>> ideas how
>>>>> >> to solve it ?
>>>>> >>
>>>>> >> Thank you in advance for any replies,
>>>>> >> Ntermitzoglou Konstantinos
>>>>> >>
>>>>> >

View raw message