felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stuart McCulloch (JIRA)" <j...@apache.org>
Subject [jira] Commented: (FELIX-306) Bundle plugin is incorrectly converting version numbers
Date Thu, 14 Jun 2007 01:42:25 GMT

    [ https://issues.apache.org/jira/browse/FELIX-306?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12504500

Stuart McCulloch commented on FELIX-306:

Yes - looks fine apart from the hyphen issue, as Felix mentioned.

FYI, Eclipse shows a warning when there are hyphens in Bundle-SymbolicName:

    "Bundle symbolic name contains illegal characters.  Legal characters are A-Z a-z 0-9 .

but I'm not sure if this is an OSGi restriction (this doesn't apply to Bundle-Name).

Recent versions of the BND tool also support conversion of versions to OSGi standards.
This even applies to any automatically discovered versions of import / export packages.

Here are the tests used with BND:

               assertVersion("1.2.3.x",         "1.2.3.x");
               assertVersion("1.2.3",           "1.2.3");
               assertVersion("1.2",             "1.2");
               assertVersion("1",               "1");
               assertVersion("1.2.x",           "1.2.0.x");
               assertVersion("1.x",             "1.0.0.x");
               assertVersion("1.2.3-x",         "1.2.3.x");
               assertVersion("1.2:x",           "1.2.0.x");
               assertVersion("1.2-snapshot",    "1.2.0.snapshot");
               assertVersion("1#x",             "1.0.0.x");
               assertVersion("1.&^%$#date2007/03/04", "1.0.0.date20070304");

> Bundle plugin is incorrectly converting version numbers
> -------------------------------------------------------
>                 Key: FELIX-306
>                 URL: https://issues.apache.org/jira/browse/FELIX-306
>             Project: Felix
>          Issue Type: Bug
>          Components: Maven Bundle Plugin
>            Reporter: Richard S. Hall
>            Priority: Minor
> The bundle plugin appears to be converting version numbers incorrectly. For example:
>     0.9.0-incubator-SNAPSHOT
> Is being converted to:
>     0.9.0.incubator_SNAPSHOT
> Only the first '-' should be converted to a '.' to be compatible with OSGi, the remaining
'-' characters to not need to be converted.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message