felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Richard S. Hall" <he...@ungoverned.org>
Subject Re: UPnP bundles
Date Fri, 04 May 2007 18:58:20 GMT
Ok, sorry for blaming the UPnP bundles! :-)

This bug was actually introduced by me, when I committed Didier's pom 
file for the spellcheckscr example...I didn't even think about this issue.

Whenever we change the packaging of any subproject, we have to remember 
to change the profile it is in. This is the second time we had issues 
due to changing the packaging of a bundle, but forgetting to changes it 
profile.

It will be nice if we can get a Maven fix for this so we can quit 
running into these sorts of issues.

I will commit your patch and uncomment the UPnP bundles...

Thanks for looking into it.

-> richard

Stefano Lenzi wrote:
> Richard S. Hall wrote:
>> Francesco Furfari wrote:
>>>
>>> Richard S. Hall wrote:
>>>> The UPnP bundles were causing my build to fail (as pointed out to 
>>>> me by Stephane), so I commented them out of the main pom file. Once 
>>>> the issue is resolved, we need to uncomment them.
>>>
>>> Sorry to which bundles are you referring to?
>>> In the trunk there aren't dependencies between UPnP and MOSGi
>>> ... and actually they are not commented !!
>>> Are you talking about my sandbox?
>>
>> I tried to do a clean build of the trunk and I got an error which 
>> says that it could not resolve a dependency for one of the UPnP 
>> bundles...I don't remember which. It looked like the dependency was 
>> on 0.1.0-incubator-SNAPSHOT of the maven-osgi-plugin, but I hadn't 
>> heard of such a version.
>>
>> Clear your .m2/repository and try to build from scratch using "ant" 
>> in the trunk and see what happens...that is what I did.
> Hi All,
>     we have just made some tests and we found that the problem resides 
> in the org.apache.felix.examples.spellcheckscr project that uses  the 
> bundle packaging even if it's in the profile for that uses the 
> osgi-bundle packaging. In fact if you look at your repository you may 
> find also the wireadmin bundle installed as .osgi-bundle artifact 
> instead of .jar due to the famous maven bug ^_^
>
>     So we have solved the issue by defining the profiles for the 
> examples pom.xml as you have done for the trunk pom.xml
>     
>     I have tried to send the patch but I get the following error message:
> Sending        examples/pom.xml
> svn: Commit failed (details follow):
> svn: CHECKOUT of 
> '/repos/asf/!svn/ver/534951/felix/trunk/examples/pom.xml': 403 
> Forbidden (https://svn.apache.org)
>
>     So I'll attach the patch :S
>
> Ciao,
> Stefano "Kismet" Lenzi
>
>

Mime
View raw message