felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Richard S. Hall" <he...@ungoverned.org>
Subject Re: UPnP bundles
Date Fri, 04 May 2007 17:44:20 GMT
Francesco Furfari wrote:
>
> Richard S. Hall wrote:
>> The UPnP bundles were causing my build to fail (as pointed out to me 
>> by Stephane), so I commented them out of the main pom file. Once the 
>> issue is resolved, we need to uncomment them.
>
> Sorry to which bundles are you referring to?
> In the trunk there aren't dependencies between UPnP and MOSGi
> ... and actually they are not commented !!
> Are you talking about my sandbox?

I tried to do a clean build of the trunk and I got an error which says 
that it could not resolve a dependency for one of the UPnP bundles...I 
don't remember which. It looked like the dependency was on 
0.1.0-incubator-SNAPSHOT of the maven-osgi-plugin, but I hadn't heard of 
such a version.

Clear your .m2/repository and try to build from scratch using "ant" in 
the trunk and see what happens...that is what I did.

-> richard

>
> francesco
>
>>
>> Two questions about the pom:
>>
>>   1. MOSGi has a dependency on Java 1.5 which causes the build to fail
>>      under 1.4. Can we put MOSGi into a profile that only gets build on
>>       > Java 1.5?
>>   2. Is there a way to modify the pom file so that the build does not
>>      stop if one of the modules fails? Would this be a better approach?
>>
>> -> richard

Mime
View raw message