felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alin Dreghiciu" <adreghi...@gmail.com>
Subject Re: What about Felix Commons
Date Tue, 13 Mar 2007 11:31:30 GMT
A proposal:

pkgVersion: 1.0RC1, 1.0RC2, 0.8-alpha
osgiVersion: 1.0.0.RC1, 1.0.0.RC2, 0.8.0.alpha

looks fine to me.

On 3/13/07, Stefano Lenzi <kismet@interfree.it> wrote:
>
> Alin Dreghiciu wrote:
> > Take a look at an example:
> https://issues.apache.org/jira/browse/FELIX-240
> > I had to add a new property: osgiVersion because pakage version does not
> > always conforms to osgi format. As in the example above the package
> > was 2.2but becasue of the pom version and snapshot the version will be
> > 2.2.0001-SNAPSHOT which is invalid. so the osgi version reuses the
> package
> > version and adds .0
> >
> What about if we have to wrap jars that use "named version" like:
> 1.0RC1, 1.0RC2, 0.8-alpha, etc ?
>
> Is that a real issue? Or we are speaking about only of Maven artifact so
> none of the jars will have a "named version".
>
> Stefano Lenzi
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message