felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Richard S. Hall" <he...@ungoverned.org>
Subject Re: Dependencies for hibernate bundle?
Date Thu, 29 Mar 2007 12:29:30 GMT
This is OBR output, correct? Are you looking at the bundle manifest or 
the generated OBR xml? Make sure the OBR xml file also defines them as 
optional.

-> richard

Tim Moloney wrote:
> I'm trying to use the hibernate bundle from the Felix commons and I'm 
> getting the following.
>
> Unsatisfied requirement(s):
> ---------------------------
>   (&(package=com.mchange.v2.c3p0)(version>=0.0.0))
>      hibernate bundle
>   (&(package=javax.security.jacc)(version>=0.0.0))
>      hibernate bundle
>   (&(package=org.jboss.cache.lock)(version>=0.0.0))
>      hibernate bundle
>   (&(package=org.gjt.xpp)(version>=0.0.0))
>      dom4j bundle
>   (&(package=com.opensymphony.oscache.general)(version>=0.0.0))
>      hibernate bundle
>   (&(package=org.apache.tools.ant.types)(version>=0.0.0))
>      hibernate bundle
>   (&(package=org.apache.tools.ant.taskdefs)(version>=0.0.0))
>      hibernate bundle
>   (&(package=net.sf.hibernate.cache)(version>=0.0.0))
>      ehcache bundle
>   (&(package=org.xmlpull.v1)(version>=0.0.0))
>      dom4j bundle
>   (&(package=org.apache.tools.ant)(version>=0.0.0))
>      hibernate bundle
>   (&(package=org.jaxen)(version>=0.0.0))
>      dom4j bundle
>   (&(package=org.logicalcobwebs.proxool)(version>=0.0.0))
>      hibernate bundle
>   (&(package=com.opensymphony.oscache.base)(version>=0.0.0))
>      hibernate bundle
>   (&(package=org.logicalcobwebs.proxool.configuration)(version>=0.0.0))
>      hibernate bundle
>   (&(package=org.jaxen.pattern)(version>=0.0.0))
>      dom4j bundle
>   (&(package=org.jboss.cache)(version>=0.0.0))
>      hibernate bundle
>   (&(package=net.sf.swarmcache)(version>=0.0.0))
>      hibernate bundle
>   (&(package=org.jaxen.dom4j)(version>=0.0.0))
>      dom4j bundle
>   (&(package=org.jaxen.saxpath)(version>=0.0.0))
>      dom4j bundle
>
> Looking at the pom.xml files for hibernate, dom4j, and ehcache, I see 
> that all of these packages have the "resolution:=optional" qualifier.  
> Are they really optional?
>
> Any tips on getting hibernate to work within Felix would be 
> appreciated.  (Warning:  I'm a newbie to hyperjaxb2, hibernate, and 
> JAXB but I'm trying to use them to use them with Felix.)
>
> Tim
>
>

Mime
View raw message