felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rick Litton" <Rick.Lit...@ktd-kyocera.com>
Subject RE: Another OBR issue
Date Thu, 08 Feb 2007 18:18:41 GMT
Steven wrote:

> It looks like either the symbolic name or the version are nil. I
haven't been able to track down all the ways this could be so.

Looking at the output from obr info, the repository.xml generated by
bindex shows that the Bundle-Name has been used as a substitute when the
Bundle-SymbolicName descriptor is missing from the manifest.  Hence my
guess is that the obr deploy command fails with an NPE only when
dependencies are not satisfied.  


Rick Litton


-----Original Message-----
From: Steven E. Harris [mailto:seh@panix.com] 
Sent: Thursday, February 08, 2007 9:51 AM
To: felix-dev@incubator.apache.org
Subject: Re: Another OBR issue

Rick Litton <Rick.Litton@ktd-kyocera.com> writes:

> java.lang.NullPointerException
>         at
>
org.apache.felix.bundlerepository.ResourceImpl.hashCode(ResourceImpl.jav
> a:79)

,----[ ResourceImpl.hashCode source ]
|  public int hashCode()
|  {
|      return getSymbolicName().hashCode() ^ getVersion().hashCode();
|  }
`----

It looks like either the symbolic name or the version are nil. I
haven't been able to track down all the ways this could be so. Do you
know if the ResourceImpl here is a LocalResourceImpl, or one created
by RepositoryImpl's parsing of an XML file?

-- 
Steven E. Harris

Mime
View raw message