felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Moloney <t.molo...@verizon.net>
Subject Re: Building the Felix trunk
Date Tue, 13 Feb 2007 13:36:31 GMT
Not for me, unfortunately.

Building Maven OSGi Plugin
[...]
Reason: Error getting POM for 
'org.apache.maven.plugins:maven-resource-plugin' from the repository: 
Failed to resolve artifact, possibly due to a repository list that is 
not appropriately equipped for this artifact's metadata.
  org.apache.maven.plugins:maven-resources-plugin:pom:2.3-SNAPSHOT
from the specified remote repositories:
  apache.snapshots (http://people.apache.org/repo/m2-snapshot-repository),
  snapshots (http://snapshots.maven.codehaus.org/maven2)
  central (http://repo1.maven.org/maven2)

After getting a fresh checkout, I ran 'ant' in the trunk directory.  I 
tried again after deleting ~/.m2/repository but got the same results.

Tim


Richard S. Hall wrote:
> Steven E. Harris wrote:
>> "Steven E. Harris" <seh@panix.com> writes:
>>
>>  
>>> This may be related to the "repository" elements not specifying
>>> whether each repository offers snapshots or releases (I just tried
>>> adding these specifications, but the problem persists)
>>>     
>>
>> Adding the following elements to the pluginRepository elements fixes
>> the problem:
>>
>>   <releases>
>>     <enabled>false</enabled>
>>   </releases>
>>   <snapshots>
>>     <enabled>true</enabled>
>>   </snapshots>
>>
>> The point being: Don't look for released plugins in the Apache
>> snapshot repository.
>>   
>
> Ok, cool. I have made this mod to the pom file...hopefully this 
> updated version will now work for everyone...it worked for me.
>
> Thanks.
>
> -> richard
>


Mime
View raw message