felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Richard S. Hall" <he...@ungoverned.org>
Subject Re: Problem with maven-osgi-plugin snapshot
Date Fri, 08 Dec 2006 21:57:16 GMT
Jeremy Boynes wrote:
> Thanks - worked great this time.

Good.

> We (Tuscany) had to rely on a snapshot as there was no official 
> release so having 0.8.0 will be great.

Well, there won't be an official release of the maven-osgi-plugin, but 
if you are already using the 0.9.0 version, then there shouldn't be any 
issue for you anyway, since that will be the "correct" version after the 
change over.

Keep us posted if anything goes wrong.

-> richard

>
>
> Thanks again
> -- 
> Jeremy
>
> On Dec 8, 2006, at 12:37 PM, Richard S. Hall wrote:
>
>> Hmmm. Ok, I made a mistake last time. Try again.
>>
>> It is likely that the SNAPSHOT repository is going to be a little 
>> messed up for the next week or two as we work out the kinks, since we 
>> are trying to get our first public release out.
>>
>> I should warn you and others now, that we plan to delete everything 
>> in the snapshot some time fairly soon, since the version numbering 
>> scheme does not clearly indicate that the artifacts are from the 
>> incubator. I am not sure when this will happen, but probably not 
>> until after we have the 0.8.0 release out the door.
>>
>> -> richard
>>
>> Jeremy Boynes wrote:
>>> Thanks - I see a new version of the 0.8.0 snapshot but not the 0.9.0 
>>> one:
>>> felix-0.8.0-20061208.195323-2.pom                    08-Dec-2006 11:53
>>>
>>> so I still get the same problem.
>>> --Jeremy
>>>
>>> On Dec 8, 2006, at 11:56 AM, Richard S. Hall wrote:
>>>
>>>> Oops. I pushed the parent POM, let me know if this solves the 
>>>> issue. Thanks.
>>>>
>>>> -> richard
>>>>
>>>> Jeremy Boynes wrote:
>>>>> A snapshot of the maven plugin has been published to the repo as 
>>>>> version 0.9.0-incubator-SNAPSHOT:
>>>>> http://people.apache.org/repo/m2-snapshot-repository/org/apache/felix/plugins/maven-osgi-plugin/0.9.0-incubator-SNAPSHOT/maven-osgi-plugin-0.9.0-incubator-20061206.161951-1.pom

>>>>>
>>>>>
>>>>> This has a dependency on a parent pom that has not been published 
>>>>> yet:
>>>>>   <parent>
>>>>>     <artifactId>felix</artifactId>
>>>>>     <groupId>org.apache.felix</groupId>
>>>>>     <version>0.9.0-incubator-SNAPSHOT</version>
>>>>>   </parent>
>>>>>
>>>>> By default, Maven will use the latest version of a plugin and 
>>>>> unfortunately this fails with
>>>>>
>>>>> GroupId: org.apache.felix
>>>>> ArtifactId: felix
>>>>> Version: 0.9.0-incubator-SNAPSHOT
>>>>>
>>>>> Reason: Unable to download the artifact from any repository
>>>>>
>>>>>   org.apache.felix:felix:pom:0.9.0-incubator-SNAPSHOT
>>>>>
>>>>> Please could someone deploy all of the 0.9.0 artifacts necessary, 
>>>>> or remove the 0.9.0 version of the plugin.
>>>>>
>>>>> Thanks
>>>>> --Jeremy
>>>>>
>>>
>

Mime
View raw message