felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Richard S. Hall" <he...@ungoverned.org>
Subject Re: unresolved package: bnd-extraimport=true ?
Date Tue, 05 Dec 2006 13:32:21 GMT
Peter Hulst wrote:
> could anyone tell me what the following error message means?
> org.osgi.framework.BundleException: Unresolved package in bundle 23:  
> [bnd-extraimport=true]
> I'm trying to deploy an OSGi/spring bundle into felix.
> My bundle doesn't have any dependencies on BND, other than the fact 
> that I use the BND maven plugin to create the OSGi bundle.
> I started getting this after doing an SVN update of the spring-osgi 
> and felix repositories. This bundle used to deploy just fine and I 
> don't believe anything changed in my code.

I have no idea what "bnd-extraimport=true" means, but to me this looks 
like a syntax error in the bundle manifest. I assume someone meant to 
put in a ";" when they actually put in a ",". Could you show us the 
manifest of bundle 23?

-> richard

View raw message