felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Kriens <Peter.Kri...@aQute.biz>
Subject Re: Which OSGi plugin to bet on?
Date Thu, 30 Nov 2006 14:37:19 GMT
There are no outstanding issues as far as I know.

If you use the new plugin as you would use the old plugin, there would
have been no bugs. This bnd plugin has considerably more horse power. The
plugin allows you to control the manifest headers in very fine grained
detail, something that was not possible with the old. Most errors we
found were actually verification issues, the plugin was sometimes a
bit too pedantic and overzealous in checking.

So I would definitely go for the bnd based plugin, I promise to fix
anything quickly when you run into an issue.

Kind regards,

     Peter Kriens


PN> Hi gang,
PN> we are wondering which Maven OSGi plugin we should bet on when
PN> starting to make some changes to support things like Require-Bundle
PN> statements etc from the POM? Peters BND sounds very nice but it seems
PN> the older one is more stable etc etc.

PN> Cheers

PN> /peter

-- 
Peter Kriens                              Tel +33467542167
9C, Avenue St. Drézéry                    AOL,Yahoo: pkriens
34160 Beaulieu, France                    ICQ 255570717
Skype pkriens                             Fax +1 8153772599


Mime
View raw message