felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bram de Kruijff" <br...@gx.nl>
Subject RE: maven-plugin: pom.version -> Bundle-Version
Date Tue, 28 Nov 2006 12:47:54 GMT
> > Version.parseVersion and this will
> > result in a NumberFormatExceprtion cause the implementation 
> of Version 
> > expects major('.'minor('.'micro('.'qualifier)?)?)? :(
> 
> This is actually, how the spec defines the Version. That is, 
> a qualifier is only allowed if there is a minor AND micro 
> version number. So, I fear, there is probably nothing you can 
> do about this except adding a micro version number.

You're right. I overlooked section 3.2.4 :0

> On the other hand, this might probably also be an extension 
> worth it to the Maven Bundle Plugin or bnd tool ....

I agree. At the least they should validate the (translated) Bundle-Version
at build time.

regards,
Bram


Mime
View raw message