felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bram de Kruijff" <br...@gx.nl>
Subject RE: Next MVN error - not able to find 'doxia'
Date Tue, 16 May 2006 09:34:38 GMT
Hi Rob,

when I moved my local repository out of the way I got the same error, worked
around it and ran into the next error :( Seems all repositories are down or
what not :S So let me describe what I did and add some more questions for
the next 'expert' to come along... 

The doxia-site-renderer-1.0-alpha-8.pom declares doxia-1.0-alpha-8.pom as
it's parents. Using the ggi-project mirror I'd expect this to work because
the parent pom is present at this mirror, but.. the
doxia-site-renderer-1.0-alpha-8.pom also declares a 'snapshots' repository
at http://snapshots.maven.codehaus.org/maven2 and this tells maven to search
that (first)(?) and because the repository is also 'unavailable' it fails
entirely..

the poms involved...
http://ftp.ggi-project.org/pub/packages/maven2/org/apache/maven/doxia/doxia/
1.0-alpha-8/doxia-1.0-alpha-8.pom
http://ftp.ggi-project.org/pub/packages/maven2/org/apache/maven/doxia/doxia-
site-renderer/1.0-alpha-8/doxia-site-renderer-1.0-alpha-8.pom

Why does maven fail when the pom it searches is available at (the mirror of)
central?

So I defined another mirror for 'snapshots' in my settings... it works, but
I'm not sure if this is the way it should be :S Does this mean I overrule
all potential respositories labelled 'snapshots' that might be defined in
and dependency? I think so.. not sure.. would be bad.

		<mirror>
			<id>ssggi-project.org</id>
	
<url>http://ftp.ggi-project.org/pub/packages/maven2</url>
			<mirrorOf>snapshots</mirrorOf>
		</mirror>

So now the build doesn't break on 'doxia' but a few moments later... jetty
depends on a servlet-api-2.-6.0 atrifact that it tries to retrieve from
dist.codehaus.org and yes... again this repo is unavailable (!*(&!)!) and
this time I cant work around it as easy as before using the ggi-project
mirror cause it does not have this artifact...

Btw what's up with all the 'latest and greatest' -alpha releases? Why is my
Felix build breaking on servlet-api 2.5 stuff that it actually doesn't
need(?) It seems that it has something todo with de maven site plugin?? How
to tell maven not to do that?

> First contact with maven ....  maven 0 - Ant 1 .... IMHO so far ;)
Second contact with maven ....  maven 0 - Ant 2 ??? :D

Maybe it's just something I overlooked, but this kind of trouble will scare
people away from using maven...

Regards,
Bram

note: repo1.maven.org is up again so I also tried a clean build with no
mirrors at all. It also fails on the doxia part... this can be considered to
be a good thing. At least it's consistend ;)

> -----Original Message-----
> From: Rob Walker [mailto:robw@ascert.com] 
> Sent: Monday, May 15, 2006 6:36 PM
> To: felix-dev@incubator.apache.org
> Subject: Next MVN error - not able to find 'doxia'
> 
> So Bram's mirror suggestion worked a treat. Now breaking much 
> later in the build, due to a 'doxia' plugin?
> 
>     Downloading:
>     
> http://ftp.ggi-project.org/pub/packages/maven2/org/apache/maven/dox
>     
> ia/doxia-site-renderer/1.0-alpha-8/doxia-site-renderer-1.0-alpha-8.pom
>     1K downloaded
>     Downloading:
>     
> http://snapshots.maven.codehaus.org/maven2/org/apache/maven/doxia/d
>     oxia/1.0-alpha-8/doxia-1.0-alpha-8.pom
>     [INFO]
>     
> --------------------------------------------------------------
> ----------
>     [ERROR] BUILD ERROR
>     [INFO]
>     
> --------------------------------------------------------------
> ----------
>     [INFO] Error building POM (may not be this project's POM).
> 
> 
>     Project ID: null:doxia-site-renderer:jar:1.0-alpha-8
> 
>     Reason: Cannot find parent: org.apache.maven.doxia:doxia for
>     project: null:doxia
>     -site-renderer:jar:1.0-alpha-8
> 
> So does this mean I need some more mirrors / repositories defined?
> 
> First contact with maven ....  maven 0 - Ant 1 .... IMHO so far ;)
> 
> -- Rob
> 
> 
> 


Mime
View raw message