felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marcel Offermans <marcel.offerm...@luminis.nl>
Subject Re: Contribution of the dependency manager to Felix
Date Fri, 20 Jan 2006 18:32:52 GMT
Jeff McAffer wrote:

>Is there any chance you can eliminate the need to use 1.4?  This is a show 
>stopper for some of our usecases.  If you want some non-1.4 concurrency 
>libs, you might consider the org.eclipse.core.jobs bundle.  Depending on 
>exactly what you are doing this may satisfy your needs and is based on 
>Foundation 1.0.
When stating I would like to remove the Java 5 dependencies I really 
meant getting it to run on Foundation 1.0 because I agree that such a 
"core" library should be useable on as many platforms as possible. To be 
honest, apart from rewriting some collections and concurrency primitives 
I really see no reason why it should not run on Foundation 1.0. I simply 
had not done this in the past because we had no direct need for that.

I will definitely have a look at the bundle you propose.

Greetings, Marcel

View raw message