felix-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From pde...@apache.org
Subject svn commit: r1800700 - /felix/site/trunk/content/obr/releases.xml
Date Mon, 03 Jul 2017 16:39:19 GMT
Author: pderop
Date: Mon Jul  3 16:39:19 2017
New Revision: 1800700

URL: http://svn.apache.org/viewvc?rev=1800700&view=rev
Log:
Added dependency manager r11 artifacts.

Modified:
    felix/site/trunk/content/obr/releases.xml

Modified: felix/site/trunk/content/obr/releases.xml
URL: http://svn.apache.org/viewvc/felix/site/trunk/content/obr/releases.xml?rev=1800700&r1=1800699&r2=1800700&view=diff
==============================================================================
--- felix/site/trunk/content/obr/releases.xml (original)
+++ felix/site/trunk/content/obr/releases.xml Mon Jul  3 16:39:19 2017
@@ -1,4 +1,4 @@
-<repository name='Felix-Releases' lastmodified='20170301124927.049'>
+<repository name='Felix-Releases' lastmodified='20170703062718.813'>
   <resource id='org.apache.felix.bundlerepository/1.2.0' symbolicname='org.apache.felix.bundlerepository'
presentationname='Apache Felix Bundle Repository' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.bundlerepository/1.2.0/org.apache.felix.bundlerepository-1.2.0.jar'
version='1.2.0'>
     <description>Bundle repository service.</description>
     <size>134382</size>
@@ -739,6 +739,44 @@
     <require name='package' filter='(&amp;(package=org.osgi.service.metatype)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.osgi.service.metatype;version="[1.3,2)"</require>
     <require name='package' filter='(&amp;(package=org.osgi.util.tracker)(version&gt;=1.5.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.osgi.util.tracker;version="[1.5,2)"</require>
   </resource>
+  <resource id='org.apache.felix.dependencymanager/4.4.1' symbolicname='org.apache.felix.dependencymanager'
presentationname='Apache Felix Dependency Manager' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.dependencymanager/4.4.1/org.apache.felix.dependencymanager-4.4.1.jar'
version='4.4.1'>
+    <description>Provides dynamic service and component dependency management</description>
+    <size>470441</size>
+    <documentation>http://felix.apache.org/documentation/subprojects/apache-felix-dependency-manager.html</documentation>
+    <license>http://www.apache.org/licenses/LICENSE-2.0.txt</license>
+    <category id='osgi'/>
+    <capability name='bundle'>
+      <p n='symbolicname' v='org.apache.felix.dependencymanager'/>
+      <p n='presentationname' v='Apache Felix Dependency Manager'/>
+      <p n='version' t='version' v='4.4.1'/>
+      <p n='manifestversion' v='2'/>
+    </capability>
+    <capability name='package'>
+      <p n='package' v='org.apache.felix.dm'/>
+      <p n='version' t='version' v='4.4.0'/>
+      <p n='uses:' v='org.osgi.framework'/>
+    </capability>
+    <capability name='package'>
+      <p n='package' v='org.apache.felix.dm.tracker'/>
+      <p n='version' t='version' v='4.0.0'/>
+      <p n='uses:' v='org.osgi.framework'/>
+    </capability>
+    <capability name='package'>
+      <p n='package' v='org.apache.felix.dm.context'/>
+      <p n='version' t='version' v='4.3.0'/>
+      <p n='uses:' v='org.apache.felix.dm,org.osgi.framework'/>
+    </capability>
+    <capability name='package'>
+      <p n='package' v='org.apache.felix.dm.diagnostics'/>
+      <p n='version' t='version' v='1.1.0'/>
+      <p n='uses:' v='org.apache.felix.dm'/>
+    </capability>
+    <require name='package' filter='(&amp;(package=org.apache.felix.dm.context)(version&gt;=4.3.0)(!(version&gt;=4.4.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.felix.dm.context;version="[4.3,4.4)"</require>
+    <require name='package' filter='(&amp;(package=org.osgi.framework)(version&gt;=1.8.0)(!(version&gt;=1.9.0)))'
extend='false' multiple='false' optional='false'>Import package org.osgi.framework;version="[1.8,1.9)"</require>
+    <require name='package' filter='(&amp;(package=org.osgi.service.cm)(version&gt;=1.5.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.osgi.service.cm;version="[1.5,2)"</require>
+    <require name='package' filter='(&amp;(package=org.osgi.service.metatype)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.osgi.service.metatype;version="[1.3,2)"</require>
+    <require name='package' filter='(&amp;(package=org.osgi.util.tracker)(version&gt;=1.5.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.osgi.util.tracker;version="[1.5,2)"</require>
+  </resource>
   <resource id='org.apache.felix.dependencymanager/3.2.0' symbolicname='org.apache.felix.dependencymanager'
presentationname='Apache Felix Dependency Manager' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.dependencymanager/3.2.0/org.apache.felix.dependencymanager-3.2.0.jar'
version='3.2.0'>
     <description>Provides dynamic service and component dependency management.</description>
     <size>193078</size>
@@ -812,6 +850,27 @@
     <require name='package' filter='(&amp;(package=aQute.service.reporter)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package aQute.service.reporter;version="[1.0,2)"</require>
     <require name='package' filter='(&amp;(package=org.apache.felix.dm.annotation.api)(version&gt;=1.2.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.felix.dm.annotation.api;version="[1.2,2)"</require>
   </resource>
+  <resource id='org.apache.felix.dependencymanager.annotation/4.2.1' symbolicname='org.apache.felix.dependencymanager.annotation'
presentationname='Apache Felix Dependency Manager Annotations' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.dependencymanager.annotation/4.2.1/org.apache.felix.dependencymanager.annotation-4.2.1.jar'
version='4.2.1'>
+    <description>Annotations for Apache Felix Dependency Manager</description>
+    <size>144810</size>
+    <documentation>http://felix.apache.org/documentation/subprojects/apache-felix-dependency-manager/apache-felix-dependency-manager-using-annotations.html</documentation>
+    <license>http://www.apache.org/licenses/LICENSE-2.0.txt</license>
+    <category id='osgi'/>
+    <capability name='bundle'>
+      <p n='symbolicname' v='org.apache.felix.dependencymanager.annotation'/>
+      <p n='presentationname' v='Apache Felix Dependency Manager Annotations'/>
+      <p n='version' t='version' v='4.2.1'/>
+      <p n='manifestversion' v='2'/>
+    </capability>
+    <capability name='package'>
+      <p n='package' v='org.apache.felix.dm.annotation.api'/>
+      <p n='version' t='version' v='1.2.0'/>
+    </capability>
+    <require name='package' filter='(&amp;(package=aQute.bnd.osgi)(version&gt;=2.3.0)(!(version&gt;=3.0.0)))'
extend='false' multiple='false' optional='false'>Import package aQute.bnd.osgi;version="[2.3,3)"</require>
+    <require name='package' filter='(&amp;(package=aQute.bnd.service)(version&gt;=4.1.0)(!(version&gt;=5.0.0)))'
extend='false' multiple='false' optional='false'>Import package aQute.bnd.service;version="[4.1,5)"</require>
+    <require name='package' filter='(&amp;(package=aQute.service.reporter)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package aQute.service.reporter;version="[1.0,2)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.felix.dm.annotation.api)(version&gt;=1.2.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.felix.dm.annotation.api;version="[1.2,2)"</require>
+  </resource>
   <resource id='org.apache.felix.dependencymanager.runtime/4.0.4' symbolicname='org.apache.felix.dependencymanager.runtime'
presentationname='Apache Felix Dependency Manager Runtime' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.dependencymanager.runtime/4.0.4/org.apache.felix.dependencymanager.runtime-4.0.4.jar'
version='4.0.4'>
     <description>Loads Apache Felix Dependency Manager component descriptors from active
annoted bundles</description>
     <size>132368</size>
@@ -834,6 +893,28 @@
     <require name='package' filter='(&amp;(package=org.osgi.service.log)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.osgi.service.log;version="[1.3,2)"</require>
     <require name='package' filter='(&amp;(package=org.osgi.service.packageadmin)(version&gt;=1.2.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.osgi.service.packageadmin;version="[1.2,2)"</require>
   </resource>
+  <resource id='org.apache.felix.dependencymanager.runtime/4.0.5' symbolicname='org.apache.felix.dependencymanager.runtime'
presentationname='Apache Felix Dependency Manager Runtime' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.dependencymanager.runtime/4.0.5/org.apache.felix.dependencymanager.runtime-4.0.5.jar'
version='4.0.5'>
+    <description>Loads Apache Felix Dependency Manager component descriptors from active
annoted bundles</description>
+    <size>133503</size>
+    <license>http://www.apache.org/licenses/LICENSE-2.0.txt</license>
+    <category id='osgi'/>
+    <capability name='bundle'>
+      <p n='symbolicname' v='org.apache.felix.dependencymanager.runtime'/>
+      <p n='presentationname' v='Apache Felix Dependency Manager Runtime'/>
+      <p n='version' t='version' v='4.0.5'/>
+      <p n='manifestversion' v='2'/>
+    </capability>
+    <capability name='package'>
+      <p n='package' v='org.apache.felix.dm.runtime.api'/>
+      <p n='version' t='version' v='1.0.0'/>
+    </capability>
+    <require name='package' filter='(&amp;(package=org.apache.felix.dm)(version&gt;=4.0.0)(!(version&gt;=5.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.felix.dm;version="[4,5)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.felix.dm.context)(version&gt;=4.0.0)(!(version&gt;=5.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.felix.dm.context;version="[4,5)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.felix.dm.runtime.api)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.felix.dm.runtime.api;version="[1.0,2)"</require>
+    <require name='package' filter='(&amp;(package=org.osgi.framework)(version&gt;=1.5.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.osgi.framework;version="[1.5,2)"</require>
+    <require name='package' filter='(&amp;(package=org.osgi.service.log)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.osgi.service.log;version="[1.3,2)"</require>
+    <require name='package' filter='(&amp;(package=org.osgi.service.packageadmin)(version&gt;=1.2.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.osgi.service.packageadmin;version="[1.2,2)"</require>
+  </resource>
   <resource id='org.apache.felix.dependencymanager.runtime/3.2.0' symbolicname='org.apache.felix.dependencymanager.runtime'
presentationname='Apache Felix Dependency Manager Runtime' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.dependencymanager.runtime/3.2.0/org.apache.felix.dependencymanager.runtime-3.2.0.jar'
version='3.2.0'>
     <description>Loads component descriptors from active bundles.</description>
     <size>104762</size>
@@ -881,6 +962,22 @@
     <require name='package' filter='(&amp;(package=org.apache.felix.service.command)(version&gt;=0.10.0)(!(version&gt;=1.0.0))(status=provisional)(mandatory:&lt;*status))'
extend='false' multiple='false' optional='false'>Import package org.apache.felix.service.command;version="[0.10,1)";status=provisional</require>
     <require name='package' filter='(&amp;(package=org.osgi.framework)(version&gt;=1.8.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.osgi.framework;version="[1.8,2)"</require>
   </resource>
+  <resource id='org.apache.felix.dependencymanager.shell/4.0.6' symbolicname='org.apache.felix.dependencymanager.shell'
presentationname='Apache Felix Dependency Manager Shell' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.dependencymanager.shell/4.0.6/org.apache.felix.dependencymanager.shell-4.0.6.jar'
version='4.0.6'>
+    <description>Gogo Shell commands for Apache Felix Dependency Manager</description>
+    <size>33976</size>
+    <license>http://www.apache.org/licenses/LICENSE-2.0.txt</license>
+    <category id='osgi'/>
+    <capability name='bundle'>
+      <p n='symbolicname' v='org.apache.felix.dependencymanager.shell'/>
+      <p n='presentationname' v='Apache Felix Dependency Manager Shell'/>
+      <p n='version' t='version' v='4.0.6'/>
+      <p n='manifestversion' v='2'/>
+    </capability>
+    <require name='package' filter='(&amp;(package=org.apache.felix.dm)(version&gt;=4.4.0)(!(version&gt;=5.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.felix.dm;version="[4.4,5)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.felix.dm.diagnostics)(version&gt;=1.1.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.felix.dm.diagnostics;version="[1.1,2)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.felix.service.command)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.felix.service.command;version="[1.0,2)"</require>
+    <require name='package' filter='(&amp;(package=org.osgi.framework)(version&gt;=1.8.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.osgi.framework;version="[1.8,2)"</require>
+  </resource>
   <resource id='org.apache.felix.eventadmin/1.0.0' symbolicname='org.apache.felix.eventadmin'
presentationname='Apache Felix EventAdmin' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.eventadmin/1.0.0/org.apache.felix.eventadmin-1.0.0.jar'
version='1.0.0'>
     <description>This bundle provides an implementation of the OSGi R4 EventAdmin service.</description>
     <size>73643</size>
@@ -6019,6 +6116,29 @@
       <p n='manifestversion' v='2'/>
     </capability>
     <capability name='package'>
+      <p n='package' v='org.apache.felix.dm.lambda'/>
+      <p n='version' t='version' v='1.1.0'/>
+      <p n='uses:' v='org.apache.felix.dm,org.apache.felix.dm.lambda.callbacks,org.osgi.framework'/>
+    </capability>
+    <capability name='package'>
+      <p n='package' v='org.apache.felix.dm.lambda.callbacks'/>
+      <p n='version' t='version' v='1.1.0'/>
+      <p n='uses:' v='org.apache.felix.dm,org.osgi.framework'/>
+    </capability>
+    <require name='package' filter='(&amp;(package=org.apache.felix.dm)(version&gt;=4.4.0)(!(version&gt;=5.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.felix.dm;version="[4.4,5)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.felix.dm.context)(version&gt;=4.3.0)(!(version&gt;=5.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.felix.dm.context;version="[4.3,5)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.felix.dm.lambda.callbacks)(version&gt;=1.1.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.felix.dm.lambda.callbacks;version="[1.1,2)"</require>
+    <require name='package' filter='(&amp;(package=org.osgi.framework)(version&gt;=1.8.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.osgi.framework;version="[1.8,2)"</require>
+  </resource>
+  <resource id='org.apache.felix.dependencymanager.lambda/1.1.1' symbolicname='org.apache.felix.dependencymanager.lambda'
presentationname='org.apache.felix.dependencymanager.lambda' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.dependencymanager.lambda/1.1.1/org.apache.felix.dependencymanager.lambda-1.1.1.jar'
version='1.1.1'>
+    <size>298435</size>
+    <capability name='bundle'>
+      <p n='symbolicname' v='org.apache.felix.dependencymanager.lambda'/>
+      <p n='presentationname' v='org.apache.felix.dependencymanager.lambda'/>
+      <p n='version' t='version' v='1.1.1'/>
+      <p n='manifestversion' v='2'/>
+    </capability>
+    <capability name='package'>
       <p n='package' v='org.apache.felix.dm.lambda'/>
       <p n='version' t='version' v='1.1.0'/>
       <p n='uses:' v='org.apache.felix.dm,org.apache.felix.dm.lambda.callbacks,org.osgi.framework'/>



Mime
View raw message