felix-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From pa...@apache.org
Subject svn commit: r1792945 - /felix/trunk/framework/src/main/resources/default.properties
Date Thu, 27 Apr 2017 19:18:42 GMT
Author: pauls
Date: Thu Apr 27 19:18:42 2017
New Revision: 1792945

URL: http://svn.apache.org/viewvc?rev=1792945&view=rev
Log:
Add missing osgi.ee

Modified:
    felix/trunk/framework/src/main/resources/default.properties

Modified: felix/trunk/framework/src/main/resources/default.properties
URL: http://svn.apache.org/viewvc/felix/trunk/framework/src/main/resources/default.properties?rev=1792945&r1=1792944&r2=1792945&view=diff
==============================================================================
--- felix/trunk/framework/src/main/resources/default.properties (original)
+++ felix/trunk/framework/src/main/resources/default.properties Thu Apr 27 19:18:42 2017
@@ -75,6 +75,11 @@ felix.service.caps=osgi.service; objectC
  osgi.service; objectClass:List<String>=org.osgi.service.startlevel.StartLevel; uses:=org.osgi.service.startlevel,
\
  osgi.service; objectClass:List<String>=org.osgi.service.packageadmin.PackageAdmin;
uses:=org.osgi.service.packageadmin
 
+eecap-1.9= osgi.ee; osgi.ee="OSGi/Minimum"; version:List<Version>="1.0,1.1,1.2", \
+ osgi.ee; osgi.ee="JavaSE"; version:List<Version>="1.0,1.1,1.2,1.3,1.4,1.5,1.6,1.7,1.8,1.9",
\
+ osgi.ee; osgi.ee="JavaSE/compact1"; version:List<Version>="1.8", \
+ osgi.ee; osgi.ee="JavaSE/compact2"; version:List<Version>="1.8", \
+ osgi.ee; osgi.ee="JavaSE/compact3"; version:List<Version>="1.8"
 eecap-1.8= osgi.ee; osgi.ee="OSGi/Minimum"; version:List<Version>="1.0,1.1,1.2", \
  osgi.ee; osgi.ee="JavaSE"; version:List<Version>="1.0,1.1,1.2,1.3,1.4,1.5,1.6,1.7,1.8",
\
  osgi.ee; osgi.ee="JavaSE/compact1"; version:List<Version>="1.8", \
@@ -97,6 +102,9 @@ eecap-1.2= osgi.ee; osgi.ee="OSGi/Minimu
 org.osgi.framework.executionenvironment= \
  ${dollar}{ee-${dollar}{java.specification.version}}
 
+ee-1.9=JavaSE-1.9,JavaSE-1.8,JavaSE-1.7,JavaSE-1.6,J2SE-1.5,J2SE-1.4,J2SE-1.3, \
+ J2SE-1.2,JRE-1.1,JRE-1.0,OSGi/Minimum-1.2,OSGi/Minimum-1.1, \
+ OSGi/Minimum-1.0
 ee-1.8=JavaSE-1.8,JavaSE-1.7,JavaSE-1.6,J2SE-1.5,J2SE-1.4,J2SE-1.3, \
  J2SE-1.2,JRE-1.1,JRE-1.0,OSGi/Minimum-1.2,OSGi/Minimum-1.1, \
  OSGi/Minimum-1.0



Mime
View raw message