felix-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From build...@apache.org
Subject svn commit: r1007447 [2/2] - in /websites/staging/felix/trunk/content: ./ obr/releases.xml
Date Tue, 28 Feb 2017 23:53:22 GMT
Modified: websites/staging/felix/trunk/content/obr/releases.xml
==============================================================================
--- websites/staging/felix/trunk/content/obr/releases.xml (original)
+++ websites/staging/felix/trunk/content/obr/releases.xml Tue Feb 28 23:53:22 2017
@@ -1,8 +1,8 @@
-<repository name='Felix-Releases' lastmodified='20140721045428.966'>
-  <resource id='org.apache.felix.bundlerepository/1.4.1' symbolicname='org.apache.felix.bundlerepository' presentationname='Apache Felix Bundle Repository' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.bundlerepository/1.4.1/org.apache.felix.bundlerepository-1.4.1.jar' version='1.4.1'>
+<repository name='Felix-Releases' lastmodified='20170301124927.049'>
+  <resource id='org.apache.felix.bundlerepository/1.2.0' symbolicname='org.apache.felix.bundlerepository' presentationname='Apache Felix Bundle Repository' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.bundlerepository/1.2.0/org.apache.felix.bundlerepository-1.2.0.jar' version='1.2.0'>
     <description>Bundle repository service.</description>
-    <size>151654</size>
-    <documentation>http://felix.apache.org/site/apache-felix-osgi-bundle-repository.html</documentation>
+    <size>134382</size>
+    <documentation>http://felix.apache.org/site/apache-felix-osgi-bundle-repository-obr.html</documentation>
     <source>http://felix.apache.org/site/downloads.cgi</source>
     <license>http://www.apache.org/licenses/LICENSE-2.0.txt</license>
     <category id='org.apache.felix'/>
@@ -16,7 +16,7 @@
       <p n='manifestversion' v='2'/>
       <p n='presentationname' v='Apache Felix Bundle Repository'/>
       <p n='symbolicname' v='org.apache.felix.bundlerepository'/>
-      <p n='version' t='version' v='1.4.1'/>
+      <p n='version' t='version' v='1.2.0'/>
     </capability>
     <capability name='service'>
       <p n='service' v='org.osgi.service.obr.RepositoryAdmin'/>
@@ -29,11 +29,10 @@
     <require name='package' filter='(&amp;(package=org.osgi.framework)(version&gt;=1.3.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.framework ;version=1.3.0</require>
     <require name='package' filter='(&amp;(package=org.osgi.service.log)(version&gt;=1.3.0))' extend='false' multiple='false' optional='true'>Import package org.osgi.service.log ;version=1.3.0</require>
     <require name='package' filter='(&amp;(package=org.osgi.service.obr)(version&gt;=1.0.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.obr ;version=1.0.0</require>
-    <require name='package' filter='(&amp;(package=org.osgi.service.url)(version&gt;=1.0.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.url ;version=1.0.0</require>
   </resource>
-  <resource id='org.apache.felix.bundlerepository/1.4.2' symbolicname='org.apache.felix.bundlerepository' presentationname='Apache Felix Bundle Repository' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.bundlerepository/1.4.2/org.apache.felix.bundlerepository-1.4.2.jar' version='1.4.2'>
+  <resource id='org.apache.felix.bundlerepository/1.2.1' symbolicname='org.apache.felix.bundlerepository' presentationname='Apache Felix Bundle Repository' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.bundlerepository/1.2.1/org.apache.felix.bundlerepository-1.2.1.jar' version='1.2.1'>
     <description>Bundle repository service.</description>
-    <size>151810</size>
+    <size>135821</size>
     <documentation>http://felix.apache.org/site/apache-felix-osgi-bundle-repository.html</documentation>
     <source>http://felix.apache.org/site/downloads.cgi</source>
     <license>http://www.apache.org/licenses/LICENSE-2.0.txt</license>
@@ -48,7 +47,7 @@
       <p n='manifestversion' v='2'/>
       <p n='presentationname' v='Apache Felix Bundle Repository'/>
       <p n='symbolicname' v='org.apache.felix.bundlerepository'/>
-      <p n='version' t='version' v='1.4.2'/>
+      <p n='version' t='version' v='1.2.1'/>
     </capability>
     <capability name='service'>
       <p n='service' v='org.osgi.service.obr.RepositoryAdmin'/>
@@ -58,29 +57,22 @@
       <p n='uses:' v='org.osgi.framework'/>
       <p n='version' t='version' v='1.0.0'/>
     </capability>
-    <require name='package' filter='(&amp;(package=org.osgi.framework)(version&gt;=1.4.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.framework ;version=1.4.0</require>
+    <require name='package' filter='(&amp;(package=org.osgi.framework)(version&gt;=1.3.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.framework ;version=1.3.0</require>
     <require name='package' filter='(&amp;(package=org.osgi.service.log)(version&gt;=1.3.0))' extend='false' multiple='false' optional='true'>Import package org.osgi.service.log ;version=1.3.0</require>
     <require name='package' filter='(&amp;(package=org.osgi.service.obr)(version&gt;=1.0.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.obr ;version=1.0.0</require>
-    <require name='package' filter='(&amp;(package=org.osgi.service.url)(version&gt;=1.0.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.url ;version=1.0.0</require>
   </resource>
-  <resource id='org.apache.felix.bundlerepository/1.4.3' symbolicname='org.apache.felix.bundlerepository' presentationname='Apache Felix Bundle Repository' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.bundlerepository/1.4.3/org.apache.felix.bundlerepository-1.4.3.jar' version='1.4.3'>
+  <resource id='org.apache.felix.bundlerepository/1.0.3' symbolicname='org.apache.felix.bundlerepository' presentationname='Apache Felix Bundle Repository' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.bundlerepository/1.0.3/org.apache.felix.bundlerepository-1.0.3.jar' version='1.0.3'>
     <description>Bundle repository service.</description>
-    <size>152089</size>
-    <documentation>http://felix.apache.org/site/apache-felix-osgi-bundle-repository.html</documentation>
-    <source>http://felix.apache.org/site/downloads.cgi</source>
+    <size>130451</size>
+    <documentation>http://oscar-osgi.sf.net/obr2/org.apache.felix.bundlerepository/</documentation>
+    <source>http://oscar-osgi.sf.net/obr2/org.apache.felix.bundlerepository/org.apache.felix.bundlerepository-1.0.3-src.jar</source>
     <license>http://www.apache.org/licenses/LICENSE-2.0.txt</license>
     <category id='org.apache.felix'/>
-    <capability name='service'>
-      <p n='service' v='org.apache.felix.shell.Command'/>
-    </capability>
-    <capability name='service'>
-      <p n='service' v='org.osgi.service.obr.RepositoryAdmin'/>
-    </capability>
     <capability name='bundle'>
       <p n='manifestversion' v='2'/>
       <p n='presentationname' v='Apache Felix Bundle Repository'/>
       <p n='symbolicname' v='org.apache.felix.bundlerepository'/>
-      <p n='version' t='version' v='1.4.3'/>
+      <p n='version' t='version' v='1.0.3'/>
     </capability>
     <capability name='service'>
       <p n='service' v='org.osgi.service.obr.RepositoryAdmin'/>
@@ -90,10 +82,8 @@
       <p n='uses:' v='org.osgi.framework'/>
       <p n='version' t='version' v='1.0.0'/>
     </capability>
-    <require name='package' filter='(&amp;(package=org.osgi.framework)(version&gt;=1.4.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.framework ;version=1.4.0</require>
-    <require name='package' filter='(&amp;(package=org.osgi.service.log)(version&gt;=1.3.0))' extend='false' multiple='false' optional='true'>Import package org.osgi.service.log ;version=1.3.0</require>
+    <require name='package' filter='(&amp;(package=org.osgi.framework)(version&gt;=1.3.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.framework ;version=1.3.0</require>
     <require name='package' filter='(&amp;(package=org.osgi.service.obr)(version&gt;=1.0.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.obr ;version=1.0.0</require>
-    <require name='package' filter='(&amp;(package=org.osgi.service.url)(version&gt;=1.0.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.url ;version=1.0.0</require>
   </resource>
   <resource id='org.apache.felix.bundlerepository/1.6.6' symbolicname='org.apache.felix.bundlerepository' presentationname='Apache Felix Bundle Repository' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.bundlerepository/1.6.6/org.apache.felix.bundlerepository-1.6.6.jar' version='1.6.6'>
     <description>Bundle repository service.</description>
@@ -134,10 +124,10 @@
     <require name='package' filter='(&amp;(package=org.osgi.service.obr)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='true'>Import package org.osgi.service.obr;resolution:=optional;version="[1.0,2)"</require>
     <require name='package' filter='(&amp;(package=org.osgi.service.url)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.url;version="[1.0,2)"</require>
   </resource>
-  <resource id='org.apache.felix.bundlerepository/1.2.0' symbolicname='org.apache.felix.bundlerepository' presentationname='Apache Felix Bundle Repository' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.bundlerepository/1.2.0/org.apache.felix.bundlerepository-1.2.0.jar' version='1.2.0'>
+  <resource id='org.apache.felix.bundlerepository/1.4.1' symbolicname='org.apache.felix.bundlerepository' presentationname='Apache Felix Bundle Repository' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.bundlerepository/1.4.1/org.apache.felix.bundlerepository-1.4.1.jar' version='1.4.1'>
     <description>Bundle repository service.</description>
-    <size>134382</size>
-    <documentation>http://felix.apache.org/site/apache-felix-osgi-bundle-repository-obr.html</documentation>
+    <size>151654</size>
+    <documentation>http://felix.apache.org/site/apache-felix-osgi-bundle-repository.html</documentation>
     <source>http://felix.apache.org/site/downloads.cgi</source>
     <license>http://www.apache.org/licenses/LICENSE-2.0.txt</license>
     <category id='org.apache.felix'/>
@@ -151,7 +141,7 @@
       <p n='manifestversion' v='2'/>
       <p n='presentationname' v='Apache Felix Bundle Repository'/>
       <p n='symbolicname' v='org.apache.felix.bundlerepository'/>
-      <p n='version' t='version' v='1.2.0'/>
+      <p n='version' t='version' v='1.4.1'/>
     </capability>
     <capability name='service'>
       <p n='service' v='org.osgi.service.obr.RepositoryAdmin'/>
@@ -164,10 +154,11 @@
     <require name='package' filter='(&amp;(package=org.osgi.framework)(version&gt;=1.3.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.framework ;version=1.3.0</require>
     <require name='package' filter='(&amp;(package=org.osgi.service.log)(version&gt;=1.3.0))' extend='false' multiple='false' optional='true'>Import package org.osgi.service.log ;version=1.3.0</require>
     <require name='package' filter='(&amp;(package=org.osgi.service.obr)(version&gt;=1.0.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.obr ;version=1.0.0</require>
+    <require name='package' filter='(&amp;(package=org.osgi.service.url)(version&gt;=1.0.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.url ;version=1.0.0</require>
   </resource>
-  <resource id='org.apache.felix.bundlerepository/1.2.1' symbolicname='org.apache.felix.bundlerepository' presentationname='Apache Felix Bundle Repository' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.bundlerepository/1.2.1/org.apache.felix.bundlerepository-1.2.1.jar' version='1.2.1'>
+  <resource id='org.apache.felix.bundlerepository/1.4.2' symbolicname='org.apache.felix.bundlerepository' presentationname='Apache Felix Bundle Repository' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.bundlerepository/1.4.2/org.apache.felix.bundlerepository-1.4.2.jar' version='1.4.2'>
     <description>Bundle repository service.</description>
-    <size>135821</size>
+    <size>151810</size>
     <documentation>http://felix.apache.org/site/apache-felix-osgi-bundle-repository.html</documentation>
     <source>http://felix.apache.org/site/downloads.cgi</source>
     <license>http://www.apache.org/licenses/LICENSE-2.0.txt</license>
@@ -182,7 +173,7 @@
       <p n='manifestversion' v='2'/>
       <p n='presentationname' v='Apache Felix Bundle Repository'/>
       <p n='symbolicname' v='org.apache.felix.bundlerepository'/>
-      <p n='version' t='version' v='1.2.1'/>
+      <p n='version' t='version' v='1.4.2'/>
     </capability>
     <capability name='service'>
       <p n='service' v='org.osgi.service.obr.RepositoryAdmin'/>
@@ -192,22 +183,29 @@
       <p n='uses:' v='org.osgi.framework'/>
       <p n='version' t='version' v='1.0.0'/>
     </capability>
-    <require name='package' filter='(&amp;(package=org.osgi.framework)(version&gt;=1.3.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.framework ;version=1.3.0</require>
+    <require name='package' filter='(&amp;(package=org.osgi.framework)(version&gt;=1.4.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.framework ;version=1.4.0</require>
     <require name='package' filter='(&amp;(package=org.osgi.service.log)(version&gt;=1.3.0))' extend='false' multiple='false' optional='true'>Import package org.osgi.service.log ;version=1.3.0</require>
     <require name='package' filter='(&amp;(package=org.osgi.service.obr)(version&gt;=1.0.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.obr ;version=1.0.0</require>
+    <require name='package' filter='(&amp;(package=org.osgi.service.url)(version&gt;=1.0.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.url ;version=1.0.0</require>
   </resource>
-  <resource id='org.apache.felix.bundlerepository/1.0.3' symbolicname='org.apache.felix.bundlerepository' presentationname='Apache Felix Bundle Repository' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.bundlerepository/1.0.3/org.apache.felix.bundlerepository-1.0.3.jar' version='1.0.3'>
+  <resource id='org.apache.felix.bundlerepository/1.4.3' symbolicname='org.apache.felix.bundlerepository' presentationname='Apache Felix Bundle Repository' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.bundlerepository/1.4.3/org.apache.felix.bundlerepository-1.4.3.jar' version='1.4.3'>
     <description>Bundle repository service.</description>
-    <size>130451</size>
-    <documentation>http://oscar-osgi.sf.net/obr2/org.apache.felix.bundlerepository/</documentation>
-    <source>http://oscar-osgi.sf.net/obr2/org.apache.felix.bundlerepository/org.apache.felix.bundlerepository-1.0.3-src.jar</source>
+    <size>152089</size>
+    <documentation>http://felix.apache.org/site/apache-felix-osgi-bundle-repository.html</documentation>
+    <source>http://felix.apache.org/site/downloads.cgi</source>
     <license>http://www.apache.org/licenses/LICENSE-2.0.txt</license>
     <category id='org.apache.felix'/>
+    <capability name='service'>
+      <p n='service' v='org.apache.felix.shell.Command'/>
+    </capability>
+    <capability name='service'>
+      <p n='service' v='org.osgi.service.obr.RepositoryAdmin'/>
+    </capability>
     <capability name='bundle'>
       <p n='manifestversion' v='2'/>
       <p n='presentationname' v='Apache Felix Bundle Repository'/>
       <p n='symbolicname' v='org.apache.felix.bundlerepository'/>
-      <p n='version' t='version' v='1.0.3'/>
+      <p n='version' t='version' v='1.4.3'/>
     </capability>
     <capability name='service'>
       <p n='service' v='org.osgi.service.obr.RepositoryAdmin'/>
@@ -217,8 +215,10 @@
       <p n='uses:' v='org.osgi.framework'/>
       <p n='version' t='version' v='1.0.0'/>
     </capability>
-    <require name='package' filter='(&amp;(package=org.osgi.framework)(version&gt;=1.3.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.framework ;version=1.3.0</require>
+    <require name='package' filter='(&amp;(package=org.osgi.framework)(version&gt;=1.4.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.framework ;version=1.4.0</require>
+    <require name='package' filter='(&amp;(package=org.osgi.service.log)(version&gt;=1.3.0))' extend='false' multiple='false' optional='true'>Import package org.osgi.service.log ;version=1.3.0</require>
     <require name='package' filter='(&amp;(package=org.osgi.service.obr)(version&gt;=1.0.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.obr ;version=1.0.0</require>
+    <require name='package' filter='(&amp;(package=org.osgi.service.url)(version&gt;=1.0.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.url ;version=1.0.0</require>
   </resource>
   <resource id='org.apache.felix.configadmin/1.2.4' symbolicname='org.apache.felix.configadmin' presentationname='Apache Felix Configuration Admin Service' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.configadmin/1.2.4/org.apache.felix.configadmin-1.2.4.jar' version='1.2.4'>
     <description>Implementation of the OSGi Configuration Admin Service Specification 1.2</description>
@@ -358,10 +358,10 @@
     <require name='package' filter='(&amp;(package=org.osgi.service.cm)(version&gt;=1.2.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.cm ;version=1.2.0</require>
     <require name='package' filter='(&amp;(package=org.osgi.util.tracker)(version&gt;=1.3.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.util.tracker ;version=1.3.0</require>
   </resource>
-  <resource id='org.apache.felix.scr/1.0.8' symbolicname='org.apache.felix.scr' presentationname='Apache Felix Declarative Services' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.scr/1.0.8/org.apache.felix.scr-1.0.8.jar' version='1.0.8'>
+  <resource id='org.apache.felix.scr/1.4.0' symbolicname='org.apache.felix.scr' presentationname='Apache Felix Declarative Services' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.scr/1.4.0/org.apache.felix.scr-1.4.0.jar' version='1.4.0'>
     <description>Implementation of the Declarative Services specification 1.0</description>
-    <size>112059</size>
-    <documentation>http://www.apache.org/</documentation>
+    <size>185414</size>
+    <documentation>http://felix.apache.org/site/apache-felix-service-component-runtime.html</documentation>
     <license>http://www.apache.org/licenses/LICENSE-2.0.txt</license>
     <category id='org.apache.felix'/>
     <capability name='service'>
@@ -379,34 +379,29 @@
       <p n='manifestversion' v='2'/>
       <p n='presentationname' v='Apache Felix Declarative Services'/>
       <p n='symbolicname' v='org.apache.felix.scr'/>
-      <p n='version' t='version' v='1.0.8'/>
+      <p n='version' t='version' v='1.4.0'/>
     </capability>
     <capability name='package'>
-      <p n='package' v='org.osgi.service.cm'/>
-      <p n='uses:' v='org.osgi.framework'/>
-      <p n='version' t='version' v='1.2.0'/>
+      <p n='package' v='org.apache.felix.scr'/>
+      <p n='uses' v='org.osgi.framework,org.osgi.service.component'/>
+      <p n='version' t='version' v='1.4.0'/>
     </capability>
     <capability name='package'>
       <p n='package' v='org.osgi.service.component'/>
-      <p n='uses:' v='org.osgi.framework'/>
-      <p n='version' t='version' v='1.0.0'/>
-    </capability>
-    <capability name='package'>
-      <p n='package' v='org.apache.felix.scr'/>
-      <p n='uses:' v='org.osgi.framework'/>
-      <p n='version' t='version' v='1.0.8'/>
+      <p n='uses' v='org.osgi.framework'/>
+      <p n='version' t='version' v='1.1.0'/>
     </capability>
     <require name='service' filter='(service=org.osgi.service.log.LogService)' extend='false' multiple='false' optional='true'>Import Service org.osgi.service.log.LogService</require>
-    <require name='package' filter='(&amp;(package=org.apache.felix.scr)(version&gt;=1.0.8))' extend='false' multiple='false' optional='false'>Import package org.apache.felix.scr ;version=1.0.8</require>
     <require name='package' filter='(&amp;(package=org.apache.felix.shell)(version&gt;=1.0.0))' extend='false' multiple='false' optional='true'>Import package org.apache.felix.shell ;version=1.0.0</require>
-    <require name='package' filter='(&amp;(package=org.osgi.framework)(version&gt;=1.3.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.framework ;version=1.3.0</require>
-    <require name='package' filter='(&amp;(package=org.osgi.service.cm)(version&gt;=1.2.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.cm ;version=1.2.0</require>
-    <require name='package' filter='(&amp;(package=org.osgi.service.component)(version&gt;=1.0.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.component ;version=1.0.0</require>
+    <require name='package' filter='(&amp;(package=org.osgi.framework)(version&gt;=1.4.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.framework ;version=[1.4.0,2.0.0)</require>
+    <require name='package' filter='(&amp;(package=org.osgi.service.cm)(version&gt;=1.2.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='true'>Import package org.osgi.service.cm ;version=[1.2.0,2.0.0)</require>
+    <require name='package' filter='(&amp;(package=org.osgi.service.component)(version&gt;=1.1.0)(!(version&gt;=1.2.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.component ;version=[1.1.0,1.2.0)</require>
+    <require name='package' filter='(&amp;(package=org.osgi.service.log)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='true'>Import package org.osgi.service.log ;version=[1.3.0,2.0.0)</require>
   </resource>
-  <resource id='org.apache.felix.scr/1.0.4' symbolicname='org.apache.felix.scr' presentationname='Apache Felix Declarative Services' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.scr/1.0.4/org.apache.felix.scr-1.0.4.jar' version='1.0.4'>
-    <description>Implementation of the Declarative Services specification 1.0</description>
-    <size>109599</size>
-    <documentation>http://www.apache.org/</documentation>
+  <resource id='org.apache.felix.scr/1.6.0' symbolicname='org.apache.felix.scr' presentationname='Apache Felix Declarative Services' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.scr/1.6.0/org.apache.felix.scr-1.6.0.jar' version='1.6.0'>
+    <description>Implementation of the Declarative Services specification 1.1</description>
+    <size>192370</size>
+    <documentation>http://felix.apache.org/site/apache-felix-service-component-runtime.html</documentation>
     <license>http://www.apache.org/licenses/LICENSE-2.0.txt</license>
     <category id='org.apache.felix'/>
     <capability name='service'>
@@ -424,34 +419,31 @@
       <p n='manifestversion' v='2'/>
       <p n='presentationname' v='Apache Felix Declarative Services'/>
       <p n='symbolicname' v='org.apache.felix.scr'/>
-      <p n='version' t='version' v='1.0.4'/>
-    </capability>
-    <capability name='package'>
-      <p n='package' v='org.osgi.service.component'/>
-      <p n='uses:' v='org.osgi.framework'/>
-      <p n='version' t='version' v='1.0.0'/>
+      <p n='version' t='version' v='1.6.0'/>
     </capability>
     <capability name='package'>
       <p n='package' v='org.apache.felix.scr'/>
-      <p n='uses:' v='org.osgi.framework'/>
-      <p n='version' t='version' v='1.0.4'/>
+      <p n='uses:' v='org.osgi.framework,org.osgi.service.component'/>
+      <p n='version' t='version' v='1.6.0'/>
     </capability>
     <capability name='package'>
-      <p n='package' v='org.osgi.service.cm'/>
+      <p n='package' v='org.osgi.service.component'/>
       <p n='uses:' v='org.osgi.framework'/>
-      <p n='version' t='version' v='1.2.0'/>
+      <p n='version' t='version' v='1.1.0'/>
     </capability>
     <require name='service' filter='(service=org.osgi.service.log.LogService)' extend='false' multiple='false' optional='true'>Import Service org.osgi.service.log.LogService</require>
-    <require name='package' filter='(&amp;(package=org.apache.felix.scr)(version&gt;=1.0.4))' extend='false' multiple='false' optional='false'>Import package org.apache.felix.scr ;version=1.0.4</require>
     <require name='package' filter='(&amp;(package=org.apache.felix.shell)(version&gt;=1.0.0))' extend='false' multiple='false' optional='true'>Import package org.apache.felix.shell ;version=1.0.0</require>
-    <require name='package' filter='(&amp;(package=org.osgi.framework)(version&gt;=1.3.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.framework ;version=1.3.0</require>
-    <require name='package' filter='(&amp;(package=org.osgi.service.cm)(version&gt;=1.2.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.cm ;version=1.2.0</require>
-    <require name='package' filter='(&amp;(package=org.osgi.service.component)(version&gt;=1.0.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.component ;version=1.0.0</require>
+    <require name='package' filter='(&amp;(package=org.osgi.framework)(version&gt;=1.4.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.framework ;version=[1.4.0,2.0.0)</require>
+    <require name='package' filter='(&amp;(package=org.osgi.service.cm)(version&gt;=1.2.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='true'>Import package org.osgi.service.cm ;version=[1.2.0,2.0.0)</require>
+    <require name='package' filter='(&amp;(package=org.osgi.service.component)(version&gt;=1.1.0)(!(version&gt;=1.2.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.component ;version=[1.1.0,1.2.0)</require>
+    <require name='package' filter='(&amp;(package=org.osgi.service.log)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='true'>Import package org.osgi.service.log ;version=[1.3.0,2.0.0)</require>
+    <require name='package' filter='(&amp;(package=org.osgi.service.metatype)(version&gt;=1.1.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='true'>Import package org.osgi.service.metatype ;version=[1.1.0,2.0.0)</require>
+    <require name='package' filter='(&amp;(package=org.osgi.service.packageadmin)(version&gt;=1.2.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='true'>Import package org.osgi.service.packageadmin ;version=[1.2.0,2.0.0)</require>
   </resource>
-  <resource id='org.apache.felix.scr/1.4.0' symbolicname='org.apache.felix.scr' presentationname='Apache Felix Declarative Services' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.scr/1.4.0/org.apache.felix.scr-1.4.0.jar' version='1.4.0'>
+  <resource id='org.apache.felix.scr/1.0.8' symbolicname='org.apache.felix.scr' presentationname='Apache Felix Declarative Services' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.scr/1.0.8/org.apache.felix.scr-1.0.8.jar' version='1.0.8'>
     <description>Implementation of the Declarative Services specification 1.0</description>
-    <size>185414</size>
-    <documentation>http://felix.apache.org/site/apache-felix-service-component-runtime.html</documentation>
+    <size>112059</size>
+    <documentation>http://www.apache.org/</documentation>
     <license>http://www.apache.org/licenses/LICENSE-2.0.txt</license>
     <category id='org.apache.felix'/>
     <capability name='service'>
@@ -469,28 +461,33 @@
       <p n='manifestversion' v='2'/>
       <p n='presentationname' v='Apache Felix Declarative Services'/>
       <p n='symbolicname' v='org.apache.felix.scr'/>
-      <p n='version' t='version' v='1.4.0'/>
+      <p n='version' t='version' v='1.0.8'/>
     </capability>
     <capability name='package'>
-      <p n='package' v='org.apache.felix.scr'/>
-      <p n='uses' v='org.osgi.framework,org.osgi.service.component'/>
-      <p n='version' t='version' v='1.4.0'/>
+      <p n='package' v='org.osgi.service.cm'/>
+      <p n='uses:' v='org.osgi.framework'/>
+      <p n='version' t='version' v='1.2.0'/>
     </capability>
     <capability name='package'>
       <p n='package' v='org.osgi.service.component'/>
-      <p n='uses' v='org.osgi.framework'/>
-      <p n='version' t='version' v='1.1.0'/>
+      <p n='uses:' v='org.osgi.framework'/>
+      <p n='version' t='version' v='1.0.0'/>
+    </capability>
+    <capability name='package'>
+      <p n='package' v='org.apache.felix.scr'/>
+      <p n='uses:' v='org.osgi.framework'/>
+      <p n='version' t='version' v='1.0.8'/>
     </capability>
     <require name='service' filter='(service=org.osgi.service.log.LogService)' extend='false' multiple='false' optional='true'>Import Service org.osgi.service.log.LogService</require>
+    <require name='package' filter='(&amp;(package=org.apache.felix.scr)(version&gt;=1.0.8))' extend='false' multiple='false' optional='false'>Import package org.apache.felix.scr ;version=1.0.8</require>
     <require name='package' filter='(&amp;(package=org.apache.felix.shell)(version&gt;=1.0.0))' extend='false' multiple='false' optional='true'>Import package org.apache.felix.shell ;version=1.0.0</require>
-    <require name='package' filter='(&amp;(package=org.osgi.framework)(version&gt;=1.4.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.framework ;version=[1.4.0,2.0.0)</require>
-    <require name='package' filter='(&amp;(package=org.osgi.service.cm)(version&gt;=1.2.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='true'>Import package org.osgi.service.cm ;version=[1.2.0,2.0.0)</require>
-    <require name='package' filter='(&amp;(package=org.osgi.service.component)(version&gt;=1.1.0)(!(version&gt;=1.2.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.component ;version=[1.1.0,1.2.0)</require>
-    <require name='package' filter='(&amp;(package=org.osgi.service.log)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='true'>Import package org.osgi.service.log ;version=[1.3.0,2.0.0)</require>
+    <require name='package' filter='(&amp;(package=org.osgi.framework)(version&gt;=1.3.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.framework ;version=1.3.0</require>
+    <require name='package' filter='(&amp;(package=org.osgi.service.cm)(version&gt;=1.2.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.cm ;version=1.2.0</require>
+    <require name='package' filter='(&amp;(package=org.osgi.service.component)(version&gt;=1.0.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.component ;version=1.0.0</require>
   </resource>
-  <resource id='org.apache.felix.scr/1.0.6' symbolicname='org.apache.felix.scr' presentationname='Apache Felix Declarative Services' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.scr/1.0.6/org.apache.felix.scr-1.0.6.jar' version='1.0.6'>
+  <resource id='org.apache.felix.scr/1.0.4' symbolicname='org.apache.felix.scr' presentationname='Apache Felix Declarative Services' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.scr/1.0.4/org.apache.felix.scr-1.0.4.jar' version='1.0.4'>
     <description>Implementation of the Declarative Services specification 1.0</description>
-    <size>109751</size>
+    <size>109599</size>
     <documentation>http://www.apache.org/</documentation>
     <license>http://www.apache.org/licenses/LICENSE-2.0.txt</license>
     <category id='org.apache.felix'/>
@@ -509,7 +506,7 @@
       <p n='manifestversion' v='2'/>
       <p n='presentationname' v='Apache Felix Declarative Services'/>
       <p n='symbolicname' v='org.apache.felix.scr'/>
-      <p n='version' t='version' v='1.0.6'/>
+      <p n='version' t='version' v='1.0.4'/>
     </capability>
     <capability name='package'>
       <p n='package' v='org.osgi.service.component'/>
@@ -519,7 +516,7 @@
     <capability name='package'>
       <p n='package' v='org.apache.felix.scr'/>
       <p n='uses:' v='org.osgi.framework'/>
-      <p n='version' t='version' v='1.0.6'/>
+      <p n='version' t='version' v='1.0.4'/>
     </capability>
     <capability name='package'>
       <p n='package' v='org.osgi.service.cm'/>
@@ -527,16 +524,16 @@
       <p n='version' t='version' v='1.2.0'/>
     </capability>
     <require name='service' filter='(service=org.osgi.service.log.LogService)' extend='false' multiple='false' optional='true'>Import Service org.osgi.service.log.LogService</require>
-    <require name='package' filter='(&amp;(package=org.apache.felix.scr)(version&gt;=1.0.6))' extend='false' multiple='false' optional='false'>Import package org.apache.felix.scr ;version=1.0.6</require>
+    <require name='package' filter='(&amp;(package=org.apache.felix.scr)(version&gt;=1.0.4))' extend='false' multiple='false' optional='false'>Import package org.apache.felix.scr ;version=1.0.4</require>
     <require name='package' filter='(&amp;(package=org.apache.felix.shell)(version&gt;=1.0.0))' extend='false' multiple='false' optional='true'>Import package org.apache.felix.shell ;version=1.0.0</require>
     <require name='package' filter='(&amp;(package=org.osgi.framework)(version&gt;=1.3.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.framework ;version=1.3.0</require>
     <require name='package' filter='(&amp;(package=org.osgi.service.cm)(version&gt;=1.2.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.cm ;version=1.2.0</require>
     <require name='package' filter='(&amp;(package=org.osgi.service.component)(version&gt;=1.0.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.component ;version=1.0.0</require>
   </resource>
-  <resource id='org.apache.felix.scr/1.6.0' symbolicname='org.apache.felix.scr' presentationname='Apache Felix Declarative Services' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.scr/1.6.0/org.apache.felix.scr-1.6.0.jar' version='1.6.0'>
-    <description>Implementation of the Declarative Services specification 1.1</description>
-    <size>192370</size>
-    <documentation>http://felix.apache.org/site/apache-felix-service-component-runtime.html</documentation>
+  <resource id='org.apache.felix.scr/1.0.6' symbolicname='org.apache.felix.scr' presentationname='Apache Felix Declarative Services' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.scr/1.0.6/org.apache.felix.scr-1.0.6.jar' version='1.0.6'>
+    <description>Implementation of the Declarative Services specification 1.0</description>
+    <size>109751</size>
+    <documentation>http://www.apache.org/</documentation>
     <license>http://www.apache.org/licenses/LICENSE-2.0.txt</license>
     <category id='org.apache.felix'/>
     <capability name='service'>
@@ -554,26 +551,29 @@
       <p n='manifestversion' v='2'/>
       <p n='presentationname' v='Apache Felix Declarative Services'/>
       <p n='symbolicname' v='org.apache.felix.scr'/>
-      <p n='version' t='version' v='1.6.0'/>
+      <p n='version' t='version' v='1.0.6'/>
+    </capability>
+    <capability name='package'>
+      <p n='package' v='org.osgi.service.component'/>
+      <p n='uses:' v='org.osgi.framework'/>
+      <p n='version' t='version' v='1.0.0'/>
     </capability>
     <capability name='package'>
       <p n='package' v='org.apache.felix.scr'/>
-      <p n='uses:' v='org.osgi.framework,org.osgi.service.component'/>
-      <p n='version' t='version' v='1.6.0'/>
+      <p n='uses:' v='org.osgi.framework'/>
+      <p n='version' t='version' v='1.0.6'/>
     </capability>
     <capability name='package'>
-      <p n='package' v='org.osgi.service.component'/>
+      <p n='package' v='org.osgi.service.cm'/>
       <p n='uses:' v='org.osgi.framework'/>
-      <p n='version' t='version' v='1.1.0'/>
+      <p n='version' t='version' v='1.2.0'/>
     </capability>
     <require name='service' filter='(service=org.osgi.service.log.LogService)' extend='false' multiple='false' optional='true'>Import Service org.osgi.service.log.LogService</require>
+    <require name='package' filter='(&amp;(package=org.apache.felix.scr)(version&gt;=1.0.6))' extend='false' multiple='false' optional='false'>Import package org.apache.felix.scr ;version=1.0.6</require>
     <require name='package' filter='(&amp;(package=org.apache.felix.shell)(version&gt;=1.0.0))' extend='false' multiple='false' optional='true'>Import package org.apache.felix.shell ;version=1.0.0</require>
-    <require name='package' filter='(&amp;(package=org.osgi.framework)(version&gt;=1.4.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.framework ;version=[1.4.0,2.0.0)</require>
-    <require name='package' filter='(&amp;(package=org.osgi.service.cm)(version&gt;=1.2.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='true'>Import package org.osgi.service.cm ;version=[1.2.0,2.0.0)</require>
-    <require name='package' filter='(&amp;(package=org.osgi.service.component)(version&gt;=1.1.0)(!(version&gt;=1.2.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.component ;version=[1.1.0,1.2.0)</require>
-    <require name='package' filter='(&amp;(package=org.osgi.service.log)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='true'>Import package org.osgi.service.log ;version=[1.3.0,2.0.0)</require>
-    <require name='package' filter='(&amp;(package=org.osgi.service.metatype)(version&gt;=1.1.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='true'>Import package org.osgi.service.metatype ;version=[1.1.0,2.0.0)</require>
-    <require name='package' filter='(&amp;(package=org.osgi.service.packageadmin)(version&gt;=1.2.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='true'>Import package org.osgi.service.packageadmin ;version=[1.2.0,2.0.0)</require>
+    <require name='package' filter='(&amp;(package=org.osgi.framework)(version&gt;=1.3.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.framework ;version=1.3.0</require>
+    <require name='package' filter='(&amp;(package=org.osgi.service.cm)(version&gt;=1.2.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.cm ;version=1.2.0</require>
+    <require name='package' filter='(&amp;(package=org.osgi.service.component)(version&gt;=1.0.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.component ;version=1.0.0</require>
   </resource>
   <resource id='org.apache.felix.scr/1.0.0' symbolicname='org.apache.felix.scr' presentationname='Apache Felix Declarative Services' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.scr/1.0.0/org.apache.felix.scr-1.0.0.jar' version='1.0.0'>
     <description>Implementation of the Declarative Services specification 1.0</description>
@@ -701,31 +701,43 @@
     <require name='package' filter='(&amp;(package=org.osgi.service.component)(version&gt;=1.1.0)(!(version&gt;=1.2.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.component ;version=[1.1.0,1.2.0)</require>
     <require name='package' filter='(&amp;(package=org.osgi.service.log)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='true'>Import package org.osgi.service.log ;version=[1.3.0,2.0.0)</require>
   </resource>
-  <resource id='org.apache.felix.dependencymanager/3.0.0' symbolicname='org.apache.felix.dependencymanager' presentationname='Apache Felix Dependency Manager' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.dependencymanager/3.0.0/org.apache.felix.dependencymanager-3.0.0.jar' version='3.0.0'>
-    <description>Provides dynamic service and component dependency management.</description>
-    <size>161118</size>
-    <documentation>http://www.apache.org/</documentation>
+  <resource id='org.apache.felix.dependencymanager/4.4.0' symbolicname='org.apache.felix.dependencymanager' presentationname='Apache Felix Dependency Manager' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.dependencymanager/4.4.0/org.apache.felix.dependencymanager-4.4.0.jar' version='4.4.0'>
+    <description>Provides dynamic service and component dependency management</description>
+    <size>455578</size>
+    <documentation>http://felix.apache.org/documentation/subprojects/apache-felix-dependency-manager.html</documentation>
     <license>http://www.apache.org/licenses/LICENSE-2.0.txt</license>
+    <category id='osgi'/>
     <capability name='bundle'>
       <p n='symbolicname' v='org.apache.felix.dependencymanager'/>
       <p n='presentationname' v='Apache Felix Dependency Manager'/>
-      <p n='version' t='version' v='3.0.0'/>
+      <p n='version' t='version' v='4.4.0'/>
       <p n='manifestversion' v='2'/>
     </capability>
     <capability name='package'>
       <p n='package' v='org.apache.felix.dm'/>
-      <p n='version' t='version' v='3.0.0'/>
+      <p n='version' t='version' v='4.4.0'/>
       <p n='uses:' v='org.osgi.framework'/>
     </capability>
     <capability name='package'>
       <p n='package' v='org.apache.felix.dm.tracker'/>
-      <p n='version' t='version' v='3.0.0'/>
-      <p n='uses:' v='org.osgi.framework,org.apache.felix.dm'/>
+      <p n='version' t='version' v='4.0.0'/>
+      <p n='uses:' v='org.osgi.framework'/>
     </capability>
-    <require name='package' filter='(&amp;(package=org.apache.felix.dm.tracker)(version&gt;=3.0.0)(!(version&gt;=3.1.0)))' extend='false' multiple='false' optional='false'>Import package org.apache.felix.dm.tracker;version="[3.0,3.1)"</require>
-    <require name='package' filter='(&amp;(package=org.osgi.framework)(version&gt;=1.5.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.framework;version="[1.5,2)"</require>
-    <require name='package' filter='(&amp;(package=org.osgi.service.cm)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.cm;version="[1.3,2)"</require>
-    <require name='package' filter='(&amp;(package=org.osgi.service.metatype)(version&gt;=1.1.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.metatype;version="[1.1,2)"</require>
+    <capability name='package'>
+      <p n='package' v='org.apache.felix.dm.context'/>
+      <p n='version' t='version' v='4.3.0'/>
+      <p n='uses:' v='org.apache.felix.dm,org.osgi.framework'/>
+    </capability>
+    <capability name='package'>
+      <p n='package' v='org.apache.felix.dm.diagnostics'/>
+      <p n='version' t='version' v='1.1.0'/>
+      <p n='uses:' v='org.apache.felix.dm'/>
+    </capability>
+    <require name='package' filter='(&amp;(package=org.apache.felix.dm.context)(version&gt;=4.3.0)(!(version&gt;=4.4.0)))' extend='false' multiple='false' optional='false'>Import package org.apache.felix.dm.context;version="[4.3,4.4)"</require>
+    <require name='package' filter='(&amp;(package=org.osgi.framework)(version&gt;=1.8.0)(!(version&gt;=1.9.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.framework;version="[1.8,1.9)"</require>
+    <require name='package' filter='(&amp;(package=org.osgi.service.cm)(version&gt;=1.5.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.cm;version="[1.5,2)"</require>
+    <require name='package' filter='(&amp;(package=org.osgi.service.metatype)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.metatype;version="[1.3,2)"</require>
+    <require name='package' filter='(&amp;(package=org.osgi.util.tracker)(version&gt;=1.5.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.util.tracker;version="[1.5,2)"</require>
   </resource>
   <resource id='org.apache.felix.dependencymanager/3.2.0' symbolicname='org.apache.felix.dependencymanager' presentationname='Apache Felix Dependency Manager' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.dependencymanager/3.2.0/org.apache.felix.dependencymanager-3.2.0.jar' version='3.2.0'>
     <description>Provides dynamic service and component dependency management.</description>
@@ -753,28 +765,97 @@
     <require name='package' filter='(&amp;(package=org.osgi.service.cm)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.cm;version="[1.3,2)"</require>
     <require name='package' filter='(&amp;(package=org.osgi.service.metatype)(version&gt;=1.1.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.metatype;version="[1.1,2)"</require>
   </resource>
-  <resource id='org.apache.felix.dependencymanager.runtime/3.2.0' symbolicname='org.apache.felix.dependencymanager.runtime' presentationname='Apache Felix Dependency Manager Runtime' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.dependencymanager.runtime/3.2.0/org.apache.felix.dependencymanager.runtime-3.2.0.jar' version='3.2.0'>
-    <description>Loads component descriptors from active bundles.</description>
-    <size>104762</size>
+  <resource id='org.apache.felix.dependencymanager/3.0.0' symbolicname='org.apache.felix.dependencymanager' presentationname='Apache Felix Dependency Manager' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.dependencymanager/3.0.0/org.apache.felix.dependencymanager-3.0.0.jar' version='3.0.0'>
+    <description>Provides dynamic service and component dependency management.</description>
+    <size>161118</size>
     <documentation>http://www.apache.org/</documentation>
     <license>http://www.apache.org/licenses/LICENSE-2.0.txt</license>
     <capability name='bundle'>
-      <p n='symbolicname' v='org.apache.felix.dependencymanager.runtime'/>
-      <p n='presentationname' v='Apache Felix Dependency Manager Runtime'/>
-      <p n='version' t='version' v='3.2.0'/>
+      <p n='symbolicname' v='org.apache.felix.dependencymanager'/>
+      <p n='presentationname' v='Apache Felix Dependency Manager'/>
+      <p n='version' t='version' v='3.0.0'/>
       <p n='manifestversion' v='2'/>
     </capability>
-    <require name='package' filter='(&amp;(package=org.apache.felix.dm)(version&gt;=3.1.0)(!(version&gt;=4.0.0)))' extend='false' multiple='false' optional='false'>Import package org.apache.felix.dm;version="[3.1,4)"</require>
-    <require name='package' filter='(&amp;(package=org.osgi.framework)(version&gt;=1.5.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.framework;version="[1.5,2)"</require>
-    <require name='package' filter='(&amp;(package=org.osgi.service.log)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.log;version="[1.3,2)"</require>
-    <require name='package' filter='(&amp;(package=org.osgi.service.packageadmin)(version&gt;=1.2.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.packageadmin;version="[1.2,2)"</require>
-  </resource>
-  <resource id='org.apache.felix.dependencymanager.shell/3.2.0' symbolicname='org.apache.felix.dependencymanager.shell' presentationname='Apache Felix Dependency Manager Shell' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.dependencymanager.shell/3.2.0/org.apache.felix.dependencymanager.shell-3.2.0.jar' version='3.2.0'>
-    <description>Shell command for the dependency manager.</description>
-    <size>21257</size>
-    <documentation>http://www.apache.org/</documentation>
-    <license>http://www.apache.org/licenses/LICENSE-2.0.txt</license>
-    <capability name='bundle'>
+    <capability name='package'>
+      <p n='package' v='org.apache.felix.dm'/>
+      <p n='version' t='version' v='3.0.0'/>
+      <p n='uses:' v='org.osgi.framework'/>
+    </capability>
+    <capability name='package'>
+      <p n='package' v='org.apache.felix.dm.tracker'/>
+      <p n='version' t='version' v='3.0.0'/>
+      <p n='uses:' v='org.osgi.framework,org.apache.felix.dm'/>
+    </capability>
+    <require name='package' filter='(&amp;(package=org.apache.felix.dm.tracker)(version&gt;=3.0.0)(!(version&gt;=3.1.0)))' extend='false' multiple='false' optional='false'>Import package org.apache.felix.dm.tracker;version="[3.0,3.1)"</require>
+    <require name='package' filter='(&amp;(package=org.osgi.framework)(version&gt;=1.5.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.framework;version="[1.5,2)"</require>
+    <require name='package' filter='(&amp;(package=org.osgi.service.cm)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.cm;version="[1.3,2)"</require>
+    <require name='package' filter='(&amp;(package=org.osgi.service.metatype)(version&gt;=1.1.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.metatype;version="[1.1,2)"</require>
+  </resource>
+  <resource id='org.apache.felix.dependencymanager.annotation/4.2.0' symbolicname='org.apache.felix.dependencymanager.annotation' presentationname='Apache Felix Dependency Manager Annotations' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.dependencymanager.annotation/4.2.0/org.apache.felix.dependencymanager.annotation-4.2.0.jar' version='4.2.0'>
+    <description>Annotations for Apache Felix Dependency Manager</description>
+    <size>144478</size>
+    <documentation>http://felix.apache.org/documentation/subprojects/apache-felix-dependency-manager/apache-felix-dependency-manager-using-annotations.html</documentation>
+    <license>http://www.apache.org/licenses/LICENSE-2.0.txt</license>
+    <category id='osgi'/>
+    <capability name='bundle'>
+      <p n='symbolicname' v='org.apache.felix.dependencymanager.annotation'/>
+      <p n='presentationname' v='Apache Felix Dependency Manager Annotations'/>
+      <p n='version' t='version' v='4.2.0'/>
+      <p n='manifestversion' v='2'/>
+    </capability>
+    <capability name='package'>
+      <p n='package' v='org.apache.felix.dm.annotation.api'/>
+      <p n='version' t='version' v='1.2.0'/>
+    </capability>
+    <require name='package' filter='(&amp;(package=aQute.bnd.osgi)(version&gt;=2.3.0)(!(version&gt;=3.0.0)))' extend='false' multiple='false' optional='false'>Import package aQute.bnd.osgi;version="[2.3,3)"</require>
+    <require name='package' filter='(&amp;(package=aQute.bnd.service)(version&gt;=4.1.0)(!(version&gt;=5.0.0)))' extend='false' multiple='false' optional='false'>Import package aQute.bnd.service;version="[4.1,5)"</require>
+    <require name='package' filter='(&amp;(package=aQute.service.reporter)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='false'>Import package aQute.service.reporter;version="[1.0,2)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.felix.dm.annotation.api)(version&gt;=1.2.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='false'>Import package org.apache.felix.dm.annotation.api;version="[1.2,2)"</require>
+  </resource>
+  <resource id='org.apache.felix.dependencymanager.runtime/4.0.4' symbolicname='org.apache.felix.dependencymanager.runtime' presentationname='Apache Felix Dependency Manager Runtime' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.dependencymanager.runtime/4.0.4/org.apache.felix.dependencymanager.runtime-4.0.4.jar' version='4.0.4'>
+    <description>Loads Apache Felix Dependency Manager component descriptors from active annoted bundles</description>
+    <size>132368</size>
+    <license>http://www.apache.org/licenses/LICENSE-2.0.txt</license>
+    <category id='osgi'/>
+    <capability name='bundle'>
+      <p n='symbolicname' v='org.apache.felix.dependencymanager.runtime'/>
+      <p n='presentationname' v='Apache Felix Dependency Manager Runtime'/>
+      <p n='version' t='version' v='4.0.4'/>
+      <p n='manifestversion' v='2'/>
+    </capability>
+    <capability name='package'>
+      <p n='package' v='org.apache.felix.dm.runtime.api'/>
+      <p n='version' t='version' v='1.0.0'/>
+    </capability>
+    <require name='package' filter='(&amp;(package=org.apache.felix.dm)(version&gt;=4.0.0)(!(version&gt;=5.0.0)))' extend='false' multiple='false' optional='false'>Import package org.apache.felix.dm;version="[4,5)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.felix.dm.context)(version&gt;=4.0.0)(!(version&gt;=5.0.0)))' extend='false' multiple='false' optional='false'>Import package org.apache.felix.dm.context;version="[4,5)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.felix.dm.runtime.api)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='false'>Import package org.apache.felix.dm.runtime.api;version="[1.0,2)"</require>
+    <require name='package' filter='(&amp;(package=org.osgi.framework)(version&gt;=1.5.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.framework;version="[1.5,2)"</require>
+    <require name='package' filter='(&amp;(package=org.osgi.service.log)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.log;version="[1.3,2)"</require>
+    <require name='package' filter='(&amp;(package=org.osgi.service.packageadmin)(version&gt;=1.2.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.packageadmin;version="[1.2,2)"</require>
+  </resource>
+  <resource id='org.apache.felix.dependencymanager.runtime/3.2.0' symbolicname='org.apache.felix.dependencymanager.runtime' presentationname='Apache Felix Dependency Manager Runtime' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.dependencymanager.runtime/3.2.0/org.apache.felix.dependencymanager.runtime-3.2.0.jar' version='3.2.0'>
+    <description>Loads component descriptors from active bundles.</description>
+    <size>104762</size>
+    <documentation>http://www.apache.org/</documentation>
+    <license>http://www.apache.org/licenses/LICENSE-2.0.txt</license>
+    <capability name='bundle'>
+      <p n='symbolicname' v='org.apache.felix.dependencymanager.runtime'/>
+      <p n='presentationname' v='Apache Felix Dependency Manager Runtime'/>
+      <p n='version' t='version' v='3.2.0'/>
+      <p n='manifestversion' v='2'/>
+    </capability>
+    <require name='package' filter='(&amp;(package=org.apache.felix.dm)(version&gt;=3.1.0)(!(version&gt;=4.0.0)))' extend='false' multiple='false' optional='false'>Import package org.apache.felix.dm;version="[3.1,4)"</require>
+    <require name='package' filter='(&amp;(package=org.osgi.framework)(version&gt;=1.5.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.framework;version="[1.5,2)"</require>
+    <require name='package' filter='(&amp;(package=org.osgi.service.log)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.log;version="[1.3,2)"</require>
+    <require name='package' filter='(&amp;(package=org.osgi.service.packageadmin)(version&gt;=1.2.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.packageadmin;version="[1.2,2)"</require>
+  </resource>
+  <resource id='org.apache.felix.dependencymanager.shell/3.2.0' symbolicname='org.apache.felix.dependencymanager.shell' presentationname='Apache Felix Dependency Manager Shell' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.dependencymanager.shell/3.2.0/org.apache.felix.dependencymanager.shell-3.2.0.jar' version='3.2.0'>
+    <description>Shell command for the dependency manager.</description>
+    <size>21257</size>
+    <documentation>http://www.apache.org/</documentation>
+    <license>http://www.apache.org/licenses/LICENSE-2.0.txt</license>
+    <capability name='bundle'>
       <p n='symbolicname' v='org.apache.felix.dependencymanager.shell'/>
       <p n='presentationname' v='Apache Felix Dependency Manager Shell'/>
       <p n='version' t='version' v='3.2.0'/>
@@ -784,6 +865,22 @@
     <require name='package' filter='(&amp;(package=org.apache.felix.service.command)(version&gt;=0.10.0)(!(version&gt;=1.0.0))(status=provisional)(mandatory:&lt;*status))' extend='false' multiple='false' optional='false'>Import package org.apache.felix.service.command;status=provisional;version="[0.10,1)"</require>
     <require name='package' filter='(&amp;(package=org.osgi.framework)(version&gt;=1.5.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.framework;version="[1.5,2)"</require>
   </resource>
+  <resource id='org.apache.felix.dependencymanager.shell/4.0.5' symbolicname='org.apache.felix.dependencymanager.shell' presentationname='Apache Felix Dependency Manager Shell' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.dependencymanager.shell/4.0.5/org.apache.felix.dependencymanager.shell-4.0.5.jar' version='4.0.5'>
+    <description>Gogo Shell commands for Apache Felix Dependency Manager</description>
+    <size>32575</size>
+    <license>http://www.apache.org/licenses/LICENSE-2.0.txt</license>
+    <category id='osgi'/>
+    <capability name='bundle'>
+      <p n='symbolicname' v='org.apache.felix.dependencymanager.shell'/>
+      <p n='presentationname' v='Apache Felix Dependency Manager Shell'/>
+      <p n='version' t='version' v='4.0.5'/>
+      <p n='manifestversion' v='2'/>
+    </capability>
+    <require name='package' filter='(&amp;(package=org.apache.felix.dm)(version&gt;=4.0.0)(!(version&gt;=5.0.0)))' extend='false' multiple='false' optional='false'>Import package org.apache.felix.dm;version="[4.0,5)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.felix.dm.diagnostics)(version&gt;=1.1.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='false'>Import package org.apache.felix.dm.diagnostics;version="[1.1,2)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.felix.service.command)(version&gt;=0.10.0)(!(version&gt;=1.0.0))(status=provisional)(mandatory:&lt;*status))' extend='false' multiple='false' optional='false'>Import package org.apache.felix.service.command;version="[0.10,1)";status=provisional</require>
+    <require name='package' filter='(&amp;(package=org.osgi.framework)(version&gt;=1.8.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.framework;version="[1.8,2)"</require>
+  </resource>
   <resource id='org.apache.felix.eventadmin/1.0.0' symbolicname='org.apache.felix.eventadmin' presentationname='Apache Felix EventAdmin' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.eventadmin/1.0.0/org.apache.felix.eventadmin-1.0.0.jar' version='1.0.0'>
     <description>This bundle provides an implementation of the OSGi R4 EventAdmin service.</description>
     <size>73643</size>
@@ -992,6 +1089,31 @@
     <require name='package' filter='(&amp;(package=org.osgi.service.startlevel)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.startlevel ;version=[1.0.0,2.0.0)</require>
     <require name='package' filter='(&amp;(package=org.osgi.util.tracker)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.util.tracker ;version=[1.3.0,2.0.0)</require>
   </resource>
+  <resource id='org.apache.felix.fileinstall/2.0.8' symbolicname='org.apache.felix.fileinstall' presentationname='Apache Felix File Install' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.fileinstall/2.0.8/org.apache.felix.fileinstall-2.0.8.jar' version='2.0.8'>
+    <description>A utility to automatically install bundles from a directory.</description>
+    <size>46376</size>
+    <documentation>http://www.apache.org/</documentation>
+    <license>http://www.apache.org/licenses/LICENSE-2.0.txt</license>
+    <category id='org.apache.felix'/>
+    <capability name='bundle'>
+      <p n='manifestversion' v='2'/>
+      <p n='presentationname' v='Apache Felix File Install'/>
+      <p n='symbolicname' v='org.apache.felix.fileinstall'/>
+      <p n='version' t='version' v='2.0.8'/>
+    </capability>
+    <capability name='package'>
+      <p n='package' v='org.apache.felix.fileinstall'/>
+      <p n='version' t='version' v='2.0.8'/>
+    </capability>
+    <require name='package' filter='(&amp;(package=org.apache.felix.fileinstall)(version&gt;=2.0.0)(!(version&gt;=3.0.0)))' extend='false' multiple='false' optional='false'>Import package org.apache.felix.fileinstall ;version=[2.0.0,3.0.0)</require>
+    <require name='package' filter='(&amp;(package=org.osgi.framework)(version&gt;=1.4.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.framework ;version=[1.4.0,2.0.0)</require>
+    <require name='package' filter='(&amp;(package=org.osgi.service.cm)(version&gt;=1.2.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='true'>Import package org.osgi.service.cm ;version=[1.2.0,2.0.0)</require>
+    <require name='package' filter='(&amp;(package=org.osgi.service.log)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='true'>Import package org.osgi.service.log ;version=[1.3.0,2.0.0)</require>
+    <require name='package' filter='(&amp;(package=org.osgi.service.packageadmin)(version&gt;=1.2.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.packageadmin ;version=[1.2.0,2.0.0)</require>
+    <require name='package' filter='(&amp;(package=org.osgi.service.startlevel)(version&gt;=1.1.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.startlevel ;version=[1.1.0,2.0.0)</require>
+    <require name='package' filter='(&amp;(package=org.osgi.service.url)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.url ;version=[1.0.0,2.0.0)</require>
+    <require name='package' filter='(&amp;(package=org.osgi.util.tracker)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.util.tracker ;version=[1.3.0,2.0.0)</require>
+  </resource>
   <resource id='org.apache.felix.fileinstall/0.9.0' symbolicname='org.apache.felix.fileinstall' presentationname='Apache Felix File Install' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.fileinstall/0.9.0/org.apache.felix.fileinstall-0.9.0.jar' version='0.9.0'>
     <description>A utility to automatically install bundles from a directory.</description>
     <size>26271</size>
@@ -1065,34 +1187,9 @@
     <require name='package' filter='(&amp;(package=org.osgi.service.packageadmin)(version&gt;=1.2.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.packageadmin ;version=1.2.0</require>
     <require name='package' filter='(&amp;(package=org.osgi.util.tracker)(version&gt;=1.3.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.util.tracker ;version=1.3.0</require>
   </resource>
-  <resource id='org.apache.felix.fileinstall/2.0.8' symbolicname='org.apache.felix.fileinstall' presentationname='Apache Felix File Install' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.fileinstall/2.0.8/org.apache.felix.fileinstall-2.0.8.jar' version='2.0.8'>
-    <description>A utility to automatically install bundles from a directory.</description>
-    <size>46376</size>
-    <documentation>http://www.apache.org/</documentation>
-    <license>http://www.apache.org/licenses/LICENSE-2.0.txt</license>
-    <category id='org.apache.felix'/>
-    <capability name='bundle'>
-      <p n='manifestversion' v='2'/>
-      <p n='presentationname' v='Apache Felix File Install'/>
-      <p n='symbolicname' v='org.apache.felix.fileinstall'/>
-      <p n='version' t='version' v='2.0.8'/>
-    </capability>
-    <capability name='package'>
-      <p n='package' v='org.apache.felix.fileinstall'/>
-      <p n='version' t='version' v='2.0.8'/>
-    </capability>
-    <require name='package' filter='(&amp;(package=org.apache.felix.fileinstall)(version&gt;=2.0.0)(!(version&gt;=3.0.0)))' extend='false' multiple='false' optional='false'>Import package org.apache.felix.fileinstall ;version=[2.0.0,3.0.0)</require>
-    <require name='package' filter='(&amp;(package=org.osgi.framework)(version&gt;=1.4.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.framework ;version=[1.4.0,2.0.0)</require>
-    <require name='package' filter='(&amp;(package=org.osgi.service.cm)(version&gt;=1.2.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='true'>Import package org.osgi.service.cm ;version=[1.2.0,2.0.0)</require>
-    <require name='package' filter='(&amp;(package=org.osgi.service.log)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='true'>Import package org.osgi.service.log ;version=[1.3.0,2.0.0)</require>
-    <require name='package' filter='(&amp;(package=org.osgi.service.packageadmin)(version&gt;=1.2.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.packageadmin ;version=[1.2.0,2.0.0)</require>
-    <require name='package' filter='(&amp;(package=org.osgi.service.startlevel)(version&gt;=1.1.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.startlevel ;version=[1.1.0,2.0.0)</require>
-    <require name='package' filter='(&amp;(package=org.osgi.service.url)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.url ;version=[1.0.0,2.0.0)</require>
-    <require name='package' filter='(&amp;(package=org.osgi.util.tracker)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))' extend='false' multiple='false' optional='false'>Import package org.osgi.util.tracker ;version=[1.3.0,2.0.0)</require>
-  </resource>
-  <resource id='org.apache.felix.gogo.command/0.10.0' symbolicname='org.apache.felix.gogo.command' presentationname='Apache Felix Gogo Command' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.gogo.command/0.10.0/org.apache.felix.gogo.command-0.10.0.jar' version='0.10.0'>
+  <resource id='org.apache.felix.gogo.command/0.6.1' symbolicname='org.apache.felix.gogo.command' presentationname='Apache Felix Gogo Command' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.gogo.command/0.6.1/org.apache.felix.gogo.command-0.6.1.jar' version='0.6.1'>
     <description>Provides basic shell commands for Gogo.</description>
-    <size>45536</size>
+    <size>45464</size>
     <documentation>http://www.apache.org/</documentation>
     <license>http://www.apache.org/licenses/LICENSE-2.0.txt</license>
     <category id='org.apache.felix'/>
@@ -1100,23 +1197,23 @@
       <p n='manifestversion' v='2'/>
       <p n='presentationname' v='Apache Felix Gogo Command'/>
       <p n='symbolicname' v='org.apache.felix.gogo.command'/>
-      <p n='version' t='version' v='0.10.0'/>
+      <p n='version' t='version' v='0.6.1'/>
     </capability>
     <capability name='package'>
       <p n='package' v='org.osgi.service.log'/>
       <p n='uses:' v='org.osgi.framework'/>
       <p n='version' t='version' v='1.3.0'/>
     </capability>
-    <require name='package' filter='(&amp;(package=org.apache.felix.service.command)(version&gt;=0.10.0)(status=provisional)(mandatory:&lt;*status))' extend='false' multiple='false' optional='false'>Import package org.apache.felix.service.command ;version=0.10.0</require>
+    <require name='package' filter='(&amp;(package=org.apache.felix.service.command)(version&gt;=0.6.0)(status=provisional)(mandatory:&lt;*status))' extend='false' multiple='false' optional='false'>Import package org.apache.felix.service.command ;version=0.6.0</require>
     <require name='package' filter='(&amp;(package=org.osgi.framework)(version&gt;=1.5.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.framework ;version=1.5.0</require>
     <require name='package' filter='(&amp;(package=org.osgi.service.log)(version&gt;=1.3.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.log ;version=1.3.0</require>
     <require name='package' filter='(&amp;(package=org.osgi.service.packageadmin)(version&gt;=1.2.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.packageadmin ;version=1.2.0</require>
     <require name='package' filter='(&amp;(package=org.osgi.service.startlevel)(version&gt;=1.1.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.startlevel ;version=1.1.0</require>
     <require name='package' filter='(&amp;(package=org.osgi.util.tracker)(version&gt;=1.3.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.util.tracker ;version=1.3.0</require>
   </resource>
-  <resource id='org.apache.felix.gogo.command/0.8.0' symbolicname='org.apache.felix.gogo.command' presentationname='Apache Felix Gogo Command' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.gogo.command/0.8.0/org.apache.felix.gogo.command-0.8.0.jar' version='0.8.0'>
+  <resource id='org.apache.felix.gogo.command/0.6.0' symbolicname='org.apache.felix.gogo.command' presentationname='Apache Felix Gogo Command' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.gogo.command/0.6.0/org.apache.felix.gogo.command-0.6.0.jar' version='0.6.0'>
     <description>Provides basic shell commands for Gogo.</description>
-    <size>45466</size>
+    <size>45415</size>
     <documentation>http://www.apache.org/</documentation>
     <license>http://www.apache.org/licenses/LICENSE-2.0.txt</license>
     <category id='org.apache.felix'/>
@@ -1124,23 +1221,23 @@
       <p n='manifestversion' v='2'/>
       <p n='presentationname' v='Apache Felix Gogo Command'/>
       <p n='symbolicname' v='org.apache.felix.gogo.command'/>
-      <p n='version' t='version' v='0.8.0'/>
+      <p n='version' t='version' v='0.6.0'/>
     </capability>
     <capability name='package'>
       <p n='package' v='org.osgi.service.log'/>
       <p n='uses:' v='org.osgi.framework'/>
       <p n='version' t='version' v='1.3.0'/>
     </capability>
-    <require name='package' filter='(&amp;(package=org.apache.felix.service.command)(version&gt;=0.8.0)(status=provisional)(mandatory:&lt;*status))' extend='false' multiple='false' optional='false'>Import package org.apache.felix.service.command ;version=0.8.0</require>
+    <require name='package' filter='(&amp;(package=org.apache.felix.service.command)(version&gt;=0.6.0))' extend='false' multiple='false' optional='false'>Import package org.apache.felix.service.command ;version=0.6.0</require>
     <require name='package' filter='(&amp;(package=org.osgi.framework)(version&gt;=1.5.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.framework ;version=1.5.0</require>
     <require name='package' filter='(&amp;(package=org.osgi.service.log)(version&gt;=1.3.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.log ;version=1.3.0</require>
     <require name='package' filter='(&amp;(package=org.osgi.service.packageadmin)(version&gt;=1.2.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.packageadmin ;version=1.2.0</require>
     <require name='package' filter='(&amp;(package=org.osgi.service.startlevel)(version&gt;=1.1.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.startlevel ;version=1.1.0</require>
     <require name='package' filter='(&amp;(package=org.osgi.util.tracker)(version&gt;=1.3.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.util.tracker ;version=1.3.0</require>
   </resource>
-  <resource id='org.apache.felix.gogo.command/0.6.1' symbolicname='org.apache.felix.gogo.command' presentationname='Apache Felix Gogo Command' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.gogo.command/0.6.1/org.apache.felix.gogo.command-0.6.1.jar' version='0.6.1'>
+  <resource id='org.apache.felix.gogo.command/0.10.0' symbolicname='org.apache.felix.gogo.command' presentationname='Apache Felix Gogo Command' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.gogo.command/0.10.0/org.apache.felix.gogo.command-0.10.0.jar' version='0.10.0'>
     <description>Provides basic shell commands for Gogo.</description>
-    <size>45464</size>
+    <size>45536</size>
     <documentation>http://www.apache.org/</documentation>
     <license>http://www.apache.org/licenses/LICENSE-2.0.txt</license>
     <category id='org.apache.felix'/>
@@ -1148,23 +1245,23 @@
       <p n='manifestversion' v='2'/>
       <p n='presentationname' v='Apache Felix Gogo Command'/>
       <p n='symbolicname' v='org.apache.felix.gogo.command'/>
-      <p n='version' t='version' v='0.6.1'/>
+      <p n='version' t='version' v='0.10.0'/>
     </capability>
     <capability name='package'>
       <p n='package' v='org.osgi.service.log'/>
       <p n='uses:' v='org.osgi.framework'/>
       <p n='version' t='version' v='1.3.0'/>
     </capability>
-    <require name='package' filter='(&amp;(package=org.apache.felix.service.command)(version&gt;=0.6.0)(status=provisional)(mandatory:&lt;*status))' extend='false' multiple='false' optional='false'>Import package org.apache.felix.service.command ;version=0.6.0</require>
+    <require name='package' filter='(&amp;(package=org.apache.felix.service.command)(version&gt;=0.10.0)(status=provisional)(mandatory:&lt;*status))' extend='false' multiple='false' optional='false'>Import package org.apache.felix.service.command ;version=0.10.0</require>
     <require name='package' filter='(&amp;(package=org.osgi.framework)(version&gt;=1.5.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.framework ;version=1.5.0</require>
     <require name='package' filter='(&amp;(package=org.osgi.service.log)(version&gt;=1.3.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.log ;version=1.3.0</require>
     <require name='package' filter='(&amp;(package=org.osgi.service.packageadmin)(version&gt;=1.2.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.packageadmin ;version=1.2.0</require>
     <require name='package' filter='(&amp;(package=org.osgi.service.startlevel)(version&gt;=1.1.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.startlevel ;version=1.1.0</require>
     <require name='package' filter='(&amp;(package=org.osgi.util.tracker)(version&gt;=1.3.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.util.tracker ;version=1.3.0</require>
   </resource>
-  <resource id='org.apache.felix.gogo.command/0.6.0' symbolicname='org.apache.felix.gogo.command' presentationname='Apache Felix Gogo Command' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.gogo.command/0.6.0/org.apache.felix.gogo.command-0.6.0.jar' version='0.6.0'>
+  <resource id='org.apache.felix.gogo.command/0.8.0' symbolicname='org.apache.felix.gogo.command' presentationname='Apache Felix Gogo Command' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.gogo.command/0.8.0/org.apache.felix.gogo.command-0.8.0.jar' version='0.8.0'>
     <description>Provides basic shell commands for Gogo.</description>
-    <size>45415</size>
+    <size>45466</size>
     <documentation>http://www.apache.org/</documentation>
     <license>http://www.apache.org/licenses/LICENSE-2.0.txt</license>
     <category id='org.apache.felix'/>
@@ -1172,23 +1269,23 @@
       <p n='manifestversion' v='2'/>
       <p n='presentationname' v='Apache Felix Gogo Command'/>
       <p n='symbolicname' v='org.apache.felix.gogo.command'/>
-      <p n='version' t='version' v='0.6.0'/>
+      <p n='version' t='version' v='0.8.0'/>
     </capability>
     <capability name='package'>
       <p n='package' v='org.osgi.service.log'/>
       <p n='uses:' v='org.osgi.framework'/>
       <p n='version' t='version' v='1.3.0'/>
     </capability>
-    <require name='package' filter='(&amp;(package=org.apache.felix.service.command)(version&gt;=0.6.0))' extend='false' multiple='false' optional='false'>Import package org.apache.felix.service.command ;version=0.6.0</require>
+    <require name='package' filter='(&amp;(package=org.apache.felix.service.command)(version&gt;=0.8.0)(status=provisional)(mandatory:&lt;*status))' extend='false' multiple='false' optional='false'>Import package org.apache.felix.service.command ;version=0.8.0</require>
     <require name='package' filter='(&amp;(package=org.osgi.framework)(version&gt;=1.5.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.framework ;version=1.5.0</require>
     <require name='package' filter='(&amp;(package=org.osgi.service.log)(version&gt;=1.3.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.log ;version=1.3.0</require>
     <require name='package' filter='(&amp;(package=org.osgi.service.packageadmin)(version&gt;=1.2.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.packageadmin ;version=1.2.0</require>
     <require name='package' filter='(&amp;(package=org.osgi.service.startlevel)(version&gt;=1.1.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.service.startlevel ;version=1.1.0</require>
     <require name='package' filter='(&amp;(package=org.osgi.util.tracker)(version&gt;=1.3.0))' extend='false' multiple='false' optional='false'>Import package org.osgi.util.tracker ;version=1.3.0</require>
   </resource>
-  <resource id='org.apache.felix.gogo.runtime/0.10.0' symbolicname='org.apache.felix.gogo.runtime' presentationname='Apache Felix Gogo Runtime' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.gogo.runtime/0.10.0/org.apache.felix.gogo.runtime-0.10.0.jar' version='0.10.0'>
+  <resource id='org.apache.felix.gogo.runtime/0.8.0' symbolicname='org.apache.felix.gogo.runtime' presentationname='Apache Felix Gogo Runtime' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.gogo.runtime/0.8.0/org.apache.felix.gogo.runtime-0.8.0.jar' version='0.8.0'>
     <description>Apache Felix Gogo Subproject</description>
-    <size>66969</size>
+    <size>66696</size>
     <documentation>http://www.apache.org/</documentation>
     <license>http://www.apache.org/licenses/LICENSE-2.0.txt</license>
     <category id='org.apache.felix'/>
@@ -1196,35 +1293,35 @@
       <p n='manifestversion' v='2'/>
       <p n='presentationname' v='Apache Felix Gogo Runtime'/>
       <p n='symbolicname' v='org.apache.felix.gogo.runtime'/>
-      <p n='version' t='version' v='0.10.0'/>
+      <p n='version' t='version' v='0.8.0'/>
     </capability>
     <capability name='package'>
       <p n='mandatory:' v='status'/>
       <p n='package' v='org.apache.felix.service.command'/>
       <p n='status' v='provisional'/>
-      <p n='version' t='version' v='0.10.0'/>
+      <p n='version' t='version' v='0.8.0'/>
     </capability>
     <capability name='package'>
       <p n='package' v='org.apache.felix.gogo.api'/>
       <p n='uses:' v='org.apache.felix.service.command'/>
-      <p n='version' t='version' v='0.10.0'/>
+      <p n='version' t='version' v='0.8.0'/>
     </capability>
     <capability name='package'>
       <p n='mandatory:' v='status'/>
       <p n='package' v='org.apache.felix.service.threadio'/>
       <p n='status' v='provisional'/>
-      <p n='version' t='version' v='0.10.0'/>
+      <p n='version' t='version' v='0.8.0'/>
     </capability>
-    <require name='package' filter='(&amp;(package=org.apache.felix.gogo.api)(version&gt;=0.10.0))' extend='false' multiple='false' optional='false'>Import package org.apache.felix.gogo.api ;version=0.10.0</require>
-    <require name='package' filter='(&amp;(package=org.apache.felix.service.command)(version&gt;=0.10.0)(status=provisional)(mandatory:&lt;*status))' extend='false' multiple='false' optional='false'>Import package org.apache.felix.service.command ;version=0.10.0</require>
-    <require name='package' filter='(&amp;(package=org.apache.felix.service.threadio)(version&gt;=0.10.0)(status=provisional)(mandatory:&lt;*status))' extend='false' multiple='false' optional='false'>Import package org.apache.felix.service.threadio ;version=0.10.0</require>
+    <require name='package' filter='(&amp;(package=org.apache.felix.gogo.api)(version&gt;=0.8.0))' extend='false' multiple='false' optional='false'>Import package org.apache.felix.gogo.api ;version=0.8.0</require>
+    <require name='package' filter='(&amp;(package=org.apache.felix.service.command)(version&gt;=0.8.0)(status=provisional)(mandatory:&lt;*status))' extend='false' multiple='false' optional='false'>Import package org.apache.felix.service.command ;version=0.8.0</require>
+    <require name='package' filter='(&amp;(package=org.apache.felix.service.threadio)(version&gt;=0.8.0)(status=provisional)(mandatory:&lt;*status))' extend='false' multiple='false' optional='false'>Import package org.apache.felix.service.threadio ;version=0.8.0</require>
     <require name='package' filter='(&amp;(package=org.osgi.framework))' extend='false' multiple='false' optional='false'>Import package org.osgi.framework</require>
     <require name='package' filter='(&amp;(package=org.osgi.service.event))' extend='false' multiple='false' optional='true'>Import package org.osgi.service.event</require>
     <require name='package' filter='(&amp;(package=org.osgi.util.tracker))' extend='false' multiple='false' optional='false'>Import package org.osgi.util.tracker</require>
   </resource>
-  <resource id='org.apache.felix.gogo.runtime/0.8.0' symbolicname='org.apache.felix.gogo.runtime' presentationname='Apache Felix Gogo Runtime' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.gogo.runtime/0.8.0/org.apache.felix.gogo.runtime-0.8.0.jar' version='0.8.0'>
+  <resource id='org.apache.felix.gogo.runtime/0.10.0' symbolicname='org.apache.felix.gogo.runtime' presentationname='Apache Felix Gogo Runtime' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.gogo.runtime/0.10.0/org.apache.felix.gogo.runtime-0.10.0.jar' version='0.10.0'>
     <description>Apache Felix Gogo Subproject</description>
-    <size>66696</size>
+    <size>66969</size>
     <documentation>http://www.apache.org/</documentation>
     <license>http://www.apache.org/licenses/LICENSE-2.0.txt</license>
     <category id='org.apache.felix'/>
@@ -1232,28 +1329,28 @@
       <p n='manifestversion' v='2'/>
       <p n='presentationname' v='Apache Felix Gogo Runtime'/>
       <p n='symbolicname' v='org.apache.felix.gogo.runtime'/>
-      <p n='version' t='version' v='0.8.0'/>
+      <p n='version' t='version' v='0.10.0'/>
     </capability>
     <capability name='package'>
       <p n='mandatory:' v='status'/>
       <p n='package' v='org.apache.felix.service.command'/>
       <p n='status' v='provisional'/>
-      <p n='version' t='version' v='0.8.0'/>
+      <p n='version' t='version' v='0.10.0'/>
     </capability>
     <capability name='package'>
       <p n='package' v='org.apache.felix.gogo.api'/>
       <p n='uses:' v='org.apache.felix.service.command'/>
-      <p n='version' t='version' v='0.8.0'/>
+      <p n='version' t='version' v='0.10.0'/>
     </capability>
     <capability name='package'>
       <p n='mandatory:' v='status'/>
       <p n='package' v='org.apache.felix.service.threadio'/>
       <p n='status' v='provisional'/>
-      <p n='version' t='version' v='0.8.0'/>
+      <p n='version' t='version' v='0.10.0'/>
     </capability>
-    <require name='package' filter='(&amp;(package=org.apache.felix.gogo.api)(version&gt;=0.8.0))' extend='false' multiple='false' optional='false'>Import package org.apache.felix.gogo.api ;version=0.8.0</require>
-    <require name='package' filter='(&amp;(package=org.apache.felix.service.command)(version&gt;=0.8.0)(status=provisional)(mandatory:&lt;*status))' extend='false' multiple='false' optional='false'>Import package org.apache.felix.service.command ;version=0.8.0</require>
-    <require name='package' filter='(&amp;(package=org.apache.felix.service.threadio)(version&gt;=0.8.0)(status=provisional)(mandatory:&lt;*status))' extend='false' multiple='false' optional='false'>Import package org.apache.felix.service.threadio ;version=0.8.0</require>
+    <require name='package' filter='(&amp;(package=org.apache.felix.gogo.api)(version&gt;=0.10.0))' extend='false' multiple='false' optional='false'>Import package org.apache.felix.gogo.api ;version=0.10.0</require>
+    <require name='package' filter='(&amp;(package=org.apache.felix.service.command)(version&gt;=0.10.0)(status=provisional)(mandatory:&lt;*status))' extend='false' multiple='false' optional='false'>Import package org.apache.felix.service.command ;version=0.10.0</require>
+    <require name='package' filter='(&amp;(package=org.apache.felix.service.threadio)(version&gt;=0.10.0)(status=provisional)(mandatory:&lt;*status))' extend='false' multiple='false' optional='false'>Import package org.apache.felix.service.threadio ;version=0.10.0</require>
     <require name='package' filter='(&amp;(package=org.osgi.framework))' extend='false' multiple='false' optional='false'>Import package org.osgi.framework</require>
     <require name='package' filter='(&amp;(package=org.osgi.service.event))' extend='false' multiple='false' optional='true'>Import package org.osgi.service.event</require>
     <require name='package' filter='(&amp;(package=org.osgi.util.tracker))' extend='false' multiple='false' optional='false'>Import package org.osgi.util.tracker</require>
@@ -1845,75 +1942,62 @@
     <require name='package' filter='(&amp;(package=org.osgi.service.log)(version&gt;=1.3.0))' extend='false' multiple='false' optional='true'>Import package org.osgi.service.log ;version=1.3.0</require>
     <require name='package' filter='(&amp;(package=org.osgi.util.tracker)(version&gt;=1.3.0))' extend='false' multiple='false' optional='true'>Import package org.osgi.util.tracker ;version=1.3.0</require>
   </resource>
-  <resource id='org.apache.felix.ipojo/1.8.0' symbolicname='org.apache.felix.ipojo' presentationname='Apache Felix iPOJO' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.ipojo/1.8.0/org.apache.felix.ipojo-1.8.0.jar' version='1.8.0'>
+  <resource id='org.apache.felix.org.apache.felix.ipojo/0.8.0' symbolicname='org.apache.felix.org.apache.felix.ipojo' presentationname='Apache Felix iPOJO' uri='http://repo1.maven.org/maven2/org/apache/felix/org.apache.felix.ipojo/0.8.0/org.apache.felix.ipojo-0.8.0.jar' version='0.8.0'>
     <description>iPOJO Core Framework</description>
-    <size>278056</size>
+    <size>181570</size>
     <documentation>http://felix.apache.org/site/apache-felix-ipojo.html</documentation>
     <license>http://www.apache.org/licenses/LICENSE-2.0.txt</license>
     <category id='org.apache.felix'/>
     <capability name='ipojo.handler'>
       <p n='name' v='controller'/>
       <p n='namespace' v='org.apache.felix.ipojo'/>
+      <p n='type' v='primitive'/>
     </capability>
     <capability name='ipojo.handler'>
       <p n='name' v='callback'/>
       <p n='namespace' v='org.apache.felix.ipojo'/>
+      <p n='type' v='primitive'/>
     </capability>
     <capability name='ipojo.handler'>
       <p n='name' v='requires'/>
       <p n='namespace' v='org.apache.felix.ipojo'/>
+      <p n='type' v='primitive'/>
     </capability>
     <capability name='ipojo.handler'>
       <p n='name' v='provides'/>
       <p n='namespace' v='org.apache.felix.ipojo'/>
+      <p n='type' v='primitive'/>
     </capability>
     <capability name='ipojo.handler'>
       <p n='name' v='properties'/>
       <p n='namespace' v='org.apache.felix.ipojo'/>
+      <p n='type' v='primitive'/>
     </capability>
     <capability name='ipojo.handler'>
       <p n='name' v='architecture'/>
       <p n='namespace' v='org.apache.felix.ipojo'/>
+      <p n='type' v='primitive'/>
     </capability>
     <capability name='bundle'>
       <p n='manifestversion' v='2'/>

[... 2505 lines stripped ...]


Mime
View raw message