felix-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rickh...@apache.org
Subject svn commit: r760215 - in /felix/trunk/bundlerepository/src/test: java/org/apache/felix/bundlerepository/MockBundleContext.java java/org/apache/felix/bundlerepository/ResolverImplTest.java resources/repo_for_resolvertest.xml
Date Mon, 30 Mar 2009 22:51:58 GMT
Author: rickhall
Date: Mon Mar 30 22:51:57 2009
New Revision: 760215

URL: http://svn.apache.org/viewvc?rev=760215&view=rev
Log:
Forgot to add these test cases from patch. (FELIX-977)

Added:
    felix/trunk/bundlerepository/src/test/java/org/apache/felix/bundlerepository/MockBundleContext.java
    felix/trunk/bundlerepository/src/test/java/org/apache/felix/bundlerepository/ResolverImplTest.java
    felix/trunk/bundlerepository/src/test/resources/repo_for_resolvertest.xml

Added: felix/trunk/bundlerepository/src/test/java/org/apache/felix/bundlerepository/MockBundleContext.java
URL: http://svn.apache.org/viewvc/felix/trunk/bundlerepository/src/test/java/org/apache/felix/bundlerepository/MockBundleContext.java?rev=760215&view=auto
==============================================================================
--- felix/trunk/bundlerepository/src/test/java/org/apache/felix/bundlerepository/MockBundleContext.java (added)
+++ felix/trunk/bundlerepository/src/test/java/org/apache/felix/bundlerepository/MockBundleContext.java Mon Mar 30 22:51:57 2009
@@ -0,0 +1,165 @@
+/* 
+ * Licensed to the Apache Software Foundation (ASF) under one
+ * or more contributor license agreements.  See the NOTICE file
+ * distributed with this work for additional information
+ * regarding copyright ownership.  The ASF licenses this file
+ * to you under the Apache License, Version 2.0 (the
+ * "License"); you may not use this file except in compliance
+ * with the License.  You may obtain a copy of the License at
+ *
+ *   http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing,
+ * software distributed under the License is distributed on an
+ * "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+ * KIND, either express or implied.  See the License for the
+ * specific language governing permissions and limitations
+ * under the License.
+ */
+package org.apache.felix.bundlerepository;
+
+import java.io.File;
+import java.io.InputStream;
+import java.net.URL;
+import java.util.Dictionary;
+
+import org.osgi.framework.Bundle;
+import org.osgi.framework.BundleContext;
+import org.osgi.framework.BundleListener;
+import org.osgi.framework.Filter;
+import org.osgi.framework.FrameworkListener;
+import org.osgi.framework.ServiceListener;
+import org.osgi.framework.ServiceReference;
+import org.osgi.framework.ServiceRegistration;
+
+public class MockBundleContext implements BundleContext
+{
+    public void addBundleListener(BundleListener arg0)
+    {
+    }
+
+    public void addFrameworkListener(FrameworkListener arg0)
+    {
+    }
+
+    public void addServiceListener(ServiceListener arg0)
+    {
+    }
+
+    public void addServiceListener(ServiceListener arg0, String arg1)
+    {
+    }
+
+    public Filter createFilter(String arg0)
+    {
+        // returns a match-all filter always
+        return new Filter()
+        {
+            public boolean matchCase(Dictionary arg0)
+            {
+                return true;
+            }
+
+            public boolean match(Dictionary arg0)
+            {
+                return true;
+            }
+
+            public boolean match(ServiceReference arg0)
+            {
+                return true;
+            }
+        };
+    }
+
+    public ServiceReference[] getAllServiceReferences(String arg0, String arg1)
+    {
+        return null;
+    }
+
+    public Bundle getBundle()
+    {
+        return null;
+    }
+
+    public Bundle getBundle(long arg0)
+    {
+        return null;
+    }
+
+    public Bundle[] getBundles()
+    {
+        return null;
+    }
+
+    public File getDataFile(String arg0)
+    {
+        return null;
+    }
+
+    public String getProperty(String name)
+    {
+        if (RepositoryAdminImpl.REPOSITORY_URL_PROP.equals(name))
+        {
+            URL url = getClass().getResource("/referred.xml");
+            if (url != null)
+            {
+                return url.toExternalForm();
+            }
+        }
+
+        return null;
+    }
+
+    public Object getService(ServiceReference arg0)
+    {
+        return null;
+    }
+
+    public ServiceReference getServiceReference(String arg0)
+    {
+        return null;
+    }
+
+    public ServiceReference[] getServiceReferences(String arg0, String arg1)
+    {
+        return null;
+    }
+
+    public Bundle installBundle(String arg0)
+    {
+        return null;
+    }
+
+    public Bundle installBundle(String arg0, InputStream arg1)
+    {
+        return null;
+    }
+
+    public ServiceRegistration registerService(String[] arg0, Object arg1, Dictionary arg2)
+    {
+        return null;
+    }
+
+    public ServiceRegistration registerService(String arg0, Object arg1, Dictionary arg2)
+    {
+        return null;
+    }
+
+    public void removeBundleListener(BundleListener arg0)
+    {
+    }
+
+    public void removeFrameworkListener(FrameworkListener arg0)
+    {
+    }
+
+    public void removeServiceListener(ServiceListener arg0)
+    {
+    }
+
+    public boolean ungetService(ServiceReference arg0)
+    {
+        return false;
+    }
+}
\ No newline at end of file

Added: felix/trunk/bundlerepository/src/test/java/org/apache/felix/bundlerepository/ResolverImplTest.java
URL: http://svn.apache.org/viewvc/felix/trunk/bundlerepository/src/test/java/org/apache/felix/bundlerepository/ResolverImplTest.java?rev=760215&view=auto
==============================================================================
--- felix/trunk/bundlerepository/src/test/java/org/apache/felix/bundlerepository/ResolverImplTest.java (added)
+++ felix/trunk/bundlerepository/src/test/java/org/apache/felix/bundlerepository/ResolverImplTest.java Mon Mar 30 22:51:57 2009
@@ -0,0 +1,77 @@
+/*
+ * Licensed to the Apache Software Foundation (ASF) under one
+ * or more contributor license agreements.  See the NOTICE file
+ * distributed with this work for additional information
+ * regarding copyright ownership.  The ASF licenses this file
+ * to you under the Apache License, Version 2.0 (the
+ * "License"); you may not use this file except in compliance
+ * with the License.  You may obtain a copy of the License at
+ *
+ *   http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing,
+ * software distributed under the License is distributed on an
+ * "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+ * KIND, either express or implied.  See the License for the
+ * specific language governing permissions and limitations
+ * under the License.
+ */
+package org.apache.felix.bundlerepository;
+
+import java.net.URL;
+
+import junit.framework.TestCase;
+
+import org.osgi.service.obr.Repository;
+import org.osgi.service.obr.Resolver;
+import org.osgi.service.obr.Resource;
+
+public class ResolverImplTest extends TestCase
+{
+    public void testReferral1() throws Exception
+    {
+
+        URL url = getClass().getResource("/repo_for_resolvertest.xml");
+        RepositoryAdminImpl repoAdmin = createRepositoryAdmin();
+        RepositoryImpl repo = (RepositoryImpl) repoAdmin.addRepository(url);
+
+        Resolver resolver = repoAdmin.resolver();
+
+        Resource r = null;
+        //MockContext doesn't support filtering!
+        Resource[] discoverResources = repoAdmin.discoverResources("");
+        for (int i = 0; i < discoverResources.length; i++) {
+            Resource resource = discoverResources[i];
+            if (resource.getSymbolicName().contains("org.apache.felix.test"))
+            {
+                r = resource;
+            }
+        }
+
+        resolver.add(r);
+        assertTrue(resolver.resolve());
+
+    }
+
+    public static void main(String[] args) throws Exception {
+
+        new ResolverImplTest().testReferral1();
+
+    }
+
+    private RepositoryAdminImpl createRepositoryAdmin()
+    {
+        final MockBundleContext bundleContext = new MockBundleContext();
+        RepositoryAdminImpl repoAdmin = new RepositoryAdminImpl(bundleContext, new Logger(bundleContext));
+
+        // force initialization && remove all initial repositories
+        Repository[] repos = repoAdmin.listRepositories();
+        for (int i = 0; repos != null && i < repos.length; i++)
+        {
+            repoAdmin.removeRepository(repos[i].getURL());
+        }
+
+        return repoAdmin;
+    }
+
+}
\ No newline at end of file

Added: felix/trunk/bundlerepository/src/test/resources/repo_for_resolvertest.xml
URL: http://svn.apache.org/viewvc/felix/trunk/bundlerepository/src/test/resources/repo_for_resolvertest.xml?rev=760215&view=auto
==============================================================================
--- felix/trunk/bundlerepository/src/test/resources/repo_for_resolvertest.xml (added)
+++ felix/trunk/bundlerepository/src/test/resources/repo_for_resolvertest.xml Mon Mar 30 22:51:57 2009
@@ -0,0 +1,1033 @@
+<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
+<repository lastmodified="20090306073223.859" name="MyRepository">
+
+    <resource id="dummy/1.0.0.SNAPSHOT"
+        presentationname="dummy"
+        symbolicname="dummy"
+        uri="/sontswo"
+        version="1.0.0.SNAPSHOT">
+        <description />
+        <size>42</size>
+        <category id="dummy" />
+        <capability name="bundle">
+            <p n="manifestversion" v="2" />
+            <p n="presentationname"
+                v="Unnamed - dummy" />
+            <p n="symbolicname" v="dummy" />
+            <p n="version" t="version" v="1.0.0.SNAPSHOT" />
+        </capability>
+        <capability name="package">
+            <p n="package" v="javax.naming" />
+            <p n="version" t="version" v="0.0.0" />
+        </capability>
+        <capability name="package">
+            <p n="package" v="javax.naming.event" />
+            <p n="version" t="version" v="0.0.0" />
+        </capability>
+        <capability name="package">
+            <p n="package" v="javax.naming.spi" />
+            <p n="version" t="version" v="0.0.0" />
+        </capability>
+        <capability name="package">
+            <p n="package" v="javax.sql" />
+            <p n="version" t="version" v="0.0.0" />
+        </capability>
+        <capability name="package">
+            <p n="package" v="org.xml.sax" />
+            <p n="version" t="version" v="0.0.0" />
+        </capability>
+        <capability name="package">
+            <p n="package" v="org.xml.sax.ext" />
+            <p n="version" t="version" v="0.0.0" />
+        </capability>
+        <capability name="package">
+            <p n="package" v="org.xml.sax.helpers" />
+            <p n="version" t="version" v="0.0.0" />
+        </capability>
+        <capability name="package">
+            <p n="package" v="org.apache.commons.logging" />
+            <p n="version" t="version" v="1.0.4" />
+        </capability>        
+    </resource>
+
+	<resource id="org.apache.felix.test.osgi.repo-test/1.0.0.SNAPSHOT"
+		presentationname="Unnamed - org.apache.felix.test.osgi:repo-test:bundle:1.0-SNAPSHOT"
+		symbolicname="org.apache.felix.test.osgi.repo-test"
+		uri="/home/kkoehler/.m2/repository/com/kkoehler/osgi/repo-test/1.0-SNAPSHOT/repo-test-1.0-SNAPSHOT.jar"
+		version="1.0.0.SNAPSHOT">
+		<description />
+		<size>2975</size>
+		<category id="org.apache.felix.test.osgi" />
+		<capability name="bundle">
+			<p n="manifestversion" v="2" />
+			<p n="presentationname"
+				v="Unnamed - org.apache.felix.test.osgi:repo-test:bundle:1.0-SNAPSHOT" />
+			<p n="symbolicname" v="org.apache.felix.test.osgi.repo-test" />
+			<p n="version" t="version" v="1.0.0.SNAPSHOT" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.apache.felix.test.osgi" />
+			<p n="uses" v="org.apache.commons.dbcp,org.springframework.context" />
+			<p n="version" t="version" v="0.0.0" />
+		</capability>
+		<require extend="false"
+			filter="(&amp;(package=org.apache.felix.test.osgi)(version&gt;=0.0.0))"
+			multiple="false" name="package" optional="false">Import package
+			org.apache.felix.test.osgi</require>
+		<require extend="false"
+			filter="(&amp;(package=org.apache.commons.dbcp)(version&gt;=1.2.0))"
+			multiple="false" name="package" optional="false">Import package
+			org.apache.commons.dbcp ;version=1.2.0</require>
+		<require extend="false"
+			filter="(&amp;(package=org.springframework.context)(version&gt;=2.5.0))"
+			multiple="false" name="package" optional="false">Import package
+			org.springframework.context ;version=2.5.0</require>
+	</resource>
+	<resource id="com.springsource.org.apache.commons.dbcp/1.2.2.osgi"
+		presentationname="Apache Commons Database Connection Pool"
+		symbolicname="com.springsource.org.apache.commons.dbcp"
+		uri="/home/kkoehler/.m2/repository/org/apache/commons/com.springsource.org.apache.commons.dbcp/1.2.2.osgi/com.springsource.org.apache.commons.dbcp-1.2.2.osgi.jar"
+		version="1.2.2.osgi">
+		<description />
+		<size>122704</size>
+		<category id="unknown" />
+		<capability name="bundle">
+			<p n="manifestversion" v="2" />
+			<p n="presentationname" v="Apache Commons Database Connection Pool" />
+			<p n="symbolicname" v="com.springsource.org.apache.commons.dbcp" />
+			<p n="version" t="version" v="1.2.2.osgi" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.apache.commons.dbcp" />
+			<p n="uses" v="javax.naming,javax.sql,org.apache.commons.pool" />
+			<p n="version" t="version" v="1.2.2.osgi" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.apache.commons.dbcp.cpdsadapter" />
+			<p n="uses" v="javax.naming,javax.sql,org.apache.commons.pool" />
+			<p n="version" t="version" v="1.2.2.osgi" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.apache.commons.dbcp.datasources" />
+			<p n="uses" v="javax.naming,javax.sql,org.apache.commons.pool" />
+			<p n="version" t="version" v="1.2.2.osgi" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.apache.commons.jocl" />
+			<p n="uses" v="org.xml.sax" />
+			<p n="version" t="version" v="1.2.2.osgi" />
+		</capability>
+		<require extend="false"
+			filter="(&amp;(package=javax.naming)(version&gt;=0.0.0))" multiple="false"
+			name="package" optional="false">Import package javax.naming</require>
+		<require extend="false"
+			filter="(&amp;(package=javax.naming.spi)(version&gt;=0.0.0))"
+			multiple="false" name="package" optional="false">Import package
+			javax.naming.spi</require>
+		<require extend="false"
+			filter="(&amp;(package=javax.sql)(version&gt;=0.0.0))" multiple="false"
+			name="package" optional="false">Import package javax.sql</require>
+		<require extend="false"
+			filter="(&amp;(package=org.apache.commons.pool)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))"
+			multiple="false" name="package" optional="false">Import package
+			org.apache.commons.pool ;version=[1.3.0,2.0.0)</require>
+		<require extend="false"
+			filter="(&amp;(package=org.apache.commons.pool.impl)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))"
+			multiple="false" name="package" optional="false">Import package
+			org.apache.commons.pool.impl ;version=[1.3.0,2.0.0)</require>
+		<require extend="false"
+			filter="(&amp;(package=org.xml.sax)(version&gt;=0.0.0))" multiple="false"
+			name="package" optional="false">Import package org.xml.sax</require>
+		<require extend="false"
+			filter="(&amp;(package=org.xml.sax.helpers)(version&gt;=0.0.0))"
+			multiple="false" name="package" optional="false">Import package
+			org.xml.sax.helpers</require>
+	</resource>
+	<resource id="com.springsource.org.apache.commons.pool/1.3.0"
+		presentationname="Apache Commons Pool" symbolicname="com.springsource.org.apache.commons.pool"
+		uri="/home/kkoehler/.m2/repository/org/apache/commons/com.springsource.org.apache.commons.pool/1.3.0/com.springsource.org.apache.commons.pool-1.3.0.jar"
+		version="1.3.0">
+		<description />
+		<size>62200</size>
+		<category id="unknown" />
+		<capability name="bundle">
+			<p n="manifestversion" v="2" />
+			<p n="presentationname" v="Apache Commons Pool" />
+			<p n="symbolicname" v="com.springsource.org.apache.commons.pool" />
+			<p n="version" t="version" v="1.3.0" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.apache.commons.pool" />
+			<p n="version" t="version" v="1.3.0" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.apache.commons.pool.impl" />
+			<p n="uses" v="org.apache.commons.pool" />
+			<p n="version" t="version" v="1.3.0" />
+		</capability>
+	</resource>
+	<resource id="org.springframework.beans/2.5.6"
+		presentationname="Spring Beans" symbolicname="org.springframework.beans"
+		uri="/home/kkoehler/.m2/repository/org/springframework/spring-beans/2.5.6/spring-beans-2.5.6.jar"
+		version="2.5.6">
+		<description />
+		<size>488282</size>
+		<category id="unknown" />
+		<capability name="bundle">
+			<p n="manifestversion" v="2" />
+			<p n="presentationname" v="Spring Beans" />
+			<p n="symbolicname" v="org.springframework.beans" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.beans" />
+			<p n="uses" v="org.springframework.core" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.beans.annotation" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.beans.factory" />
+			<p n="uses" v="org.springframework.beans" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.beans.factory.access" />
+			<p n="uses" v="org.springframework.beans,org.springframework.beans.factory" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.beans.factory.access.el" />
+			<p n="uses" v="javax.el,org.springframework.beans.factory" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.beans.factory.annotation" />
+			<p n="uses"
+				v="org.springframework.beans,org.springframework.beans.factory,org.springframework.beans.factory.config,org.springframework.beans.factory.support,org.springframework.beans.factory.wiring,org.springframework.core.type" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.beans.factory.config" />
+			<p n="uses"
+				v="org.springframework.beans,org.springframework.beans.factory,org.springframework.core,org.springframework.util" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.beans.factory.generic" />
+			<p n="uses" v="org.springframework.beans,org.springframework.beans.factory" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.beans.factory.parsing" />
+			<p n="uses"
+				v="org.apache.commons.logging,org.springframework.beans.factory.config,org.springframework.core.io" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.beans.factory.serviceloader" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.beans.factory.support" />
+			<p n="uses"
+				v="net.sf.cglib.proxy,org.apache.commons.logging,org.springframework.beans,org.springframework.beans.factory,org.springframework.beans.factory.config,org.springframework.core,org.springframework.core.io,org.springframework.core.io.support,org.springframework.util" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.beans.factory.wiring" />
+			<p n="uses" v="org.springframework.beans.factory" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.beans.factory.xml" />
+			<p n="uses"
+				v="javax.xml.parsers,org.springframework.beans,org.springframework.beans.factory,org.springframework.beans.factory.config,org.springframework.beans.factory.parsing,org.springframework.beans.factory.support,org.springframework.core.io,org.springframework.core.io.support,org.w3c.dom,org.xml.sax" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.beans.propertyeditors" />
+			<p n="uses" v="org.springframework.core.io" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.beans.support" />
+			<p n="uses" v="org.springframework.beans,org.springframework.core.io" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<require extend="false"
+			filter="(&amp;(package=javax.el)(version&gt;=2.1.0)(!(version&gt;=3.0.0)))"
+			multiple="false" name="package" optional="true">Import package
+			javax.el ;version=[2.1.0,3.0.0)</require>
+		<require extend="false"
+			filter="(&amp;(package=javax.xml.parsers)(version&gt;=0.0.0))"
+			multiple="false" name="package" optional="true">Import package
+			javax.xml.parsers</require>
+		<require extend="false"
+			filter="(&amp;(package=net.sf.cglib.proxy)(version&gt;=2.1.3)(!(version&gt;=2.2.0)))"
+			multiple="false" name="package" optional="true">Import package
+			net.sf.cglib.proxy ;version=[2.1.3,2.2.0)</require>
+		<require extend="false"
+			filter="(&amp;(package=org.apache.commons.logging)(version&gt;=1.0.4)(!(version&gt;=2.0.0)))"
+			multiple="false" name="package" optional="false">Import package
+			org.apache.commons.logging ;version=[1.0.4,2.0.0)</require>
+		<require extend="false"
+			filter="(&amp;(package=org.springframework.core)(version&gt;=2.5.6)(version&lt;=2.5.6))"
+			multiple="false" name="package" optional="true">Import package
+			org.springframework.core ;version=[2.5.6,2.5.6]</require>
+		<require extend="false"
+			filter="(&amp;(package=org.springframework.core.annotation)(version&gt;=2.5.6)(version&lt;=2.5.6))"
+			multiple="false" name="package" optional="true">Import package
+			org.springframework.core.annotation ;version=[2.5.6,2.5.6]</require>
+		<require extend="false"
+			filter="(&amp;(package=org.springframework.core.io)(version&gt;=2.5.6)(version&lt;=2.5.6))"
+			multiple="false" name="package" optional="true">Import package
+			org.springframework.core.io ;version=[2.5.6,2.5.6]</require>
+		<require extend="false"
+			filter="(&amp;(package=org.springframework.core.io.support)(version&gt;=2.5.6)(version&lt;=2.5.6))"
+			multiple="false" name="package" optional="true">Import package
+			org.springframework.core.io.support ;version=[2.5.6,2.5.6]</require>
+		<require extend="false"
+			filter="(&amp;(package=org.springframework.core.type)(version&gt;=2.5.6)(version&lt;=2.5.6))"
+			multiple="false" name="package" optional="true">Import package
+			org.springframework.core.type ;version=[2.5.6,2.5.6]</require>
+		<require extend="false"
+			filter="(&amp;(package=org.springframework.util)(version&gt;=2.5.6)(version&lt;=2.5.6))"
+			multiple="false" name="package" optional="true">Import package
+			org.springframework.util ;version=[2.5.6,2.5.6]</require>
+		<require extend="false"
+			filter="(&amp;(package=org.springframework.util.xml)(version&gt;=2.5.6)(version&lt;=2.5.6))"
+			multiple="false" name="package" optional="true">Import package
+			org.springframework.util.xml ;version=[2.5.6,2.5.6]</require>
+		<require extend="false"
+			filter="(&amp;(package=org.w3c.dom)(version&gt;=0.0.0))" multiple="false"
+			name="package" optional="true">Import package org.w3c.dom</require>
+		<require extend="false"
+			filter="(&amp;(package=org.xml.sax)(version&gt;=0.0.0))" multiple="false"
+			name="package" optional="true">Import package org.xml.sax</require>
+	</resource>
+	<resource id="org.springframework.core/2.5.6"
+		presentationname="Spring Core" symbolicname="org.springframework.core"
+		uri="/home/kkoehler/.m2/repository/org/springframework/spring-core/2.5.6/spring-core-2.5.6.jar"
+		version="2.5.6">
+		<description />
+		<size>285491</size>
+		<category id="unknown" />
+		<capability name="bundle">
+			<p n="manifestversion" v="2" />
+			<p n="presentationname" v="Spring Core" />
+			<p n="symbolicname" v="org.springframework.core" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.asm" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.asm.commons" />
+			<p n="uses" v="org.springframework.asm" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.asm.signature" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.core" />
+			<p n="uses"
+				v="org.apache.commons.logging,org.springframework.asm,org.springframework.util" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.core.annotation" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.core.enums" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.core.io" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.core.io.support" />
+			<p n="uses" v="org.springframework.core.io,org.springframework.util" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.core.style" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.core.task" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.core.task.support" />
+			<p n="uses" v="org.springframework.core.task" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.core.type" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.core.type.classreading" />
+			<p n="uses"
+				v="org.springframework.asm,org.springframework.core.io,org.springframework.core.type" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.core.type.filter" />
+			<p n="uses"
+				v="org.springframework.core.type,org.springframework.core.type.classreading" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.metadata" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.metadata.commons" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.util" />
+			<p n="uses" v="org.apache.commons.logging" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.util.comparator" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.util.xml" />
+			<p n="uses"
+				v="javax.xml.transform,org.apache.commons.logging,org.w3c.dom,org.xml.sax" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<require extend="false"
+			filter="(&amp;(package=edu.emory.mathcs.backport.java.util.concurrent)(version&gt;=3.0.0)(!(version&gt;=4.0.0)))"
+			multiple="false" name="package" optional="true">Import package
+			edu.emory.mathcs.backport.java.util.concurrent ;version=[3.0.0,4.0.0)
+		</require>
+		<require extend="false"
+			filter="(&amp;(package=javax.xml.transform)(version&gt;=0.0.0))"
+			multiple="false" name="package" optional="true">Import package
+			javax.xml.transform</require>
+		<require extend="false"
+			filter="(&amp;(package=org.apache.commons.attributes)(version&gt;=2.2.0)(!(version&gt;=3.0.0)))"
+			multiple="false" name="package" optional="true">Import package
+			org.apache.commons.attributes ;version=[2.2.0,3.0.0)</require>
+		<require extend="false"
+			filter="(&amp;(package=org.apache.commons.collections)(version&gt;=3.2.0)(!(version&gt;=4.0.0)))"
+			multiple="false" name="package" optional="true">Import package
+			org.apache.commons.collections ;version=[3.2.0,4.0.0)</require>
+		<require extend="false"
+			filter="(&amp;(package=org.apache.commons.collections.map)(version&gt;=3.2.0)(!(version&gt;=4.0.0)))"
+			multiple="false" name="package" optional="true">Import package
+			org.apache.commons.collections.map ;version=[3.2.0,4.0.0)</require>
+		<require extend="false"
+			filter="(&amp;(package=org.apache.commons.logging)(version&gt;=1.0.4)(!(version&gt;=2.0.0)))"
+			multiple="false" name="package" optional="false">Import package
+			org.apache.commons.logging ;version=[1.0.4,2.0.0)</require>
+		<require extend="false"
+			filter="(&amp;(package=org.apache.log4j)(version&gt;=1.2.15)(!(version&gt;=2.0.0)))"
+			multiple="false" name="package" optional="true">Import package
+			org.apache.log4j ;version=[1.2.15,2.0.0)</require>
+		<require extend="false"
+			filter="(&amp;(package=org.apache.log4j.xml)(version&gt;=1.2.15)(!(version&gt;=2.0.0)))"
+			multiple="false" name="package" optional="true">Import package
+			org.apache.log4j.xml ;version=[1.2.15,2.0.0)</require>
+		<require extend="false"
+			filter="(&amp;(package=org.aspectj.bridge)(version&gt;=1.5.4)(!(version&gt;=2.0.0)))"
+			multiple="false" name="package" optional="true">Import package
+			org.aspectj.bridge ;version=[1.5.4,2.0.0)</require>
+		<require extend="false"
+			filter="(&amp;(package=org.aspectj.weaver)(version&gt;=1.5.4)(!(version&gt;=2.0.0)))"
+			multiple="false" name="package" optional="true">Import package
+			org.aspectj.weaver ;version=[1.5.4,2.0.0)</require>
+		<require extend="false"
+			filter="(&amp;(package=org.aspectj.weaver.bcel)(version&gt;=1.5.4)(!(version&gt;=2.0.0)))"
+			multiple="false" name="package" optional="true">Import package
+			org.aspectj.weaver.bcel ;version=[1.5.4,2.0.0)</require>
+		<require extend="false"
+			filter="(&amp;(package=org.aspectj.weaver.patterns)(version&gt;=1.5.4)(!(version&gt;=2.0.0)))"
+			multiple="false" name="package" optional="true">Import package
+			org.aspectj.weaver.patterns ;version=[1.5.4,2.0.0)</require>
+		<require extend="false"
+			filter="(&amp;(package=org.eclipse.core.runtime)(version&gt;=0.0.0)(common=split)(mandatory:&lt;*common))"
+			multiple="false" name="package" optional="true">Import package
+			org.eclipse.core.runtime</require>
+		<require extend="false"
+			filter="(&amp;(package=org.w3c.dom)(version&gt;=0.0.0))" multiple="false"
+			name="package" optional="true">Import package org.w3c.dom</require>
+		<require extend="false"
+			filter="(&amp;(package=org.xml.sax)(version&gt;=0.0.0))" multiple="false"
+			name="package" optional="true">Import package org.xml.sax</require>
+	</resource>
+	<resource id="org.springframework.context/2.5.6"
+		presentationname="Spring Context" symbolicname="org.springframework.context"
+		uri="/home/kkoehler/.m2/repository/org/springframework/spring-context/2.5.6/spring-context-2.5.6.jar"
+		version="2.5.6">
+		<description />
+		<size>476940</size>
+		<category id="unknown" />
+		<capability name="bundle">
+			<p n="manifestversion" v="2" />
+			<p n="presentationname" v="Spring Context" />
+			<p n="symbolicname" v="org.springframework.context" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.context" />
+			<p n="uses"
+				v="org.springframework.beans,org.springframework.beans.factory.config,org.springframework.core.io" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.context.access" />
+			<p n="uses"
+				v="org.springframework.beans,org.springframework.beans.factory,org.springframework.beans.factory.access,org.springframework.context" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.context.annotation" />
+			<p n="uses"
+				v="org.springframework.beans,org.springframework.beans.factory,org.springframework.beans.factory.annotation,org.springframework.beans.factory.config,org.springframework.beans.factory.support,org.springframework.beans.factory.xml,org.springframework.core.io,org.springframework.core.type,org.springframework.core.type.classreading,org.springframework.core.type.filter,org.w3c.dom" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.context.config" />
+			<p n="uses"
+				v="org.springframework.beans.factory.config,org.springframework.beans.factory.support,org.springframework.beans.factory.xml,org.w3c.dom" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.context.event" />
+			<p n="uses"
+				v="org.aopalliance.intercept,org.springframework.context,org.springframework.core.task" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.context.i18n" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.context.support" />
+			<p n="uses"
+				v="org.springframework.beans,org.springframework.beans.factory,org.springframework.beans.factory.config,org.springframework.beans.factory.support,org.springframework.beans.factory.xml,org.springframework.context,org.springframework.core.io,org.springframework.core.io.support,org.springframework.util" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.context.weaving" />
+			<p n="uses"
+				v="org.springframework.beans,org.springframework.beans.factory,org.springframework.beans.factory.config,org.springframework.instrument.classloading" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.ejb.access" />
+			<p n="uses" v="javax.ejb,javax.naming,org.aopalliance.intercept" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.ejb.config" />
+			<p n="uses"
+				v="org.springframework.beans.factory.support,org.springframework.beans.factory.xml,org.w3c.dom" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.ejb.interceptor" />
+			<p n="uses"
+				v="javax.interceptor,org.springframework.beans.factory,org.springframework.beans.factory.access,org.springframework.beans.factory.annotation" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.ejb.support" />
+			<p n="uses"
+				v="javax.ejb,org.springframework.beans,org.springframework.beans.factory,org.springframework.beans.factory.access" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.instrument.classloading" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.instrument.classloading.glassfish" />
+			<p n="uses" v="com.sun.enterprise.loader" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.instrument.classloading.oc4j" />
+			<p n="uses" v="oracle.classloader.util" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.instrument.classloading.weblogic" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.jmx" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.jmx.access" />
+			<p n="uses"
+				v="javax.management,javax.management.remote,org.aopalliance.intercept,org.springframework.jmx" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.jmx.export" />
+			<p n="uses"
+				v="javax.management,javax.management.modelmbean,org.springframework.beans.factory,org.springframework.jmx.export.assembler,org.springframework.jmx.export.naming" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.jmx.export.annotation" />
+			<p n="uses" v="org.springframework.jmx.export.metadata" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.jmx.export.assembler" />
+			<p n="uses"
+				v="javax.management,javax.management.modelmbean,org.springframework.jmx.export.metadata" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.jmx.export.metadata" />
+			<p n="uses" v="javax.management.modelmbean,org.springframework.metadata" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.jmx.export.naming" />
+			<p n="uses"
+				v="javax.management,org.springframework.core.io,org.springframework.jmx.export.metadata" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.jmx.export.notification" />
+			<p n="uses" v="javax.management,javax.management.modelmbean" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.jmx.support" />
+			<p n="uses"
+				v="javax.management,javax.management.remote,org.springframework.jmx" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.jndi" />
+			<p n="uses" v="javax.naming,org.aopalliance.intercept" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.jndi.support" />
+			<p n="uses" v="org.springframework.beans,org.springframework.beans.factory" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.remoting" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.remoting.rmi" />
+			<p n="uses"
+				v="javax.naming,org.aopalliance.intercept,org.omg.CORBA,org.omg.CORBA.portable,org.springframework.jndi,org.springframework.remoting,org.springframework.remoting.support" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.remoting.soap" />
+			<p n="uses" v="javax.xml.namespace" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.remoting.support" />
+			<p n="uses"
+				v="com.sun.net.httpserver,org.aopalliance.intercept,org.springframework.core.task" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.scheduling" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.scheduling.backportconcurrent" />
+			<p n="uses" v="edu.emory.mathcs.backport.java.util.concurrent" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.scheduling.concurrent" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.scheduling.support" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.scheduling.timer" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.scripting" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.scripting.bsh" />
+			<p n="uses" v="bsh,org.springframework.scripting" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.scripting.config" />
+			<p n="uses"
+				v="org.springframework.beans.factory.config,org.springframework.beans.factory.support,org.springframework.beans.factory.xml,org.w3c.dom" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.scripting.groovy" />
+			<p n="uses"
+				v="groovy.lang,org.springframework.beans,org.springframework.beans.factory,org.springframework.scripting" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.scripting.jruby" />
+			<p n="uses"
+				v="org.jruby,org.jruby.ast,org.jruby.exceptions,org.jruby.runtime.builtin,org.springframework.scripting" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.scripting.support" />
+			<p n="uses"
+				v="org.springframework.aop,org.springframework.beans.factory,org.springframework.beans.factory.config,org.springframework.core.io,org.springframework.scripting" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.stereotype" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.ui" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.ui.context" />
+			<p n="uses" v="org.springframework.context" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.ui.context.support" />
+			<p n="uses" v="org.springframework.context,org.springframework.ui.context" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.validation" />
+			<p n="uses" v="org.springframework.beans,org.springframework.core" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<capability name="package">
+			<p n="package" v="org.springframework.validation.support" />
+			<p n="version" t="version" v="2.5.6" />
+		</capability>
+		<require extend="false"
+			filter="(&amp;(package=bsh)(version&gt;=2.0.0.b4)(!(version&gt;=3.0.0)))"
+			multiple="false" name="package" optional="true">Import package bsh
+			;version=[2.0.0.b4,3.0.0)</require>
+		<require extend="false"
+			filter="(&amp;(package=com.ibm.websphere.management)(version&gt;=0.0.0))"
+			multiple="false" name="package" optional="true">Import package
+			com.ibm.websphere.management</require>
+		<require extend="false"
+			filter="(&amp;(package=com.sun.enterprise.loader)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))"
+			multiple="false" name="package" optional="true">Import package
+			com.sun.enterprise.loader ;version=[1.0.0,2.0.0)</require>
+		<require extend="false"
+			filter="(&amp;(package=com.sun.net.httpserver)(version&gt;=0.0.0))"
+			multiple="false" name="package" optional="true">Import package
+			com.sun.net.httpserver</require>
+		<require extend="false"
+			filter="(&amp;(package=edu.emory.mathcs.backport.java.util.concurrent)(version&gt;=3.0.0)(!(version&gt;=4.0.0)))"
+			multiple="false" name="package" optional="true">Import package
+			edu.emory.mathcs.backport.java.util.concurrent ;version=[3.0.0,4.0.0)
+		</require>
+		<require extend="false"
+			filter="(&amp;(package=groovy.lang)(version&gt;=1.5.1)(!(version&gt;=2.0.0)))"
+			multiple="false" name="package" optional="true">Import package
+			groovy.lang ;version=[1.5.1,2.0.0)</require>
+		<require extend="false"
+			filter="(&amp;(package=javax.annotation)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))"
+			multiple="false" name="package" optional="true">Import package
+			javax.annotation ;version=[1.0.0,2.0.0)</require>
+		<require extend="false"
+			filter="(&amp;(package=javax.ejb)(version&gt;=3.0.0)(!(version&gt;=4.0.0)))"
+			multiple="false" name="package" optional="true">Import package
+			javax.ejb ;version=[3.0.0,4.0.0)</require>
+		<require extend="false"
+			filter="(&amp;(package=javax.interceptor)(version&gt;=3.0.0)(!(version&gt;=4.0.0)))"
+			multiple="false" name="package" optional="true">Import package
+			javax.interceptor ;version=[3.0.0,4.0.0)</require>
+		<require extend="false"
+			filter="(&amp;(package=javax.jms)(version&gt;=1.1.0)(!(version&gt;=2.0.0)))"
+			multiple="false" name="package" optional="true">Import package
+			javax.jms ;version=[1.1.0,2.0.0)</require>
+		<require extend="false"
+			filter="(&amp;(package=javax.management)(version&gt;=0.0.0))"
+			multiple="false" name="package" optional="true">Import package
+			javax.management</require>
+		<require extend="false"
+			filter="(&amp;(package=javax.management.modelmbean)(version&gt;=0.0.0))"
+			multiple="false" name="package" optional="true">Import package
+			javax.management.modelmbean</require>
+		<require extend="false"
+			filter="(&amp;(package=javax.management.openmbean)(version&gt;=0.0.0))"
+			multiple="false" name="package" optional="true">Import package
+			javax.management.openmbean</require>
+		<require extend="false"
+			filter="(&amp;(package=javax.management.remote)(version&gt;=0.0.0))"
+			multiple="false" name="package" optional="true">Import package
+			javax.management.remote</require>
+		<require extend="false"
+			filter="(&amp;(package=javax.naming)(version&gt;=0.0.0))" multiple="false"
+			name="package" optional="true">Import package javax.naming</require>
+		<require extend="false"
+			filter="(&amp;(package=javax.persistence)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))"
+			multiple="false" name="package" optional="true">Import package
+			javax.persistence ;version=[1.0.0,2.0.0)</require>
+		<require extend="false"
+			filter="(&amp;(package=javax.persistence.spi)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))"
+			multiple="false" name="package" optional="true">Import package
+			javax.persistence.spi ;version=[1.0.0,2.0.0)</require>
+		<require extend="false"
+			filter="(&amp;(package=javax.rmi)(version&gt;=0.0.0))" multiple="false"
+			name="package" optional="true">Import package javax.rmi</require>
+		<require extend="false"
+			filter="(&amp;(package=javax.rmi.CORBA)(version&gt;=0.0.0))"
+			multiple="false" name="package" optional="true">Import package
+			javax.rmi.CORBA</require>
+		<require extend="false"
+			filter="(&amp;(package=javax.xml.namespace)(version&gt;=0.0.0))"
+			multiple="false" name="package" optional="true">Import package
+			javax.xml.namespace</require>
+		<require extend="false"
+			filter="(&amp;(package=javax.xml.ws)(version&gt;=2.1.1)(!(version&gt;=3.0.0)))"
+			multiple="false" name="package" optional="true">Import package
+			javax.xml.ws ;version=[2.1.1,3.0.0)</require>
+		<require extend="false"
+			filter="(&amp;(package=net.sf.cglib.asm)(version&gt;=2.1.3)(!(version&gt;=2.2.0)))"
+			multiple="false" name="package" optional="true">Import package
+			net.sf.cglib.asm ;version=[2.1.3,2.2.0)</require>
+		<require extend="false"
+			filter="(&amp;(package=net.sf.cglib.core)(version&gt;=2.1.3)(!(version&gt;=2.2.0)))"
+			multiple="false" name="package" optional="true">Import package
+			net.sf.cglib.core ;version=[2.1.3,2.2.0)</require>
+		<require extend="false"
+			filter="(&amp;(package=net.sf.cglib.proxy)(version&gt;=2.1.3)(!(version&gt;=2.2.0)))"
+			multiple="false" name="package" optional="true">Import package
+			net.sf.cglib.proxy ;version=[2.1.3,2.2.0)</require>
+		<require extend="false"
+			filter="(&amp;(package=oracle.classloader.util)(version&gt;=10.1.3.1)(!(version&gt;=10.2.0.0)))"
+			multiple="false" name="package" optional="true">Import package
+			oracle.classloader.util ;version=[10.1.3.1,10.2.0.0)</require>
+		<require extend="false"
+			filter="(&amp;(package=org.aopalliance.aop)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))"
+			multiple="false" name="package" optional="true">Import package
+			org.aopalliance.aop ;version=[1.0.0,2.0.0)</require>
+		<require extend="false"
+			filter="(&amp;(package=org.aopalliance.intercept)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))"
+			multiple="false" name="package" optional="true">Import package
+			org.aopalliance.intercept ;version=[1.0.0,2.0.0)</require>
+		<require extend="false"
+			filter="(&amp;(package=org.apache.commons.logging)(version&gt;=1.0.4)(!(version&gt;=2.0.0)))"
+			multiple="false" name="package" optional="false">Import package
+			org.apache.commons.logging ;version=[1.0.4,2.0.0)</require>
+		<require extend="false"
+			filter="(&amp;(package=org.aspectj.weaver.loadtime)(version&gt;=1.5.4)(!(version&gt;=2.0.0)))"
+			multiple="false" name="package" optional="true">Import package
+			org.aspectj.weaver.loadtime ;version=[1.5.4,2.0.0)</require>
+		<require extend="false"
+			filter="(&amp;(package=org.codehaus.groovy.control)(version&gt;=1.5.1)(!(version&gt;=2.0.0)))"
+			multiple="false" name="package" optional="true">Import package
+			org.codehaus.groovy.control ;version=[1.5.1,2.0.0)</require>
+		<require extend="false"
+			filter="(&amp;(package=org.jruby)(version&gt;=1.1.0)(!(version&gt;=2.0.0)))"
+			multiple="false" name="package" optional="true">Import package
+			org.jruby ;version=[1.1.0,2.0.0)</require>
+		<require extend="false"
+			filter="(&amp;(package=org.jruby.ast)(version&gt;=1.1.0)(!(version&gt;=2.0.0)))"
+			multiple="false" name="package" optional="true">Import package
+			org.jruby.ast ;version=[1.1.0,2.0.0)</require>
+		<require extend="false"
+			filter="(&amp;(package=org.jruby.exceptions)(version&gt;=1.1.0)(!(version&gt;=2.0.0)))"
+			multiple="false" name="package" optional="true">Import package
+			org.jruby.exceptions ;version=[1.1.0,2.0.0)</require>
+		<require extend="false"
+			filter="(&amp;(package=org.jruby.javasupport)(version&gt;=1.1.0)(!(version&gt;=2.0.0)))"
+			multiple="false" name="package" optional="true">Import package
+			org.jruby.javasupport ;version=[1.1.0,2.0.0)</require>
+		<require extend="false"
+			filter="(&amp;(package=org.jruby.runtime)(version&gt;=1.1.0)(!(version&gt;=2.0.0)))"
+			multiple="false" name="package" optional="true">Import package
+			org.jruby.runtime ;version=[1.1.0,2.0.0)</require>
+		<require extend="false"
+			filter="(&amp;(package=org.jruby.runtime.builtin)(version&gt;=1.1.0)(!(version&gt;=2.0.0)))"
+			multiple="false" name="package" optional="true">Import package
+			org.jruby.runtime.builtin ;version=[1.1.0,2.0.0)</require>
+		<require extend="false"
+			filter="(&amp;(package=org.omg.CORBA)(version&gt;=0.0.0))" multiple="false"
+			name="package" optional="true">Import package org.omg.CORBA</require>
+		<require extend="false"
+			filter="(&amp;(package=org.omg.CORBA.portable)(version&gt;=0.0.0))"
+			multiple="false" name="package" optional="true">Import package
+			org.omg.CORBA.portable</require>
+		<require extend="false"
+			filter="(&amp;(package=org.omg.CORBA_2_3.portable)(version&gt;=0.0.0))"
+			multiple="false" name="package" optional="true">Import package
+			org.omg.CORBA_2_3.portable</require>
+		<require extend="false"
+			filter="(&amp;(package=org.springframework.aop)(version&gt;=2.5.6)(version&lt;=2.5.6))"
+			multiple="false" name="package" optional="true">Import package
+			org.springframework.aop ;version=[2.5.6,2.5.6]</require>
+		<require extend="false"
+			filter="(&amp;(package=org.springframework.aop.framework)(version&gt;=2.5.6)(version&lt;=2.5.6))"
+			multiple="false" name="package" optional="true">Import package
+			org.springframework.aop.framework ;version=[2.5.6,2.5.6]</require>
+		<require extend="false"
+			filter="(&amp;(package=org.springframework.aop.framework.adapter)(version&gt;=2.5.6)(version&lt;=2.5.6))"
+			multiple="false" name="package" optional="true">Import package
+			org.springframework.aop.framework.adapter ;version=[2.5.6,2.5.6]
+		</require>
+		<require extend="false"
+			filter="(&amp;(package=org.springframework.aop.scope)(version&gt;=2.5.6)(version&lt;=2.5.6))"
+			multiple="false" name="package" optional="true">Import package
+			org.springframework.aop.scope ;version=[2.5.6,2.5.6]</require>
+		<require extend="false"
+			filter="(&amp;(package=org.springframework.aop.support)(version&gt;=2.5.6)(version&lt;=2.5.6))"
+			multiple="false" name="package" optional="true">Import package
+			org.springframework.aop.support ;version=[2.5.6,2.5.6]</require>
+		<require extend="false"
+			filter="(&amp;(package=org.springframework.aop.target)(version&gt;=2.5.6)(version&lt;=2.5.6))"
+			multiple="false" name="package" optional="true">Import package
+			org.springframework.aop.target ;version=[2.5.6,2.5.6]</require>
+		<require extend="false"
+			filter="(&amp;(package=org.springframework.aop.target.dynamic)(version&gt;=2.5.6)(version&lt;=2.5.6))"
+			multiple="false" name="package" optional="true">Import package
+			org.springframework.aop.target.dynamic ;version=[2.5.6,2.5.6]
+		</require>
+		<require extend="false"
+			filter="(&amp;(package=org.springframework.beans)(version&gt;=2.5.6)(version&lt;=2.5.6))"
+			multiple="false" name="package" optional="true">Import package
+			org.springframework.beans ;version=[2.5.6,2.5.6]</require>
+		<require extend="false"
+			filter="(&amp;(package=org.springframework.beans.annotation)(version&gt;=2.5.6)(version&lt;=2.5.6))"
+			multiple="false" name="package" optional="true">Import package
+			org.springframework.beans.annotation ;version=[2.5.6,2.5.6]</require>
+		<require extend="false"
+			filter="(&amp;(package=org.springframework.beans.factory)(version&gt;=2.5.6)(version&lt;=2.5.6))"
+			multiple="false" name="package" optional="true">Import package
+			org.springframework.beans.factory ;version=[2.5.6,2.5.6]</require>
+		<require extend="false"
+			filter="(&amp;(package=org.springframework.beans.factory.access)(version&gt;=2.5.6)(version&lt;=2.5.6))"
+			multiple="false" name="package" optional="true">Import package
+			org.springframework.beans.factory.access ;version=[2.5.6,2.5.6]
+		</require>
+		<require extend="false"
+			filter="(&amp;(package=org.springframework.beans.factory.annotation)(version&gt;=2.5.6)(version&lt;=2.5.6))"
+			multiple="false" name="package" optional="true">Import package
+			org.springframework.beans.factory.annotation ;version=[2.5.6,2.5.6]
+		</require>
+		<require extend="false"
+			filter="(&amp;(package=org.springframework.beans.factory.config)(version&gt;=2.5.6)(version&lt;=2.5.6))"
+			multiple="false" name="package" optional="true">Import package
+			org.springframework.beans.factory.config ;version=[2.5.6,2.5.6]
+		</require>
+		<require extend="false"
+			filter="(&amp;(package=org.springframework.beans.factory.parsing)(version&gt;=2.5.6)(version&lt;=2.5.6))"
+			multiple="false" name="package" optional="true">Import package
+			org.springframework.beans.factory.parsing ;version=[2.5.6,2.5.6]
+		</require>
+		<require extend="false"
+			filter="(&amp;(package=org.springframework.beans.factory.support)(version&gt;=2.5.6)(version&lt;=2.5.6))"
+			multiple="false" name="package" optional="true">Import package
+			org.springframework.beans.factory.support ;version=[2.5.6,2.5.6]
+		</require>
+		<require extend="false"
+			filter="(&amp;(package=org.springframework.beans.factory.xml)(version&gt;=2.5.6)(version&lt;=2.5.6))"
+			multiple="false" name="package" optional="true">Import package
+			org.springframework.beans.factory.xml ;version=[2.5.6,2.5.6]
+		</require>
+		<require extend="false"
+			filter="(&amp;(package=org.springframework.beans.propertyeditors)(version&gt;=2.5.6)(version&lt;=2.5.6))"
+			multiple="false" name="package" optional="true">Import package
+			org.springframework.beans.propertyeditors ;version=[2.5.6,2.5.6]
+		</require>
+		<require extend="false"
+			filter="(&amp;(package=org.springframework.beans.support)(version&gt;=2.5.6)(version&lt;=2.5.6))"
+			multiple="false" name="package" optional="true">Import package
+			org.springframework.beans.support ;version=[2.5.6,2.5.6]</require>
+		<require extend="false"
+			filter="(&amp;(package=org.springframework.core)(version&gt;=2.5.6)(version&lt;=2.5.6))"
+			multiple="false" name="package" optional="true">Import package
+			org.springframework.core ;version=[2.5.6,2.5.6]</require>
+		<require extend="false"
+			filter="(&amp;(package=org.springframework.core.annotation)(version&gt;=2.5.6)(version&lt;=2.5.6))"
+			multiple="false" name="package" optional="true">Import package
+			org.springframework.core.annotation ;version=[2.5.6,2.5.6]</require>
+		<require extend="false"
+			filter="(&amp;(package=org.springframework.core.io)(version&gt;=2.5.6)(version&lt;=2.5.6))"
+			multiple="false" name="package" optional="true">Import package
+			org.springframework.core.io ;version=[2.5.6,2.5.6]</require>
+		<require extend="false"
+			filter="(&amp;(package=org.springframework.core.io.support)(version&gt;=2.5.6)(version&lt;=2.5.6))"
+			multiple="false" name="package" optional="true">Import package
+			org.springframework.core.io.support ;version=[2.5.6,2.5.6]</require>
+		<require extend="false"
+			filter="(&amp;(package=org.springframework.core.task)(version&gt;=2.5.6)(version&lt;=2.5.6))"
+			multiple="false" name="package" optional="true">Import package
+			org.springframework.core.task ;version=[2.5.6,2.5.6]</require>
+		<require extend="false"
+			filter="(&amp;(package=org.springframework.core.task.support)(version&gt;=2.5.6)(version&lt;=2.5.6))"
+			multiple="false" name="package" optional="true">Import package
+			org.springframework.core.task.support ;version=[2.5.6,2.5.6]
+		</require>
+		<require extend="false"
+			filter="(&amp;(package=org.springframework.core.type)(version&gt;=2.5.6)(version&lt;=2.5.6))"
+			multiple="false" name="package" optional="true">Import package
+			org.springframework.core.type ;version=[2.5.6,2.5.6]</require>
+		<require extend="false"
+			filter="(&amp;(package=org.springframework.core.type.classreading)(version&gt;=2.5.6)(version&lt;=2.5.6))"
+			multiple="false" name="package" optional="true">Import package
+			org.springframework.core.type.classreading ;version=[2.5.6,2.5.6]
+		</require>
+		<require extend="false"
+			filter="(&amp;(package=org.springframework.core.type.filter)(version&gt;=2.5.6)(version&lt;=2.5.6))"
+			multiple="false" name="package" optional="true">Import package
+			org.springframework.core.type.filter ;version=[2.5.6,2.5.6]</require>
+		<require extend="false"
+			filter="(&amp;(package=org.springframework.instrument)(version&gt;=2.5.6)(version&lt;=2.5.6))"
+			multiple="false" name="package" optional="true">Import package
+			org.springframework.instrument ;version=[2.5.6,2.5.6]</require>
+		<require extend="false"
+			filter="(&amp;(package=org.springframework.metadata)(version&gt;=2.5.6)(version&lt;=2.5.6))"
+			multiple="false" name="package" optional="true">Import package
+			org.springframework.metadata ;version=[2.5.6,2.5.6]</require>
+		<require extend="false"
+			filter="(&amp;(package=org.springframework.orm.jpa.support)(version&gt;=2.5.6)(version&lt;=2.5.6))"
+			multiple="false" name="package" optional="true">Import package
+			org.springframework.orm.jpa.support ;version=[2.5.6,2.5.6]</require>
+		<require extend="false"
+			filter="(&amp;(package=org.springframework.util)(version&gt;=2.5.6)(version&lt;=2.5.6))"
+			multiple="false" name="package" optional="true">Import package
+			org.springframework.util ;version=[2.5.6,2.5.6]</require>
+		<require extend="false"
+			filter="(&amp;(package=org.springframework.util.xml)(version&gt;=2.5.6)(version&lt;=2.5.6))"
+			multiple="false" name="package" optional="true">Import package
+			org.springframework.util.xml ;version=[2.5.6,2.5.6]</require>
+		<require extend="false"
+			filter="(&amp;(package=org.w3c.dom)(version&gt;=0.0.0))" multiple="false"
+			name="package" optional="true">Import package org.w3c.dom</require>
+		<require extend="false"
+			filter="(&amp;(package=org.xml.sax)(version&gt;=0.0.0))" multiple="false"
+			name="package" optional="true">Import package org.xml.sax</require>
+	</resource>
+</repository>
\ No newline at end of file



Mime
View raw message