falcon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aaron Turner <synfina...@gmail.com>
Subject Unable to submit cluster definition
Date Thu, 05 Jan 2017 00:01:23 GMT
Sorry if this is the wrong place to ask questions, but the IRC channel
is dead and I don't see a falcon-users list?

Long story short, I'm on 0.10 and trying to get Falcon (distributed
mode) working with CDH 5.8.2.  I've got things built and installed and
I'm trying to submit my cluster definition but it keeps on failing:

$ /falcon entity -submit -type cluster -file /etc/falcon/cluster.xml
Hadoop home is set, adding libraries from
'/usr/lib/hadoop-mapreduce//bin/hadoop classpath' into falcon
classpath
/usr/lib/falcon-server/bin/falcon-config.sh: line 75:
/usr/lib/hadoop-mapreduce//bin/hadoop: No such file or directory
SLF4J: Class path contains multiple SLF4J bindings.
SLF4J: Found binding in
[jar:file:/usr/lib/falcon-server/client/lib/falcon-cli-0.10.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: Found binding in
[jar:file:/usr/lib/falcon-server/client/lib/slf4j-log4j12-1.7.5.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: Found binding in
[jar:file:/usr/lib/zookeeper/lib/slf4j-log4j12-1.7.5.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: See http://www.slf4j.org/codes.html#multiple_bindings for an explanation.
SLF4J: Actual binding is of type [org.slf4j.impl.Log4jLoggerFactory]
FALCON_DEBUG: true
POST http://localhost:16444/api/entities/submit/cluster returned a
response status of 400 Bad Request
ERROR: Bad Request;local/org.apache.falcon.FalconException::org.apache.falcon.FalconException:
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1"/>
<title>Error 404 NOT_FOUND</title>
</head>
<body><h2>HTTP ERROR 404</h2>
<p>Problem accessing /secure/sync/submit/cluster. Reason:
<pre>    NOT_FOUND</pre></p><hr /><i><small>Powered by
Jetty://</small></i><br/>
<br/>
<br/>
<br/>
<br/>
<br/>
<br/>
<br/>
<br/>
<br/>
<br/>
<br/>
<br/>
<br/>
<br/>
<br/>
<br/>
<br/>
<br/>
<br/>

</body>
</html>


This error looks almost exactly like what was reported here a few years ago:
https://www.mail-archive.com/dev@falcon.incubator.apache.org/msg03621.html

Suggestions or ideas?

Thanks!

--
Aaron Turner
https://synfin.net/         Twitter: @synfinatic
Those who would give up essential Liberty, to purchase a little temporary
Safety, deserve neither Liberty nor Safety.
    -- Benjamin Franklin

Mime
View raw message