falcon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "jp (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FALCON-291) Not able to package Falcon
Date Thu, 14 Apr 2016 08:59:25 GMT

    [ https://issues.apache.org/jira/browse/FALCON-291?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15240826#comment-15240826
] 

jp commented on FALCON-291:
---------------------------

to:Pallavi Rao
 when I changed JDK from 1.7 to 1.6, error information changed.
==============================================================
[INFO] Apache Falcon ..................................... SUCCESS [3.185s]
[INFO] Apache Falcon UI .................................. FAILURE [0.303s]
[INFO] Checkstyle ........................................ SKIPPED
[INFO] Build Tools ....................................... SKIPPED
[INFO] Apache Falcon Java client ......................... SKIPPED
[INFO] Apache Falcon CLI client .......................... SKIPPED
[INFO] Apache Falcon Metrics ............................. SKIPPED
[INFO] Apache Falcon Hadoop Dependencies ................. SKIPPED
[INFO] Apache Falcon Test Utility ........................ SKIPPED
[INFO] Apache Falcon Commons ............................. SKIPPED
[INFO] Apache Falcon Oozie EL Extension .................. SKIPPED
[INFO] Apache Falcon Embedded Hadoop - Test Cluster ...... SKIPPED
[INFO] Apache Falcon Sharelib Hive - Test Cluster ........ SKIPPED
[INFO] Apache Falcon Sharelib Pig - Test Cluster ......... SKIPPED
[INFO] Apache Falcon Sharelib Hcatalog - Test Cluster .... SKIPPED
[INFO] Apache Falcon Sharelib Oozie - Test Cluster ....... SKIPPED
[INFO] Apache Falcon Test Tools - Test Cluster ........... SKIPPED
[INFO] Apache Falcon Messaging ........................... SKIPPED
[INFO] Apache Falcon LIfecycle Module .................... SKIPPED
[INFO] Apache Falcon Oozie Adaptor ....................... SKIPPED
[INFO] Apache Falcon Scheduler ........................... SKIPPED
[INFO] Apache Falcon Acquisition ......................... SKIPPED
[INFO] Apache Falcon Distcp Replication .................. SKIPPED
[INFO] Apache Falcon Retention ........................... SKIPPED
[INFO] Apache Falcon Archival ............................ SKIPPED
[INFO] Apache Falcon Rerun ............................... SKIPPED
[INFO] Apache Falcon Prism ............................... SKIPPED
[INFO] falcon-unit ....................................... SKIPPED
[INFO] Apache Falcon Web Application ..................... SKIPPED
[INFO] Apache Falcon Documentation ....................... SKIPPED
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 4.866s
[INFO] Finished at: Fri Apr 15 02:10:34 JST 2016
[INFO] Final Memory: 32M/436M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal com.github.eirslett:frontend-maven-plugin:0.0.23:npm (npm install)
on project falcon-ui: Execution npm install of goal com.github.eirslett:frontend-maven-plugin:0.0.23:npm
failed: Look-behind group does not have an obvious maximum length near index 11
[ERROR] //(?<keep>.*):.*@
[ERROR] ^
[ERROR] -> [Help 1]
[ERROR] 
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] 
[ERROR] For more information about the errors and possible solutions, please read the following
articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/PluginExecutionException
[ERROR] 
[ERROR] After correcting the problems, you can resume the build with the command
[ERROR]   mvn <goals> -rf :falcon-ui
==============================================================
could you give me some help ??



> Not able to package Falcon
> --------------------------
>
>                 Key: FALCON-291
>                 URL: https://issues.apache.org/jira/browse/FALCON-291
>             Project: Falcon
>          Issue Type: Bug
>          Components: build-tools, oozie
>    Affects Versions: 0.4
>         Environment: HDP 1.3 and CDH 4.3
>            Reporter: prashant
>
> Hi,
> I am not able to build falcon 0.4-incubating jar and getting error when i am trying to
build it on HDP 1.3 as well as CDH 4.3.
> below are steps which i am following
> * git clone https://git-wip-us.apache.org/repos/asf/incubator-falcon.git falcon
> * cd falcon
> * export mvn package
> below is the error
> [ERROR] Failed to execute goal org.codehaus.mojo:exec-maven-plugin:1.2.1:exec (BUILD-OOZIE)
on project build-tools: Command execution failed. Process exited with an error: 1 (Exit value:
1) -> [Help 1]
> [ERROR]
> [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
> [ERROR]
> [ERROR] For more information about the errors and possible solutions, please read the
following articles:
> [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
> [ERROR]
> [ERROR] After correcting the problems, you can resume the build with the command
> [ERROR]   mvn <goals> -rf :build-tools



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message