falcon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sowmya Ramesh (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FALCON-1497) Hive script / oozie workflow is not updated on updating a process definition
Date Thu, 01 Oct 2015 03:42:04 GMT

    [ https://issues.apache.org/jira/browse/FALCON-1497?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14939275#comment-14939275
] 

Sowmya Ramesh commented on FALCON-1497:
---------------------------------------

[~rishav_rohit]: Can you please attach the falcon application log for debugging? If new entity
is same as old entity I am not sure if bundle gets updated. Can you upload the new hive script
to a diff location than old location then update the falcon process with the new hive script
path and verify if new hive script gets picked?

> Hive script / oozie workflow is not updated on updating a process definition
> ----------------------------------------------------------------------------
>
>                 Key: FALCON-1497
>                 URL: https://issues.apache.org/jira/browse/FALCON-1497
>             Project: Falcon
>          Issue Type: Bug
>          Components: process
>    Affects Versions: 0.6
>         Environment: HDP-2.2.0
>            Reporter: Rishav Rohit
>
> Suppose a process is defined which invokes Oozie workflow or Hive script. When I update
the Oozie workflow or Hive script and and then update the process definition in Falcon, the
Falcon update command executes successfully but the Oozie workflow / Hive script is not updated.
> I have not checked if same is the case with pig scripts too.
> I believe this is a bug because when I update a workflow/script and then update the process,
it should take new workflow/scripts.
> Thanks



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message