falcon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Suhas Vasu (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FALCON-1212) Remove dependency on Gremlin
Date Tue, 02 Jun 2015 13:55:18 GMT

    [ https://issues.apache.org/jira/browse/FALCON-1212?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14569122#comment-14569122
] 

Suhas Vasu commented on FALCON-1212:
------------------------------------

Minor nit 
{noformat}
                    String pipelines = p.getPipelines();
                    if (StringUtils.isNotEmpty(pipelines)) {
                        for (String tag : pipelines.split(",")) {
                            if (StringUtils.equals(tag.trim(), pipeline.trim())) {
                                processes.add(p);
                            }
{noformat}

I feel it is little confusing to have both pipeline & pipelines as variables. Would be
cleaner with a better name for pipelines.

> Remove dependency on Gremlin
> ----------------------------
>
>                 Key: FALCON-1212
>                 URL: https://issues.apache.org/jira/browse/FALCON-1212
>             Project: Falcon
>          Issue Type: Improvement
>            Reporter: Ajay Yadava
>            Assignee: Ajay Yadava
>         Attachments: FALCON-1212.patch
>
>
> Currently only entityLineage is using gremlin and that can be achieved using ConfigurationStore
as well. We should remove this unnecessary dependency.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message