falcon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ajay Yadava (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FALCON-1157) Build error when using maven 3.3.x
Date Wed, 17 Jun 2015 09:29:00 GMT

    [ https://issues.apache.org/jira/browse/FALCON-1157?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14589534#comment-14589534
] 

Ajay Yadava commented on FALCON-1157:
-------------------------------------

Ran into same issue when I upgraded maven. One caveat is that the 0.23 version of the frontend-maven-plugin
requires maven 3.1.0 or higher.

> Build error when using maven 3.3.x
> ----------------------------------
>
>                 Key: FALCON-1157
>                 URL: https://issues.apache.org/jira/browse/FALCON-1157
>             Project: Falcon
>          Issue Type: Bug
>          Components: ui
>    Affects Versions: 0.6
>            Reporter: Venkat Ramachandran
>
> Building latest code base using maven 3.3.x fails with following error:
> [ERROR] Failed to execute goal com.github.eirslett:frontend-maven-plugin:0.0.14:install-node-and-npm
(install node and npm) on project falcon-ui: Execution install node and npm of goal com.github.eirslett:frontend-maven-plugin:0.0.14:install-node-and-npm
failed: A required class was missing while executing com.github.eirslett:frontend-maven-plugin:0.0.14:install-node-and-npm:
org/slf4j/helpers/MarkerIgnoringBase
> Upgrading the plugin as below makes the build to complete (requires testing) with both
maven 3.2.x and 3.3.x 
>          <groupId>com.github.eirslett</groupId>
>          <artifactId>frontend-maven-plugin</artifactId>
>          <version>0.0.23</version>
>   



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message