falcon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Raghav Gautam" <rag...@apache.org>
Subject Re: Review Request 34240: Feed Wizard multiple tests
Date Wed, 20 May 2015 00:46:38 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/34240/#review84429
-----------------------------------------------------------



falcon-regression/merlin/src/main/java/org/apache/falcon/regression/ui/search/FeedWizardPage.java
<https://reviews.apache.org/r/34240/#comment135677>

    function, variable name are not indicative of what is happening in the function, a name
like isFeedFrequencyDisplay(boolean isDisplayed) will make the code more readable.
    
    Same thing applies to other functions too.



falcon-regression/merlin/src/main/java/org/apache/falcon/regression/ui/search/FeedWizardPage.java
<https://reviews.apache.org/r/34240/#comment135679>

    probably you can use waitForAngularToFinish().



falcon-regression/merlin/src/test/java/org/apache/falcon/regression/searchUI/FeedSetupTest.java
<https://reviews.apache.org/r/34240/#comment135681>

    please use java doc comments.
    
    /**
    ... doc here...
    */


- Raghav Gautam


On May 18, 2015, 11:37 a.m., Namit Maheshwari wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/34240/
> -----------------------------------------------------------
> 
> (Updated May 18, 2015, 11:37 a.m.)
> 
> 
> Review request for Falcon.
> 
> 
> Bugs: FALCON-1222
>     https://issues.apache.org/jira/browse/FALCON-1222
> 
> 
> Repository: falcon-git
> 
> 
> Description
> -------
> 
> Feed Wizard multiple tests
> 
> 
> Diffs
> -----
> 
>   falcon-regression/merlin/src/main/java/org/apache/falcon/regression/ui/search/AbstractSearchPage.java
e72ce6706d7fe3331744d723894193bfbaff586a 
>   falcon-regression/merlin/src/main/java/org/apache/falcon/regression/ui/search/FeedWizardPage.java
6eed4cef86c1974c3d30f0133b34894e24ac1750 
>   falcon-regression/merlin/src/test/java/org/apache/falcon/regression/searchUI/FeedSetupTest.java
8920f41129175a207ae6dee0659a514fef17bcfc 
> 
> Diff: https://reviews.apache.org/r/34240/diff/
> 
> 
> Testing
> -------
> 
> Below new tests added. Tested the same.
> testWizardCancel
> testWizardXmlPreview
> testGeneralStepEditXml
> testGeneralStepDefaultScenario
> testGeneralStepXmlPreview
> testGeneralStepAddRemoveTag
> testGeneralStepBlankOptionalFields
> testTimingStepDefaultScenario
> testTimingStepXmlPreview
> testTimingStepEditXml
> testTimingStepDropDownLists
> testTimingStepAddDeleteProperties
> testLocationStepValidValuesFS
> testLocationStepValidCatalogStorage
> testLocationStepBothLocationsAndTableUri
> testLocationStepEditXml
> testClustersStepDefaultScenario
> testClustersStepDropDownLists
> testClustersStepDefaultLocations
> testClusterStepEditXml
> testSummaryStepDefaultScenario
> 
> 
> Thanks,
> 
> Namit Maheshwari
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message