falcon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tony Reix (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FALCON-825) Downloading & compiling Oozie source code creates an issue
Date Tue, 21 Oct 2014 13:03:33 GMT

    [ https://issues.apache.org/jira/browse/FALCON-825?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14178368#comment-14178368
] 

Tony Reix commented on FALCON-825:
----------------------------------

You said: " the apache version oozie artifacts are not available in any mvn repo" . That may
explain why I cannot compile Falcon on 2 Ubuntu (PPC64LE and x86_64) environments ? However,
I can compile/test Falcon on 2 RHEL7 (PPC64BE and x86_64) environments. So, i'm lost...

My error is:
[WARNING] The POM for org.apache.oozie:oozie-core:jar:4.0.1-falcon is missing, no dependency
information available
...
[INFO] Apache Falcon Oozie EL Extension .................. FAILURE [  0.171 s]
...
[ERROR] Failed to execute goal on project falcon-oozie-el-extension: Could not resolve dependencies
for project org.apache.falcon:falcon-oozie-el-extension:jar:0.5-incubating: Failure to find
org.apache.oozie:oozie-core:jar:4.0.1-falcon in http://repo1.maven.org/maven2 was cached in
the local repository, resolution will not be reattempted until the update interval of central
has elapsed or updates are forced -> [Help 1]
org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal on project
falcon-oozie-el-extension: Could not resolve dependencies for project org.apache.falcon:falcon-oozie-el-extension:jar:0.5-incubating:
Failure to find org.apache.oozie:oozie-core:jar:4.0.1-falcon in http://repo1.maven.org/maven2
was cached in the local repository, resolution will not be reattempted until the update interval
of central has elapsed or updates are forced
        at org.apache.maven.lifecycle.internal.LifecycleDependencyResolver.getDependencies(LifecycleDependencyResolver.java:220)


> Downloading & compiling Oozie source code creates an issue
> ----------------------------------------------------------
>
>                 Key: FALCON-825
>                 URL: https://issues.apache.org/jira/browse/FALCON-825
>             Project: Falcon
>          Issue Type: Improvement
>          Components: build-tools
>    Affects Versions: 0.5
>         Environment: Ubuntu / PPC64LE : only IBM JVM 1.7 is available.
> More
>            Reporter: Tony Reix
>            Priority: Blocker
>
> Falcon 0.5 makes use of Oozie. Instead of downloading Jar files of Oozie, Falcon downloads
source files of Oozie 4.0.1 and then compiles it localy.
> Since Oozie requires a v1.6 JVM, this is an issue on machines where no version 1.6 of
Java is available, like Ubuntu/PPC64LE. Moreover, Oozie compiles fine with Java 1.7 .
> Falcon should use a localy available .jar version (4.0.1) of Oozie or use Maven to download
a jar file of Oozie.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message