falcon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Raghav Gautam" <rag...@apache.org>
Subject Re: Review Request 27280: https://issues.apache.org/jira/browse/FALCON-618
Date Tue, 28 Oct 2014 22:06:36 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/27280/#review58882
-----------------------------------------------------------



falcon-regression/merlin-core/src/main/java/org/apache/falcon/regression/Entities/FeedMerlin.java
<https://reviews.apache.org/r/27280/#comment100027>

    This method seems scenario spcific. May be it should be part of feedRetryTest().
    
    Inline perhaps ?



falcon-regression/merlin-core/src/main/java/org/apache/falcon/regression/core/util/HadoopUtil.java
<https://reviews.apache.org/r/27280/#comment100028>

    This assumes that test user has privileges to proxy as hdfs. Which is a strong assumption.
    
    ACL_OWNER for intents and purposes is current user. Perhaps it would be better to setPermission
as current user ?
    
    Also, if directory creation and setting permissions is not being done frequently, can
we keep them as two separate methods.



falcon-regression/merlin/src/test/java/org/apache/falcon/regression/RetryTest.java
<https://reviews.apache.org/r/27280/#comment100031>

    changing name of setRetry to setProcessRetry would make things much clearer.



falcon-regression/merlin/src/test/java/org/apache/falcon/regression/RetryTest.java
<https://reviews.apache.org/r/27280/#comment100052>

    formatting ?



falcon-regression/merlin/src/test/java/org/apache/falcon/regression/RetryTest.java
<https://reviews.apache.org/r/27280/#comment100051>

    formatting ?



falcon-regression/merlin/src/test/java/org/apache/falcon/regression/RetryTest.java
<https://reviews.apache.org/r/27280/#comment100044>

    javadoc ?



falcon-regression/merlin/src/test/java/org/apache/falcon/regression/RetryTest.java
<https://reviews.apache.org/r/27280/#comment100047>

    unit of delayVal ?



falcon-regression/merlin/src/test/java/org/apache/falcon/regression/RetryTest.java
<https://reviews.apache.org/r/27280/#comment100050>

    may be use switch instead of if ?



falcon-regression/merlin/src/test/java/org/apache/falcon/regression/RetryTest.java
<https://reviews.apache.org/r/27280/#comment100049>

    may be use switch instead of if ?



falcon-regression/merlin/src/test/java/org/apache/falcon/regression/RetryTest.java
<https://reviews.apache.org/r/27280/#comment100048>

    Can you please simplify this expression - may be by using temp variables ?


- Raghav Gautam


On Oct. 28, 2014, 6:15 a.m., samarth gupta wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/27280/
> -----------------------------------------------------------
> 
> (Updated Oct. 28, 2014, 6:15 a.m.)
> 
> 
> Review request for Falcon.
> 
> 
> Repository: falcon-git
> 
> 
> Description
> -------
> 
> https://issues.apache.org/jira/browse/FALCON-618
> 
> 
> Diffs
> -----
> 
>   falcon-regression/merlin-core/src/main/java/org/apache/falcon/regression/Entities/FeedMerlin.java
02f572e 
>   falcon-regression/merlin-core/src/main/java/org/apache/falcon/regression/core/enumsAndConstants/MerlinConstants.java
dab5d2c 
>   falcon-regression/merlin-core/src/main/java/org/apache/falcon/regression/core/util/HadoopUtil.java
024a652 
>   falcon-regression/merlin-core/src/main/java/org/apache/falcon/regression/core/util/OSUtil.java
86d4d47 
>   falcon-regression/merlin-core/src/main/java/org/apache/falcon/regression/core/util/OozieUtil.java
c6217c1 
>   falcon-regression/merlin/src/test/java/org/apache/falcon/regression/NewRetryTest.java
d4f31e9 
>   falcon-regression/merlin/src/test/java/org/apache/falcon/regression/ProcessInstanceResumeTest.java
f564bb4 
>   falcon-regression/merlin/src/test/java/org/apache/falcon/regression/ProcessInstanceStatusTest.java
a94cf1a 
>   falcon-regression/merlin/src/test/java/org/apache/falcon/regression/ProcessLateRerunTest.java
3f7258e 
>   falcon-regression/merlin/src/test/java/org/apache/falcon/regression/RetryTest.java
PRE-CREATION 
>   falcon-regression/merlin/src/test/java/org/apache/falcon/regression/prism/PrismFeedUpdateTest.java
9b5d770 
>   falcon-regression/merlin/src/test/resources/RetryTests/valid1/bundle1/process-agg.xml
03cb727 
> 
> Diff: https://reviews.apache.org/r/27280/diff/
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> samarth gupta
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message