falcon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shwetha G S (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FALCON-106) Falcon compilation fails for hadoop-2 profile
Date Fri, 13 Sep 2013 06:35:51 GMT

    [ https://issues.apache.org/jira/browse/FALCON-106?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13766281#comment-13766281
] 

Shwetha G S commented on FALCON-106:
------------------------------------

Installation steps should be updated with how to compile with different hadoop versions to
use -Dhadoop1.version or -Dhadoop2.version. As of now, it says use -Dhadoop.version.

HadoopStartupListener uses value of hadoop.profile to figure out if it has to start JT/TT
or RM/NM. That should be changed since you have removed hadoop.profile property. It can probably
load a hadoop2 class to check which hadoop is used.

                
> Falcon compilation fails for hadoop-2 profile
> ---------------------------------------------
>
>                 Key: FALCON-106
>                 URL: https://issues.apache.org/jira/browse/FALCON-106
>             Project: Falcon
>          Issue Type: Bug
>          Components: build-tools
>            Reporter: Suresh Srinivas
>            Assignee: Suresh Srinivas
>         Attachments: falcon-build-2.x.patch, falcon-build-2.x.v2.patch, falcon-build-2.x.v2.patch,
falcon-build-2.x.v3.patch
>
>
> Mainly due to hadoop-core and hadoop-test artifacts not being available in hadoop 2.x.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message