excalibur-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Petteri R├Ąty <betelge...@gentoo.org>
Subject Re: Minimum JDK version
Date Mon, 26 Feb 2007 22:19:43 GMT
Leif Mortenson wrote:
> Aaron,
>    It sounds like the sun APIs are still supported by Java 6, but will
> probably go away in
> Java 7.  One option is provide two versions of the jar.  One that works
> with 1.3 and
> the other that works with 1.4 and above.
> 
>    Maybe a better option is to require that the jar be built on 1.4 or
> above, but let it
> work on 1.3.   I can do a class existence check on startup and then have
> two copies
> of the image generation based on a static flag.  Breaking those two
> implementations
> into difference classes would make it cleaner.
>      I have done something similar with the Java Service Wrapper.  It
> requires 1.3 or
> above to build, but runs with java 1.2 without some features.
> 
>    Once people are using 1.4 and above, they are not going to need the
> JAI jars.
> 
> Cheers,
> Leif
> 

I am fine with this but please make it possible to build Excalibur
without JAI present via some property for example so then I will not
have to add JAI to dependencies as we only support >=1.4 on Gentoo any way.

Regards,
Petteri


Mime
View raw message