excalibur-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Leif Mortenson <leifli...@tanukisoftware.com>
Subject Re: Minimum JDK version
Date Sun, 25 Feb 2007 06:53:21 GMT
    It sounds like the sun APIs are still supported by Java 6, but will 
probably go away in
Java 7.  One option is provide two versions of the jar.  One that works 
with 1.3 and
the other that works with 1.4 and above.

    Maybe a better option is to require that the jar be built on 1.4 or 
above, but let it
work on 1.3.   I can do a class existence check on startup and then have 
two copies
of the image generation based on a static flag.  Breaking those two 
into difference classes would make it cleaner.
    I have done something similar with the Java Service Wrapper.  It 
requires 1.3 or
above to build, but runs with java 1.2 without some features.

    Once people are using 1.4 and above, they are not going to need the 
JAI jars.


J Aaron Farr wrote:
> Vadim Gritsenko <vadim@reverycodes.com> writes:
>> Leif Mortenson wrote:
>>> Hi all,
>>> I am looking at how best fix bug #EXLBR-34. What is the minimum Java version
>>> that we are currently supporting? Do we still need to support 1.3? Or is
>>> it ok to use 1.4 packages?
>> Hi Leif,
>> Cocoon's maintenance 2.1 branch uses bunch of Excalibur libraries and has a Java
>> 1.3 requirement. Given that fact, I'd guess that Excalibur, de-facto, supports 1.3.
>> Vadim
> I agree that we should keep 1.3 compatibility.  Excalibur is pretty
> stable and I know of installations still using 1.3.
> So is the only solution to add JAI to our list of dependencies?

To unsubscribe, e-mail: dev-unsubscribe@excalibur.apache.org
For additional commands, e-mail: dev-help@excalibur.apache.org

View raw message